summaryrefslogtreecommitdiff
path: root/sci-biology/tree-puzzle/tree-puzzle-5.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-02 11:00:10 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-02 11:00:10 +0000
commit4c506c69909bdb43fda5e36c79b165e404d3b86b (patch)
treeb0f9d49fd462021c82f6ebbbbafb92e1a0eae3da /sci-biology/tree-puzzle/tree-puzzle-5.2.ebuild
parent81f73a84efe20818880d8c52c55a3bd067115b06 (diff)
gentoo auto-resync : 02:12:2023 - 11:00:10
Diffstat (limited to 'sci-biology/tree-puzzle/tree-puzzle-5.2.ebuild')
-rw-r--r--sci-biology/tree-puzzle/tree-puzzle-5.2.ebuild59
1 files changed, 0 insertions, 59 deletions
diff --git a/sci-biology/tree-puzzle/tree-puzzle-5.2.ebuild b/sci-biology/tree-puzzle/tree-puzzle-5.2.ebuild
deleted file mode 100644
index 61e95bb658d5..000000000000
--- a/sci-biology/tree-puzzle/tree-puzzle-5.2.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit autotools
-
-DESCRIPTION="Maximum likelihood analysis for nucleotide, amino acid, and two-state data"
-HOMEPAGE="http://www.tree-puzzle.de"
-SRC_URI="http://www.tree-puzzle.de/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE="mpi"
-RESTRICT="test"
-
-DEPEND="mpi? ( virtual/mpi )"
-RDEPEND="${DEPEND}"
-
-PATCHES=(
- "${FILESDIR}"/${P}-C99-decls.patch
- "${FILESDIR}"/${P}-MPI-3.0.patch
-)
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- default
-
- if ! use mpi; then
- sed \
- -e 's:bin_PROGRAMS = puzzle$(EXEEXT) ppuzzle:bin_PROGRAMS = puzzle :' \
- -e 's:DIST_SOURCES = $(ppuzzle_SOURCES) $(puzzle_SOURCES):DIST_SOURCES = $(puzzle_SOURCES):' \
- -i src/Makefile || die
- fi
-}
-
-src_compile() {
- # hopelessly terrible build system, abuses Automake
- emake -j1
-}
-
-src_install() {
- dobin src/puzzle $(usev mpi src/ppuzzle)
-
- einstalldocs
-
- # User manual
- dodoc doc/tree-puzzle.pdf
-
- # Example data files
- insinto /usr/share/${PN}/data
- rm data/Makefile* || die
- doins -r data/.
-}