summaryrefslogtreecommitdiff
path: root/sci-biology/tree-puzzle
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /sci-biology/tree-puzzle
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'sci-biology/tree-puzzle')
-rw-r--r--sci-biology/tree-puzzle/Manifest2
-rw-r--r--sci-biology/tree-puzzle/tree-puzzle-5.2.ebuild39
2 files changed, 19 insertions, 22 deletions
diff --git a/sci-biology/tree-puzzle/Manifest b/sci-biology/tree-puzzle/Manifest
index 2a82bc13aa0d..4805dbe3df20 100644
--- a/sci-biology/tree-puzzle/Manifest
+++ b/sci-biology/tree-puzzle/Manifest
@@ -1,4 +1,4 @@
AUX tree-puzzle-impl-dec.patch 380 BLAKE2B 22c00e2e0b4682a98212ec0b6e941ac37eff4cdeb8f684dc607e80a1617a35e209d23ac739af0e69af91deb8122fe04c3f9e7bdbd0c54edd8e603a817bdf0848 SHA512 092743fff8a305a41ef55afde3e058c1892d9c608bd05cb87de38a451c2b9cafc7749825347d5c245f1c6b1e84cf9d28b63bd4e7389440da5604766412290110
DIST tree-puzzle-5.2.tar.gz 875142 BLAKE2B aa13e9a7aa403c12aebefb94a1931baa8b17cbee56d20011cb06db5a7b1b7f78c719ed6c6bfb0b79e47dc652d7b984415694907fc6cd56bdbe9eebca4aaa96a8 SHA512 5b9a729b120cba59f59ba426acd439cf396826ea01e75361b23387ccb9baf295d2512f21af96071a5f7b7507db4ff4d6b135cf6c5b6233a8b438532d31abe751
-EBUILD tree-puzzle-5.2.ebuild 1355 BLAKE2B 4d9dd7728bc34b4481d9b63030618b343f6cdec04cf24670be81319c8a9e2e7f7ce42956797dc51da24e1e42e9e5dd7a20be018f027a04f38cb55b850d1c5a34 SHA512 44c268b736aa1769c4b85170094d620bdd12798e8d194d4d991f5a2078641d29a19216bb733636052337b93863dec386b0cf2bc3544401059c566205d6d5fe7d
+EBUILD tree-puzzle-5.2.ebuild 1290 BLAKE2B e02eee43fabed81ca8d164630aa720365eb1cdab5660b878a750138b4dbdda42e3d04da4b0f3f404b45852e26c5ec56f005aa54cedfdf63d4e98718b2f0be145 SHA512 fa04a780ca5680424507123a007856fd442245812b03621efb29215bb8b651d19d5874904a6f4791d446f95f97cee676c2ac33554d4b893ed7068e3ecb70eb1e
MISC metadata.xml 1555 BLAKE2B afe1aecc51f612aad5b1fd991ba020fe15cf5336c0cd521330394ef486a786e088f8a85d0b89944f75557109c56409709e92d62bbde67f8f1f41ef015dcf3bc9 SHA512 d74b3243cb62071c16a1728cb14e4c226644b8116dc032ac2d74a928260a252334583d1867ec3663533f36fa1bb746270f1d33f6fb4bae220af86eba668307b8
diff --git a/sci-biology/tree-puzzle/tree-puzzle-5.2.ebuild b/sci-biology/tree-puzzle/tree-puzzle-5.2.ebuild
index 27dd0bc2212f..8e2a07f8183e 100644
--- a/sci-biology/tree-puzzle/tree-puzzle-5.2.ebuild
+++ b/sci-biology/tree-puzzle/tree-puzzle-5.2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="Maximum likelihood analysis for nucleotide, amino acid, and two-state data"
HOMEPAGE="http://www.tree-puzzle.de"
@@ -13,44 +13,41 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
IUSE="mpi"
+RESTRICT="test"
DEPEND="mpi? ( virtual/mpi )"
RDEPEND="${DEPEND}"
-RESTRICT="test"
-
-pkg_setup () {
- use mpi && [ $(tc-getCC) = icc ] && die "The parallelized version of tree-puzzle cannot be compiled using icc.
- Either disable the \"mpi\" USE flag to compile only the non-parallelized
- version of the program, or use gcc as your compiler (CC=\"gcc\")."
-}
+PATCHES=( "${FILESDIR}"/${PN}-impl-dec.patch )
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-impl-dec.patch
+pkg_setup() {
+ use mpi && [[ $(tc-getCC) == icc* ]] &&
+ die "The parallelized version of tree-puzzle cannot be compiled using icc.
+ Either disable the \"mpi\" USE flag to compile only the non-parallelized
+ version of the program, or use gcc as your compiler (CC=\"gcc\")."
}
src_configure() {
default
if ! use mpi; then
- sed \
- -e 's:bin_PROGRAMS = puzzle$(EXEEXT) ppuzzle:bin_PROGRAMS = puzzle :' \
- -e 's:DIST_SOURCES = $(ppuzzle_SOURCES) $(puzzle_SOURCES):DIST_SOURCES = $(puzzle_SOURCES):' \
- -i "${S}"/src/Makefile || die
+ sed \
+ -e 's:bin_PROGRAMS = puzzle$(EXEEXT) ppuzzle:bin_PROGRAMS = puzzle :' \
+ -e 's:DIST_SOURCES = $(ppuzzle_SOURCES) $(puzzle_SOURCES):DIST_SOURCES = $(puzzle_SOURCES):' \
+ -i src/Makefile || die
fi
}
src_install() {
dobin src/puzzle
use mpi && dobin src/ppuzzle
- dodoc AUTHORS ChangeLog README
+ einstalldocs
# User manual
- insinto /usr/share/doc/${PF}
- doins doc/tree-puzzle.pdf
+ dodoc doc/tree-puzzle.pdf
# Example data files
insinto /usr/share/${PN}/data
- rm data/Makefile*
- doins data/*
+ rm data/Makefile* || die
+ doins -r data/.
}