summaryrefslogtreecommitdiff
path: root/sci-calculators/hexcalc/hexcalc-1.11-r4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-30 15:24:40 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-30 15:24:40 +0100
commit31459e63971ac3b08706bba949851d93c45043c3 (patch)
treef50f9db11363f1369a1aead733baccaf2842b673 /sci-calculators/hexcalc/hexcalc-1.11-r4.ebuild
parenteba9b95ba8976f2938bafa5789c1b50611bb3459 (diff)
gentoo auto-resync : 30:09:2022 - 15:24:40
Diffstat (limited to 'sci-calculators/hexcalc/hexcalc-1.11-r4.ebuild')
-rw-r--r--sci-calculators/hexcalc/hexcalc-1.11-r4.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/sci-calculators/hexcalc/hexcalc-1.11-r4.ebuild b/sci-calculators/hexcalc/hexcalc-1.11-r4.ebuild
new file mode 100644
index 000000000000..20e117cd6853
--- /dev/null
+++ b/sci-calculators/hexcalc/hexcalc-1.11-r4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Simple hex calculator for X"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="mirror://gentoo/${P}.tar.Z"
+S="${WORKDIR}/${PN}"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXaw
+ x11-libs/libXt"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto"
+BDEPEND="
+ app-text/rman
+ sys-devel/gcc
+ >=x11-misc/imake-1.0.8-r1"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-keypad.diff
+ "${FILESDIR}"/${PN}-order.diff
+)
+
+src_configure() {
+ CC="$(tc-getBUILD_CC)" LD="$(tc-getLD)" \
+ IMAKECPP="${IMAKECPP:-${CHOST}-gcc -E}" xmkmf || die
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ CCLINK="$(tc-getCC)" \
+ LDOPTIONS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin ${PN}
+ newman ${PN}.{man,1}
+}