summaryrefslogtreecommitdiff
path: root/sci-calculators/tiemu/tiemu-3.03-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-calculators/tiemu/tiemu-3.03-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-calculators/tiemu/tiemu-3.03-r1.ebuild')
-rw-r--r--sci-calculators/tiemu/tiemu-3.03-r1.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/sci-calculators/tiemu/tiemu-3.03-r1.ebuild b/sci-calculators/tiemu/tiemu-3.03-r1.ebuild
new file mode 100644
index 000000000000..4b7d7fcc4595
--- /dev/null
+++ b/sci-calculators/tiemu/tiemu-3.03-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils
+
+DESCRIPTION="Texas Instruments hand-helds emulator"
+HOMEPAGE="http://lpg.ticalc.org/prj_tiemu/"
+SRC_URI="http://repo.calcforge.org/debian/source/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="dbus nls sdl threads xinerama"
+
+RDEPEND="sci-libs/libticables2
+ sci-libs/libticalcs2
+ sci-libs/libtifiles2
+ sci-libs/libticonv
+ gnome-base/libglade:2.0
+ x11-libs/gtk+:2
+ dbus? ( >=dev-libs/dbus-glib-0.60 )
+ nls? ( virtual/libintl )
+ sdl? ( media-libs/libsdl )
+ xinerama? ( x11-libs/libXinerama )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+ xinerama? ( x11-proto/xineramaproto )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-remove_depreciated_gtk_calls.patch
+ "${FILESDIR}"/${P}-r2820.patch
+)
+
+src_prepare() {
+ default
+ # Don't use GTK_DISABLE_DEPRECATED flags
+ sed 's:-DGTK_DISABLE_DEPRECATED::g' -i configure.ac configure || die
+}
+
+src_configure() {
+ econf \
+ --disable-rpath \
+ --disable-debugger \
+ --disable-gdb \
+ $(use_enable nls) \
+ $(use_enable sdl sound) \
+ $(use_enable threads) \
+ $(use_enable threads threading) \
+ $(use_with dbus) \
+ --without-kde \
+ $(use_with xinerama)
+}
+
+src_install() {
+ default
+ rm -f "${ED%/}"/usr/share/tiemu/{Manpage.txt,COPYING,RELEASE,AUTHORS,LICENSES} || die
+ make_desktop_entry tiemu "TiEmu Calculator" \
+ "${EPREFIX}"/usr/share/tiemu/pixmaps/icon.xpm
+}