summaryrefslogtreecommitdiff
path: root/sci-calculators/wcalc/wcalc-2.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-calculators/wcalc/wcalc-2.5.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-calculators/wcalc/wcalc-2.5.ebuild')
-rw-r--r--sci-calculators/wcalc/wcalc-2.5.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sci-calculators/wcalc/wcalc-2.5.ebuild b/sci-calculators/wcalc/wcalc-2.5.ebuild
new file mode 100644
index 000000000000..9b9a8d8b67a6
--- /dev/null
+++ b/sci-calculators/wcalc/wcalc-2.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils
+
+DESCRIPTION="A flexible command-line scientific calculator"
+HOMEPAGE="http://w-calc.sourceforge.net/"
+SRC_URI="mirror://sourceforge/w-calc/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="readline"
+
+RDEPEND="
+ dev-libs/gmp:0=
+ dev-libs/mpfr:0=
+ readline? ( sys-libs/readline:0= )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf $(use_with readline)
+}
+
+src_install() {
+ default
+
+ # Wcalc icons
+ newicon graphics/w.png wcalc.png
+ newicon graphics/Wred.png wcalc-red.png
+}