summaryrefslogtreecommitdiff
path: root/sci-chemistry/cluster/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-chemistry/cluster/files
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-chemistry/cluster/files')
-rw-r--r--sci-chemistry/cluster/files/1.3.081231-includes.patch12
-rw-r--r--sci-chemistry/cluster/files/1.3.081231-ldflags.patch41
2 files changed, 53 insertions, 0 deletions
diff --git a/sci-chemistry/cluster/files/1.3.081231-includes.patch b/sci-chemistry/cluster/files/1.3.081231-includes.patch
new file mode 100644
index 000000000000..a5586a540a4f
--- /dev/null
+++ b/sci-chemistry/cluster/files/1.3.081231-includes.patch
@@ -0,0 +1,12 @@
+diff --git a/cluster.cpp b/cluster.cpp
+index 0a8c3c1..1384949 100644
+--- a/cluster.cpp
++++ b/cluster.cpp
+@@ -24,6 +24,7 @@
+ #include <iostream>
+ #include <vector>
+ #include <string>
++#include <cstring>
+
+ #include <iostream>
+ #include <fstream>
diff --git a/sci-chemistry/cluster/files/1.3.081231-ldflags.patch b/sci-chemistry/cluster/files/1.3.081231-ldflags.patch
new file mode 100644
index 000000000000..1b99f6d662f2
--- /dev/null
+++ b/sci-chemistry/cluster/files/1.3.081231-ldflags.patch
@@ -0,0 +1,41 @@
+ Makefile | 12 ++++++------
+ 1 files changed, 6 insertions(+), 6 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 7892054..929564b 100644
+--- a/Makefile
++++ b/Makefile
+@@ -3,27 +3,27 @@ PROG_FLGS = -D BOOLPREDEFINED
+
+ SRCS = cluster.cpp DisjointSets.cpp utility.cpp
+
+-CFLAGS = $(OPT) $(DEBUG) $(PROG_FLGS)
++CXXFLAGS += $(OPT) $(DEBUG) $(PROG_FLGS)
+
+ LFLAGS =
+
+ OBJLIST = cluster.o DisjointSets.o utility.o
+
+-CXX = g++
++CXX ?= g++
+
+ .cpp.o:
+- $(CXX) -c $*.cpp $(CFLAGS)
++ $(CXX) $(CXXFLAGS) -c $*.cpp
+
+-OPT = -O3
++OPT =
+ DEBUG = $(CXXDEBUGFLAGS)
+
+ all: cluster
+
+ cluster: $(OBJLIST)
+- $(CXX) -o $@ $(OBJLIST) $(LFLAGS)
++ $(CXX) $(LDFLAGS) -o $@ $(OBJLIST)
+
+ depend:
+- makedepend -- $(CFLAGS) -- $(SRCS)
++ makedepend -- $(CXXFLAGS) -- $(SRCS)
+
+ clean:
+ @rm -rf *.o *.ckp ii_files