summaryrefslogtreecommitdiff
path: root/sci-chemistry/gromacs/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /sci-chemistry/gromacs/files
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'sci-chemistry/gromacs/files')
-rw-r--r--sci-chemistry/gromacs/files/gromacs-2020-pytest.patch35
-rw-r--r--sci-chemistry/gromacs/files/gromacs-2020_beta1-pytest.patch12
-rw-r--r--sci-chemistry/gromacs/files/gromacs-2021-nblib.patch53
3 files changed, 88 insertions, 12 deletions
diff --git a/sci-chemistry/gromacs/files/gromacs-2020-pytest.patch b/sci-chemistry/gromacs/files/gromacs-2020-pytest.patch
new file mode 100644
index 000000000000..cc7730afecb9
--- /dev/null
+++ b/sci-chemistry/gromacs/files/gromacs-2020-pytest.patch
@@ -0,0 +1,35 @@
+From e4e1263776844d660c471e3d1203acf54cdc855f Mon Sep 17 00:00:00 2001
+From: Alexey Shvetsov <alexxyum@gmail.com>
+Date: Fri, 23 Apr 2021 13:21:24 +0300
+Subject: [PATCH 2/2] Allow to build python part without build testing enabled
+
+Signed-off-by: Alexey Shvetsov <alexxyum@gmail.com>
+---
+ python_packaging/src/CMakeLists.txt | 6 ++++--
+ 1 file changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/python_packaging/src/CMakeLists.txt b/python_packaging/src/CMakeLists.txt
+index c75549fc82..4f983fdd5f 100644
+--- a/python_packaging/src/CMakeLists.txt
++++ b/python_packaging/src/CMakeLists.txt
+@@ -1,7 +1,7 @@
+ #
+ # This file is part of the GROMACS molecular simulation package.
+ #
+-# Copyright (c) 2019,2020, by the GROMACS development team, led by
++# Copyright (c) 2019,2020,2021, by the GROMACS development team, led by
+ # Mark Abraham, David van der Spoel, Berk Hess, and Erik Lindahl,
+ # and including many others, as listed in the AUTHORS file in the
+ # top-level source directory and at http://www.gromacs.org.
+@@ -252,5 +252,7 @@ endif()
+ # to the `check` target. Normal usage is to first install the Python package,
+ # then run `pytest` on the `tests` directory. Refer to gmxapi package documentation.
+ if(NOT GMXAPI_MASTER_PROJECT)
+- add_subdirectory(test)
++ if (BUILD_TESTING)
++ add_subdirectory(test)
++ endif()
+ endif()
+--
+2.31.1
+
diff --git a/sci-chemistry/gromacs/files/gromacs-2020_beta1-pytest.patch b/sci-chemistry/gromacs/files/gromacs-2020_beta1-pytest.patch
deleted file mode 100644
index 452987f38b96..000000000000
--- a/sci-chemistry/gromacs/files/gromacs-2020_beta1-pytest.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -urN gromacs-2020-beta1/python_packaging/src/CMakeLists.txt gromacs-2020-beta1-py/python_packaging/src/CMakeLists.txt
---- gromacs-2020-beta1/python_packaging/src/CMakeLists.txt 2019-09-12 05:48:57.000000000 +0300
-+++ gromacs-2020-beta1-py/python_packaging/src/CMakeLists.txt 2019-10-09 17:01:30.845304765 +0300
-@@ -201,5 +201,7 @@
- # to the `check` target. Normal usage is to first install the Python package,
- # then run `pytest` on the `tests` directory. Refer to gmxapi package documentation.
- if(NOT GMXAPI_MASTER_PROJECT)
-- add_subdirectory(test)
-+ if (GMX_BUILD_TESTING)
-+ add_subdirectory(test)
-+ endif()
- endif()
diff --git a/sci-chemistry/gromacs/files/gromacs-2021-nblib.patch b/sci-chemistry/gromacs/files/gromacs-2021-nblib.patch
new file mode 100644
index 000000000000..67ea6f6f63c8
--- /dev/null
+++ b/sci-chemistry/gromacs/files/gromacs-2021-nblib.patch
@@ -0,0 +1,53 @@
+From 5771842a06f483ad52781f4f2cdf5311ddb5cfa1 Mon Sep 17 00:00:00 2001
+From: Alexey Shvetsov <alexxyum@gmail.com>
+Date: Fri, 23 Apr 2021 13:15:10 +0300
+Subject: [PATCH 1/2] Allow to build and install nblib without GMX TESTS
+ enabled
+
+Without it you'll get error like this:
+
+ CMake Error at api/nblib/CMakeLists.txt:79 (add_dependencies):
+ Cannot add target-level dependencies to non-existent target "tests".
+
+ The add_dependencies works for top-level logical targets created by the
+ add_executable, add_library, or add_custom_target commands. If you want to
+ add file-level dependencies see the DEPENDS option of the add_custom_target
+ and add_custom_command commands.
+
+Signed-off-by: Alexey Shvetsov <alexxyum@gmail.com>
+---
+ api/nblib/CMakeLists.txt | 18 ++++++++++--------
+ 1 file changed, 10 insertions(+), 8 deletions(-)
+
+diff --git a/api/nblib/CMakeLists.txt b/api/nblib/CMakeLists.txt
+index a2ce06596e..51211c3d70 100644
+--- a/api/nblib/CMakeLists.txt
++++ b/api/nblib/CMakeLists.txt
+@@ -76,14 +76,16 @@ add_custom_target(nblib-tests
+ )
+ # Ensure that "make tests" builds all nblib tests so the top-level
+ # "make check" will work.
+-add_dependencies(tests nblib-tests)
+-
+-# this allows all nblib tests to be run with "make check-nblib"
+-add_custom_target(check-nblib
+- COMMAND ${CMAKE_CTEST_COMMAND} --output-on-failure -R NbLib
+- COMMENT "Running nblib tests"
+- USES_TERMINAL VERBATIM)
+-add_dependencies(check-nblib nblib-tests)
++if (BUILD_TESTING)
++ add_dependencies(tests nblib-tests)
++
++ # this allows all nblib tests to be run with "make check-nblib"
++ add_custom_target(check-nblib
++ COMMAND ${CMAKE_CTEST_COMMAND} --output-on-failure -R NbLib
++ COMMENT "Running nblib tests"
++ USES_TERMINAL VERBATIM)
++ add_dependencies(check-nblib nblib-tests)
++endif()
+
+ set(NBLIB_MAJOR 0)
+ set(NBLIB_MINOR 1)
+--
+2.31.1
+