summaryrefslogtreecommitdiff
path: root/sci-chemistry/ksdssp/ksdssp-040728-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
commit8b4ace9c50842c5b83401ea7b179dcab940387e1 (patch)
tree230f3135ceaace633cf93e9838b185c4a6664c2e /sci-chemistry/ksdssp/ksdssp-040728-r1.ebuild
parent9ee6d97c2883d42f204a533a8bc1f4562df778fb (diff)
gentoo resync : 23.09.2020
Diffstat (limited to 'sci-chemistry/ksdssp/ksdssp-040728-r1.ebuild')
-rw-r--r--sci-chemistry/ksdssp/ksdssp-040728-r1.ebuild25
1 files changed, 13 insertions, 12 deletions
diff --git a/sci-chemistry/ksdssp/ksdssp-040728-r1.ebuild b/sci-chemistry/ksdssp/ksdssp-040728-r1.ebuild
index b5e9e772743f..118f15c3c2d6 100644
--- a/sci-chemistry/ksdssp/ksdssp-040728-r1.ebuild
+++ b/sci-chemistry/ksdssp/ksdssp-040728-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
inherit toolchain-funcs
@@ -9,19 +9,18 @@ DESCRIPTION="An open source implementation of sci-chemistry/dssp"
HOMEPAGE="http://www.cgl.ucsf.edu/Overview/software.html"
SRC_URI="mirror://gentoo/${P}.shar"
-SLOT="0"
LICENSE="BSD"
+SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE=""
RDEPEND="sci-libs/libpdb++"
-DEPEND="${RDEPEND}
- app-arch/sharutils"
+DEPEND="${RDEPEND}"
+BDEPEND="app-arch/sharutils"
-S="${WORKDIR}"/${PN}
+S="${WORKDIR}/${PN}"
src_unpack() {
- "${EPREFIX}/usr/bin/unshar" "${DISTDIR}"/${A} || die
+ unshar "${DISTDIR}"/${A} || die
}
src_compile() {
@@ -39,8 +38,10 @@ src_compile() {
}
src_install() {
- dobin ${PN}{,.csh}
- dodoc README
- dohtml ${PN}.html
- doman ${PN}.1
+ dobin ksdssp{,.csh}
+
+ HTML_DOCS=( ksdssp.html )
+ einstalldocs
+
+ doman ksdssp.1
}