summaryrefslogtreecommitdiff
path: root/sci-chemistry/molequeue/molequeue-0.9.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /sci-chemistry/molequeue/molequeue-0.9.0-r1.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'sci-chemistry/molequeue/molequeue-0.9.0-r1.ebuild')
-rw-r--r--sci-chemistry/molequeue/molequeue-0.9.0-r1.ebuild12
1 files changed, 8 insertions, 4 deletions
diff --git a/sci-chemistry/molequeue/molequeue-0.9.0-r1.ebuild b/sci-chemistry/molequeue/molequeue-0.9.0-r1.ebuild
index 5c4f667b458d..8901b0f81ce5 100644
--- a/sci-chemistry/molequeue/molequeue-0.9.0-r1.ebuild
+++ b/sci-chemistry/molequeue/molequeue-0.9.0-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..11} )
inherit cmake python-r1 virtualx
@@ -66,9 +66,14 @@ src_configure() {
src_compile() {
if use zeromq; then
- python_foreach_impl run_in_build_dir cmake_src_compile all $(usex doc documentation "")
+ my_src_compile() {
+ run_in_build_dir cmake_src_compile all $(usex doc documentation "")
+ use doc && export HTML_DOCS=( "${BUILD_DIR}"/docs/html/. )
+ }
+ python_foreach_impl my_src_compile
else
cmake_src_compile all $(usex doc documentation "")
+ use doc && export HTML_DOCS=( "${BUILD_DIR}"/docs/html/. )
fi
}
@@ -81,7 +86,6 @@ src_test() {
}
src_install() {
- use doc && local HTML_DOCS=( "${BUILD_DIR}"/docs/html/. )
if use zeromq; then
python_foreach_impl run_in_build_dir cmake_src_install
python_foreach_impl run_in_build_dir python_optimize