summaryrefslogtreecommitdiff
path: root/sci-chemistry/mpqc/mpqc-2.3.1-r4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /sci-chemistry/mpqc/mpqc-2.3.1-r4.ebuild
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'sci-chemistry/mpqc/mpqc-2.3.1-r4.ebuild')
-rw-r--r--sci-chemistry/mpqc/mpqc-2.3.1-r4.ebuild48
1 files changed, 24 insertions, 24 deletions
diff --git a/sci-chemistry/mpqc/mpqc-2.3.1-r4.ebuild b/sci-chemistry/mpqc/mpqc-2.3.1-r4.ebuild
index bdf7bcdcce0a..fc84f06b4f82 100644
--- a/sci-chemistry/mpqc/mpqc-2.3.1-r4.ebuild
+++ b/sci-chemistry/mpqc/mpqc-2.3.1-r4.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit autotools toolchain-funcs
@@ -12,30 +12,31 @@ SRC_URI="mirror://sourceforge/mpqc/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="doc mpi threads static-libs tk"
+IUSE="doc mpi threads tk"
RDEPEND="
virtual/blas
virtual/lapack
mpi? ( virtual/mpi[cxx] )
tk? ( dev-lang/tk:0 )"
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
dev-lang/perl
sys-devel/flex
- sys-apps/sed
virtual/pkgconfig
doc? (
app-doc/doxygen
- media-gfx/graphviz )"
+ media-gfx/graphviz
+ )"
PATCHES=(
- "${FILESDIR}/${P}-as-needed.patch"
- "${FILESDIR}/${P}-respect-ldflags.patch"
- "${FILESDIR}/${P}-test-failure-hack.patch"
- "${FILESDIR}/${P}-blas.patch"
- "${FILESDIR}/${P}-wformat-security.patch"
+ "${FILESDIR}"/${P}-as-needed.patch
+ "${FILESDIR}"/${P}-respect-ldflags.patch
+ "${FILESDIR}"/${P}-test-failure-hack.patch
+ "${FILESDIR}"/${P}-blas.patch
+ "${FILESDIR}"/${P}-wformat-security.patch
+ "${FILESDIR}"/${P}-MPI-3.0.patch
)
-DOCS=(CHANGES CITATION README)
src_prepare() {
# do not install tkmolrender if not requested
@@ -48,7 +49,7 @@ src_prepare() {
|| die "failed to disable tkmolrender"
fi
default
- mv configure.{in,ac} || die
+
eautoreconf
}
@@ -60,40 +61,40 @@ src_configure() {
fi
econf \
+ --enable-shared \
$(use_enable threads) \
- $(use_enable mpi parallel) \
- $(use_enable static-libs static)
+ $(use_enable mpi parallel)
sed \
- -e "s:^CFLAGS =.*$:CFLAGS=${CFLAGS}:" \
- -e "s:^FFLAGS =.*$:FFLAGS=${FFLAGS:- -O2}:" \
- -e "s:^CXXFLAGS =.*$:CXXFLAGS=${CXXFLAGS}:" \
+ -e "s|^CFLAGS =.*$|CFLAGS=${CFLAGS}|" \
+ -e "s|^FFLAGS =.*$|FFLAGS=${FFLAGS:- -O2}|" \
+ -e "s|^CXXFLAGS =.*$|CXXFLAGS=${CXXFLAGS}|" \
-i lib/LocalMakefile || die
}
src_test() {
- cd src/bin/mpqc/validate || die
-
# we'll only run the small test set, since the
# medium and large ones take >10h and >24h on my
# 1.8Ghz P4M
- emake -j1 check1
+ emake -C src/bin/mpqc/validate -j1 check1
}
src_install() {
emake installroot="${D}" install install_devel install_inc
+ dodoc CHANGES CITATION README
# make extended docs
if use doc; then
cd doc || die
emake all
doman man/man1/* man/man3/*
- dodoc -r html/
+ dodoc -r html
fi
+
+ find "${ED}" -name '*.la' -delete || die
}
pkg_postinst() {
- echo
einfo "MPQC can be picky with regard to compilation flags."
einfo "If during mpqc runs you have trouble converging or "
einfo "experience oscillations during SCF interations, "
@@ -101,5 +102,4 @@ pkg_postinst() {
einfo "Particularly, replacing -march=pentium4 by -march=pentium3"
einfo "might help if you encounter problems with correlation "
einfo "consistent basis sets."
- echo
}