summaryrefslogtreecommitdiff
path: root/sci-chemistry/numbat
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /sci-chemistry/numbat
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'sci-chemistry/numbat')
-rw-r--r--sci-chemistry/numbat/Manifest2
-rw-r--r--sci-chemistry/numbat/numbat-0.999-r1.ebuild42
2 files changed, 24 insertions, 20 deletions
diff --git a/sci-chemistry/numbat/Manifest b/sci-chemistry/numbat/Manifest
index 9363cbaa95a8..31c9db303cf6 100644
--- a/sci-chemistry/numbat/Manifest
+++ b/sci-chemistry/numbat/Manifest
@@ -1,4 +1,4 @@
AUX numbat-0.999-gnuplot.patch 2048 BLAKE2B 662ff2337d8a56ba21d1037911dab787ce3faead57a692310e694be4435875c1c7b66a6b756b28c2a2bd8ee29c29b845b794c6f70720c9f7b31810cd8296a083 SHA512 dd646e8f6652a63cb4e1c97830a755629e45d20fa13431f628b66fe8a5062b7bd7ebacddb3dbcca5aeeac3ae0d89f59c61036c1a3639d25fe0426ada77a888bb
DIST Numbat-0.999.tar.gz 1791471 BLAKE2B 7f6536533fdf6bc3860dc1a7c03ade4896e782c5ecadf1c6a7d70896f4c6ef9f0571796c171012497d7b47b3342c215a5302ed210d7dde3ecdbef170c3f55dbc SHA512 0887f77905bbb476b0d12a7015d5d5745023740acc974ea9cd452de7d38a75a92e6090015127588b38ba62353d38c2be20f57be5df3011b51050c4934dfd206c
-EBUILD numbat-0.999-r1.ebuild 1075 BLAKE2B e9ef3bf4ab2b0c751809a4f412e2f44514637a88c0c03cdbb7c47bb554c1d3ac6f6ae1468c0e304db5743dd83239cc300779e5d8c286d54432562cc40ab0c4ef SHA512 28df0153d08c7656c59212ced742ab2d6c8e3eaefaa96c5f62d44beb2e56e39cc60d51a8dc284187e90b3eb57322f7352137908294508b53b13e79e7e0719a30
+EBUILD numbat-0.999-r1.ebuild 1005 BLAKE2B 7f2925f5d97e688fb8e31768523aa6d0c0e4529f9e5b0cf0acc639b5dd96b79d81e65445f79dc63086142192d9aeeab83dc30fb459338803a903cb54379dd041 SHA512 a4e95f3f0d5df19c46ec0a8c2f647258c0a70fba9447f2f669fe86c3437a2026196c1076adce22c6b41fb445c36bdcc382e3801373460e1ca6ce1992f8c6eb63
MISC metadata.xml 852 BLAKE2B 623b64ec229e39a4def8e03c4b69e6268abb2a42f7d2337e71d17da183a0ac99b953e820c2875703dfb5a599229ec94cea9f40a4386563acadb5082a835ff186 SHA512 64e5552a677fc7370f68f7f811734ac17144fcb95e23503c962b678a1678dccf22a2d19991eb69dcdf8d4c1c97448d35d7f34654245ebe3fee8b30a0a8fa586c
diff --git a/sci-chemistry/numbat/numbat-0.999-r1.ebuild b/sci-chemistry/numbat/numbat-0.999-r1.ebuild
index 66f5b2ae0652..766c64b1b9cd 100644
--- a/sci-chemistry/numbat/numbat-0.999-r1.ebuild
+++ b/sci-chemistry/numbat/numbat-0.999-r1.ebuild
@@ -1,52 +1,56 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-AUTOTOOLS_AUTORECONF=true
-
-inherit autotools-utils
+inherit autotools
MY_PN="Numbat"
MY_P="${MY_PN}-${PV}"
-DESCRIPTION="new user-friendly method built for automatic dX-tensor determination"
+DESCRIPTION="New user-friendly method built for automatic dX-tensor determination"
HOMEPAGE="http://www.nmr.chem.uu.nl/~christophe/numbat.html"
SRC_URI="http://comp-bio.anu.edu.au/private/downloads/Numbat/${MY_P}.tar.gz"
+S="${WORKDIR}"/${MY_P}
SLOT="0"
LICENSE="GPL-3"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE=""
-CDEPEND="
+DEPEND="
gnome-base/libglade:2.0
sci-libs/gsl
- x11-libs/gtk+:2"
-DEPEND="${CDEPEND}
- virtual/pkgconfig"
-RDEPEND="${CDEPEND}
+ x11-libs/gtk+:2
+"
+RDEPEND="
+ ${DEPEND}
sci-chemistry/molmol
sci-chemistry/pymol
- sci-visualization/gnuplot"
-
-S="${WORKDIR}"/${MY_P}
+ sci-visualization/gnuplot
+"
+BDEPEND="virtual/pkgconfig"
PATCHES=(
# "${FILESDIR}"/${P}-glade.patch
- "${FILESDIR}"/${P}-gnuplot.patch )
+ "${FILESDIR}"/${P}-gnuplot.patch
+)
src_prepare() {
+ default
+
sed \
-e '/COPYING/d' \
-e "s:doc/numbat:share/doc/${PF}:g" \
-i Makefile.am src/common.h || die
- rm missing
+
+ rm missing || die
+
emake distclean
- autotools-utils_src_prepare
+ eautoreconf
}
src_install() {
docompress -x /usr/share/doc/${PF}
- autotools-utils_src_install
+
+ default
}