summaryrefslogtreecommitdiff
path: root/sci-chemistry/pdbcat/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-chemistry/pdbcat/files
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-chemistry/pdbcat/files')
-rw-r--r--sci-chemistry/pdbcat/files/CMakeLists.txt11
-rw-r--r--sci-chemistry/pdbcat/files/pdbcat-1.3-gcc.patch17
2 files changed, 28 insertions, 0 deletions
diff --git a/sci-chemistry/pdbcat/files/CMakeLists.txt b/sci-chemistry/pdbcat/files/CMakeLists.txt
new file mode 100644
index 000000000000..7a6f348f5929
--- /dev/null
+++ b/sci-chemistry/pdbcat/files/CMakeLists.txt
@@ -0,0 +1,11 @@
+cmake_minimum_required (VERSION 2.6)
+project (pdbcat)
+add_executable(pdbcat
+ Common.C
+ Common.h
+ pdbcat.C
+ PDBData.C
+ PDBData.h)
+
+install (TARGETS pdbcat DESTINATION bin)
+
diff --git a/sci-chemistry/pdbcat/files/pdbcat-1.3-gcc.patch b/sci-chemistry/pdbcat/files/pdbcat-1.3-gcc.patch
new file mode 100644
index 000000000000..b45c36bd8a8d
--- /dev/null
+++ b/sci-chemistry/pdbcat/files/pdbcat-1.3-gcc.patch
@@ -0,0 +1,17 @@
+ pdbcat.C | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/pdbcat.C b/pdbcat.C
+index 0786d9b..387edf9 100644
+--- a/pdbcat.C
++++ b/pdbcat.C
+@@ -17,7 +17,8 @@
+ #include <stdlib.h> // for exit
+ #include <stdio.h> // for feof() and other file manip stuff
+ #include <string.h> // for strcasecmp
+-#include <iostream.h>
++#include <iostream>
++using namespace std;
+ #include "Common.h"
+ #include "PDBData.h"
+