summaryrefslogtreecommitdiff
path: root/sci-chemistry/suitename/suitename-0.3.070628.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-chemistry/suitename/suitename-0.3.070628.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-chemistry/suitename/suitename-0.3.070628.ebuild')
-rw-r--r--sci-chemistry/suitename/suitename-0.3.070628.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sci-chemistry/suitename/suitename-0.3.070628.ebuild b/sci-chemistry/suitename/suitename-0.3.070628.ebuild
new file mode 100644
index 000000000000..e0306fac8f29
--- /dev/null
+++ b/sci-chemistry/suitename/suitename-0.3.070628.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit toolchain-funcs
+
+MY_P="${PN}.${PV}"
+
+DESCRIPTION="The ROC RNA Ontology Consortium consensus RNA backbone nomenclature and conformer-list development"
+HOMEPAGE="http://kinemage.biochem.duke.edu/software/suitename.php"
+SRC_URI="http://kinemage.biochem.duke.edu/downloads/software/${PN}/${MY_P}.src.tgz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="richardson"
+IUSE=""
+
+S="${WORKDIR}"/${MY_P}
+
+src_prepare() {
+ tc-export CC
+ cp Makefile.linux Makefile || die
+ sed \
+ -e 's:cc:${CC}:g' \
+ -e "s:-o:${LDFLAGS} -o:g" \
+ -i Makefile || die
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin ${PN}
+}