summaryrefslogtreecommitdiff
path: root/sci-chemistry/wxmacmolplt/wxmacmolplt-7.5-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-chemistry/wxmacmolplt/wxmacmolplt-7.5-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-chemistry/wxmacmolplt/wxmacmolplt-7.5-r1.ebuild')
-rw-r--r--sci-chemistry/wxmacmolplt/wxmacmolplt-7.5-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/sci-chemistry/wxmacmolplt/wxmacmolplt-7.5-r1.ebuild b/sci-chemistry/wxmacmolplt/wxmacmolplt-7.5-r1.ebuild
new file mode 100644
index 000000000000..17f69a8387ae
--- /dev/null
+++ b/sci-chemistry/wxmacmolplt/wxmacmolplt-7.5-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+WX_GTK_VER=3.0
+
+inherit autotools eutils wxwidgets
+
+DESCRIPTION="Chemical 3D graphics program with GAMESS input builder"
+HOMEPAGE="http://www.scl.ameslab.gov/MacMolPlt/"
+SRC_URI="https://wxmacmolplt.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="flash"
+
+RDEPEND="
+ media-libs/glew:0=
+ media-libs/mesa
+ x11-libs/wxGTK:${WX_GTK_VER}[X,opengl]
+ flash? ( media-libs/ming )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ need-wxwidgets unicode
+ epatch "${FILESDIR}"/${P}-glew.patch
+ sed \
+ -e "/^dist_doc_DATA/d" \
+ -i Makefile.am || die "Failed to disable installation of LICENSE file"
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-glew \
+ $(use_with flash ming)
+}
+
+src_install() {
+ default
+ doicon resources/${PN}.png
+ make_desktop_entry ${PN} wxMacMolPlt ${PN} "Science;DataVisualization;"
+}