summaryrefslogtreecommitdiff
path: root/sci-electronics/ghdl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-03-09 01:48:35 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-03-09 01:48:35 +0000
commit0b832a429ecd6081aa9faa0eb262303b019d87ea (patch)
treec39bb9eaa7bc30cec17f3a3bdef0cf5ed27c6a75 /sci-electronics/ghdl
parent80e87db4d9ed551615eb2d0309bf370e79500716 (diff)
gentoo auto-resync : 09:03:2025 - 01:48:35
Diffstat (limited to 'sci-electronics/ghdl')
-rw-r--r--sci-electronics/ghdl/Manifest2
-rw-r--r--sci-electronics/ghdl/ghdl-5.0.1.ebuild100
2 files changed, 102 insertions, 0 deletions
diff --git a/sci-electronics/ghdl/Manifest b/sci-electronics/ghdl/Manifest
index 6783bfb17bd2..f6bbd60a3879 100644
--- a/sci-electronics/ghdl/Manifest
+++ b/sci-electronics/ghdl/Manifest
@@ -1,4 +1,6 @@
AUX ghdl-4.0.0_pre20231218-no-pyunit.patch 689 BLAKE2B 2df3df07e290240b2e99422fda33d2ccee9f01a5f3c3aa3535e40ab66bf5de95cbef3821a3e31b0f36b82f5bc90e078e9d2f9424ea5226f7c671ce4dec571458 SHA512 9149bb90346b0c97683a4ed7056cecb727f4ff9a5b89f8b4046983475cd40937f363438129304c72199442bcc3ad948f2c86cb38b6bd0d314dba9199f34a37a6
DIST ghdl-4.1.0.tar.gz 7704716 BLAKE2B d69791d947ed11b62fac8e076c3b9e1bad606a0de57e8d5bd67c9a8f7ea0cad73643085efbaaa06fabdd5900366334b63385589da72f4db488f5b27b142a76f8 SHA512 0a3a465f7f8ed7fba9b81b5dec2903bf82731c97a127666e7644286c9ea80078354be4e6bf8947a6ef631b646dc7e8e69dce2d9a467ac36ee03c67d9335a2703
+DIST ghdl-5.0.1.tar.gz 7851730 BLAKE2B 110f17e7891a4e89aaa27e763f1f8c0354bd6054641b1a17c1f037b5b07a573781c36a3657a0501252b76c03e63f485f2099fcee59ef451aab17939cdd20a222 SHA512 c07dab30b779f0dd424e588b66d32351bdfcc9cab6da5bb5ea85c477083bda6a0f99c2301e55bb2c285d7765911a0fc0b0c8079933b1abdda553d126f2e58400
EBUILD ghdl-4.1.0-r1.ebuild 1749 BLAKE2B e7737ba8f156ec920d63371c3b8cdf2a276a434833fa0a929e00a6915a780daa5e59cb6065982a41c41587b8ec902378e8266aaf9b53c7295589dbb389cbba18 SHA512 e31e5618327bc7cfa35b0947b9b0d0dd1a97d43955b5a3bd60f221f6542396f459365d59432b4c63178e5e48035ca33fbe9cf960d24646e9b5e8016fba89c923
+EBUILD ghdl-5.0.1.ebuild 1734 BLAKE2B 9abbcd81b6eaf2fd9f997c35552ec2b8f8200f5441b08330b923e2a07ee219e4967ee56f4cf4c01d66322a8182cd3ef898fc54f01830ad4e86d27e4c5e0350d0 SHA512 30b623a8c55d9d1140b8793ec6e444eae79be35af78ca5fa7871d66d6f99a4e79aa4613b8de663c36d0af028501c2ca019f395b381ce2b07a546d1ce26ccc727
MISC metadata.xml 1462 BLAKE2B a403ab50a3463fc26ddfb6ad65aa2cfe9782e98b74cd91fe24ef81678e7c52a2211b0bcad27accc4cd57db281ed23ad5d8697ae69dd8b67c623465949d6d3434 SHA512 4bd4c20a8fbbdaa80a63373f81bd96144e110371403832627aba81a7a95d073ee73922516a6d5c193898affbeb8bd7f1ce9fc4203faa13464cf39ba809c82d5d
diff --git a/sci-electronics/ghdl/ghdl-5.0.1.ebuild b/sci-electronics/ghdl/ghdl-5.0.1.ebuild
new file mode 100644
index 000000000000..741bd0ca7663
--- /dev/null
+++ b/sci-electronics/ghdl/ghdl-5.0.1.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ADA_COMPAT=( gcc_14 )
+LLVM_COMPAT=( {18..19} ) # Check configure script for supported LLVM versions.
+
+inherit ada edo llvm-r1 toolchain-funcs
+
+DESCRIPTION="Open-source analyzer, compiler, and simulator for VHDL 2008/93/87"
+HOMEPAGE="https://ghdl.github.io/ghdl/
+ https://github.com/ghdl/ghdl/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/ghdl/${PN}.git"
+else
+ SRC_URI="https://github.com/ghdl/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="llvm +static-libs"
+
+# The LLVM backend requires static libraries to work, see bug: https://bugs.gentoo.org/938171
+REQUIRED_USE="${ADA_REQUIRED_USE} llvm? ( static-libs )"
+
+RDEPEND="
+ ${ADA_DEPS}
+ llvm? (
+ $(llvm_gen_dep '
+ llvm-core/llvm:${LLVM_SLOT}=
+ ')
+ )
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ dev-util/patchelf
+"
+
+PATCHES=( "${FILESDIR}/${PN}-4.0.0_pre20231218-no-pyunit.patch" )
+
+pkg_setup() {
+ ada_pkg_setup
+
+ use llvm && llvm-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ sed -i "s|ar rc|$(tc-getAR) rc|g" Makefile.in || die
+}
+
+src_configure() {
+ tc-export CC CXX
+
+ local -a myconf=(
+ # Build.
+ --disable-werror
+
+ # Install location.
+ --libdir=$(get_libdir)
+ --prefix="/usr"
+
+ # Features.
+ --enable-libghdl
+ --enable-synth
+ )
+
+ if use llvm ; then
+ myconf+=(
+ --with-llvm-config="llvm-config"
+ )
+ fi
+
+ # Not a autotools script!
+ edo sh ./configure "${myconf[@]}"
+}
+
+src_compile() {
+ default
+
+ patchelf --set-soname libghw.so lib/libghw.so || die
+}
+
+src_install() {
+ default
+
+ if ! use static-libs ; then
+ find "${ED}" -type f -name '*.a' -delete || die
+ fi
+}