summaryrefslogtreecommitdiff
path: root/sci-geosciences/librttopo/librttopo-1.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-12 16:41:52 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-12 16:41:52 +0100
commitd4de2b287be5b8553180509934fd44ef3d7fce3c (patch)
treea12a5c99efcbae7b7d052e2f8ad1adf8caf638e1 /sci-geosciences/librttopo/librttopo-1.1.0.ebuild
parentfc1125ea4b3373e327ba0e157daa1d7e8aee15f9 (diff)
gentoo auto-resync : 12:09:2023 - 16:41:52
Diffstat (limited to 'sci-geosciences/librttopo/librttopo-1.1.0.ebuild')
-rw-r--r--sci-geosciences/librttopo/librttopo-1.1.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sci-geosciences/librttopo/librttopo-1.1.0.ebuild b/sci-geosciences/librttopo/librttopo-1.1.0.ebuild
new file mode 100644
index 000000000000..09e3dd82391a
--- /dev/null
+++ b/sci-geosciences/librttopo/librttopo-1.1.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Exposes an API to create and manage standard (ISO 13249 aka SQL/MM) topologies"
+HOMEPAGE="https://git.osgeo.org/gitea/rttopo/librttopo"
+SRC_URI="https://git.osgeo.org/gitea/rttopo/librttopo/archive/${P}.tar.gz"
+S="${WORKDIR}/librttopo"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="sci-libs/geos"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}