summaryrefslogtreecommitdiff
path: root/sci-geosciences/routino
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-20 19:08:44 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-20 19:08:44 +0100
commit6b89cba67f554b60d139fd07623aef5cc724ec91 (patch)
tree876c06b4840a2ed6bff1771d124049d9bfff55b1 /sci-geosciences/routino
parent30114ae8ef07a32fea1e44a10b61f98c84142645 (diff)
gentoo auto-resync : 20:07:2023 - 19:08:44
Diffstat (limited to 'sci-geosciences/routino')
-rw-r--r--sci-geosciences/routino/Manifest2
-rw-r--r--sci-geosciences/routino/routino-3.4.1.ebuild84
2 files changed, 86 insertions, 0 deletions
diff --git a/sci-geosciences/routino/Manifest b/sci-geosciences/routino/Manifest
index f5c38c40eb53..9e61f3018c67 100644
--- a/sci-geosciences/routino/Manifest
+++ b/sci-geosciences/routino/Manifest
@@ -1,4 +1,6 @@
AUX routino-3.3.2.patch 1771 BLAKE2B a40ebca2cbc81f479eca69222e679a1abef4c42bd3db8417bd8bcc62c8d15a5ed2f43ae8b55e56870ca037b98de2c424f258d139dff11c0128ac60940f09ace6 SHA512 52cbd47e68b25a7c735d32a4bb51436ea45867cdb9f86bc3a55304674b80d33dcc41f845527659db345e118f2f56036a2265a98a177744b4cb1029c7a18e202e
DIST routino-3.3.3.tgz 2564198 BLAKE2B 0476e4afb2279c6a93b3d5192a1be580b0ee20fe07b5101c7d590bd3b74873e0205549c2fa621c6444eea0dd0cf0545c9fc054454e04f434d3e57ed750b1df3d SHA512 b037f6ef38b3abef4639d639c3564b42adc742d225108905d0cacb790e4a07593245c537b5550c43874cd6083f37b710b7aec02a0b0669c927804cf30ce34386
+DIST routino-3.4.1.tgz 2591859 BLAKE2B cdc2018cb735c190258c9f4ebf09ad14d27923fcc520b3c58fb910e63d93e280bbad345ca1c82b31284827cf914f5da45b8f5a69c9ac1721b3f056dfd9d2e918 SHA512 c9e6dea5c60a265f7a5c7217711d2c880f201d1102740d756e10f731ace785a7afd7b84cdfb8485ee3af58b5a0f1b0e8e273dab1deedd319b27c77d400b30baa
EBUILD routino-3.3.3-r4.ebuild 1653 BLAKE2B 816fc0fd22080103c441d068b25a2800551590f2b3fec8aec09ef735b2665b5b2bf7e60808a9aec1f982969450072b0467ec07a6cee054550716307cfbbcfd69 SHA512 a5d22cfba38e2b2ddd2c0669980a28a8b84b223a2a1fc237b02a70f8e4e38989a6bb4719145f5b89b2b5132493b572655882d4c4f4922989f8a80e180ad69afd
+EBUILD routino-3.4.1.ebuild 1654 BLAKE2B 85a3fe0439c1dfc818ed9a8ed9d1a5b5ccfcd3ec527021dbeab4f4da4951d228a8b7ac14e3db4b0ed6747301615f4fe3dc8d68c8d3152a7b1dfe6e8f88056f7d SHA512 e8af2ae31e1fc19a335918118dd50d5cf30d554fc8f6d7c96829222170e95e32a8226e1b67f2da42de49b2fdf4243c5c263131e0edcad2c4bfb84497097ac863
MISC metadata.xml 894 BLAKE2B e9854b11005fdab70046e42a963c65a4e921f2d05572c4591e0ee581316a8ba3d3a5a0df39cf2aa500b1a89bde29fd1aaa459962abb68fdc71b49abd9681db54 SHA512 1397fb38a051f523925f04ab1d77044f2bbbcb2957a724696b54d6c057d49d67e758ae3d5b3c925fbce95f35e95c8b3a191724021bb82d4aa35ea61bc2c2153a
diff --git a/sci-geosciences/routino/routino-3.4.1.ebuild b/sci-geosciences/routino/routino-3.4.1.ebuild
new file mode 100644
index 000000000000..3a03984a6ad0
--- /dev/null
+++ b/sci-geosciences/routino/routino-3.4.1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit toolchain-funcs distutils-r1
+
+DESCRIPTION="Routing application based on openstreetmap data"
+HOMEPAGE="https://routino.org/"
+SRC_URI="https://routino.org/download/${P}.tgz"
+
+LICENSE="AGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="python test"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ python? (
+ ${PYTHON_DEPS}
+ dev-lang/swig[pcre]
+ )
+"
+RDEPEND="python? ( ${PYTHON_DEPS} )"
+
+PATCHES=( "${FILESDIR}"/${PN}-3.3.2.patch )
+
+src_prepare() {
+ default
+
+ sed -i -e "s@libdir=\(.*\)@libdir=\$(prefix)/$(get_libdir)@" \
+ -e "s@CC=gcc@CC=$(tc-getCC)@" \
+ -e "s@LD=gcc@LD=$(tc-getCC)@" \
+ Makefile.conf || die "failed sed"
+}
+
+src_compile() {
+ emake -j1
+
+ rm README.txt || die "rm README.txt failed"
+ mv doc/README.txt . || die "mv doc/README.txt . failed"
+
+ if use python; then
+ pushd python > /dev/null || die
+ distutils-r1_src_compile
+ popd > /dev/null || die
+ fi
+}
+
+python_compile() {
+ rm -f build/.timestamp || die
+ emake PYTHON=${EPYTHON} src/_router.c src/_database.cc || die
+ distutils-r1_python_compile
+}
+
+src_test() {
+ emake test
+
+ # Need to fix import issues with these
+ #if use python; then
+ # pushd python > /dev/null || die
+ # distutils-r1_src_test
+ # popd > /dev/null || die
+ #fi
+}
+
+python_test() {
+ emake PYTHON=${EPYTHON} test
+}
+
+src_install() {
+ default
+
+ if use python; then
+ pushd python > /dev/null || die
+ distutils-r1_src_install
+ newdoc README.txt README_python.txt
+ popd > /dev/null || die
+ fi
+}