summaryrefslogtreecommitdiff
path: root/sci-geosciences
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-02-19 00:15:15 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-02-19 00:15:15 +0000
commit2e512e4e32285f8c4eb19586d014cb9d31454ec9 (patch)
treee5884cadbd260c6936495a63b92f4503d54e5428 /sci-geosciences
parent5264c18a325553759d67fb4e059db03cf3fc5c81 (diff)
gentoo auto-resync : 19:02:2025 - 00:15:15
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/Manifest.gzbin7707 -> 7704 bytes
-rw-r--r--sci-geosciences/osmctools/Manifest3
-rw-r--r--sci-geosciences/osmctools/files/osmctools-0.9-gcc15.patch56
-rw-r--r--sci-geosciences/osmctools/osmctools-0.9-r2.ebuild4
4 files changed, 61 insertions, 2 deletions
diff --git a/sci-geosciences/Manifest.gz b/sci-geosciences/Manifest.gz
index 8e3c9f779232..6e71bcf36f46 100644
--- a/sci-geosciences/Manifest.gz
+++ b/sci-geosciences/Manifest.gz
Binary files differ
diff --git a/sci-geosciences/osmctools/Manifest b/sci-geosciences/osmctools/Manifest
index 168d556c3d5e..8bf48bd7d101 100644
--- a/sci-geosciences/osmctools/Manifest
+++ b/sci-geosciences/osmctools/Manifest
@@ -1,3 +1,4 @@
+AUX osmctools-0.9-gcc15.patch 1350 BLAKE2B fcf28ffda922c782e7d105d8d49cbd31dca5763c542695ee83b78ce006da6e5218c62495a241367e64c63da15997fd6ee0cb3af270a06d846e5f55002a7c472f SHA512 a594c65c5c272c81572654b95a370ecea97e641b04c860ab8d225554f17b99e85a15c05a31c98ad098f4522b0b3412ffe9e6fa130e471baf6a81eda181975345
DIST osmctools-0.9.tar.bz2 127337 BLAKE2B c31596e2465d299b11637664e994177072b4cec4ee83c2043a45251d5a097f7215f55dde5d92bfc0fbe9f1816a7906e5bbe30b17ef752a65ba1a4243ca86ed06 SHA512 6b7068796e15d31c8bab5016ed7245d161889d84cf88566ffa71c145b7d93c428b3b83232098b6283b651e7dad4a761fd1ccdebc14c95617f23598cc3281e4a6
-EBUILD osmctools-0.9-r2.ebuild 468 BLAKE2B efb36a79cbdfb1439a864d9d702606a07611bb185fa7ddbbc97201bb5f45998fe193421e400e91c70583d78d9d4f22ab610a6adc63c64b0f6dc83ab61efec18a SHA512 2b8f2b7a95018f7b11e024b0624a8e5323d70ca547a990bcc1163289ab8b8f4487ec9966aa4a9f58c58cbdfb0d073ceb1b40c02042bcba76d2ec364086da6e39
+EBUILD osmctools-0.9-r2.ebuild 517 BLAKE2B d5ddb0a605e8480f1d0bc0e35b86ac3019068466871accb922c1b5a3ce85342d88c75f23227ae15d4408d4d9db163b09ed5cb1e51d7737e65349348258664a11 SHA512 25cad23baa6c9161c75d19fe22a62ec6d031dc6c47f3a378eafd17db8048e6196c30fba7638d94ac4125f2a1812d49fb2a7ed2491cf7eed3356f401b976a12ca
MISC metadata.xml 586 BLAKE2B ef415e4141e2e71a96a85cc1f18781b2ef9c62ffe6c8f489898c74f6ae3081d55228175b96d434ac47159d0dc5898b420aa0dfcf4a32bbb0ef1c5fbf3e8a5089 SHA512 a268d7e3406bbc95bc090e13d99e4a08346184ffd260791d2b8dddeae22fefa79aeee6346239833b8b66d9533da726ad82d8cbb3af3ba624403fef9d70446531
diff --git a/sci-geosciences/osmctools/files/osmctools-0.9-gcc15.patch b/sci-geosciences/osmctools/files/osmctools-0.9-gcc15.patch
new file mode 100644
index 000000000000..a8a4f2a693c2
--- /dev/null
+++ b/sci-geosciences/osmctools/files/osmctools-0.9-gcc15.patch
@@ -0,0 +1,56 @@
+diff -durN a/src/osmconvert.c b/src/osmconvert.c
+--- a/src/osmconvert.c
++++ b/src/osmconvert.c
+@@ -464,6 +464,7 @@
+ #include <stdlib.h>
+ #include <string.h>
+ #include <stdio.h>
++#include <stdbool.h>
+ #include <locale.h>
+ #include <time.h>
+ #include <ctype.h>
+@@ -471,7 +472,6 @@
+ #include <fcntl.h>
+ #include <signal.h>
+
+-typedef enum {false= 0,true= 1} bool;
+ typedef uint8_t byte;
+ typedef unsigned int uint;
+ #define isdig(x) isdigit((unsigned char)(x))
+diff -durN a/src/osmfilter.c b/src/osmfilter.c
+--- a/src/osmfilter.c
++++ b/src/osmfilter.c
+@@ -377,13 +377,13 @@
+ #include <stdlib.h>
+ #include <string.h>
+ #include <stdio.h>
++#include <stdbool.h>
+ #include <time.h>
+ #include <ctype.h>
+ #include <unistd.h>
+ #include <fcntl.h>
+ #include <signal.h>
+
+-typedef enum {false= 0,true= 1} bool;
+ typedef uint8_t byte;
+ typedef unsigned int uint;
+ #define isdig(x) isdigit((unsigned char)(x))
+diff -durN a/src/osmupdate.c b/src/osmupdate.c
+--- a/src/osmupdate.c
++++ b/src/osmupdate.c
+@@ -172,6 +172,7 @@
+ #include <stdlib.h>
+ #include <string.h>
+ #include <stdio.h>
++#include <stdbool.h>
+ #include <errno.h>
+ #include <time.h>
+ #include <ctype.h>
+@@ -180,7 +181,6 @@
+ #include <signal.h>
+ #include <sys/stat.h>
+
+-typedef enum {false= 0,true= 1} bool;
+ typedef uint8_t byte;
+ typedef unsigned int uint;
+ #define isdig(x) isdigit((unsigned char)(x))
diff --git a/sci-geosciences/osmctools/osmctools-0.9-r2.ebuild b/sci-geosciences/osmctools/osmctools-0.9-r2.ebuild
index e096bec36d61..7fbb789ed233 100644
--- a/sci-geosciences/osmctools/osmctools-0.9-r2.ebuild
+++ b/sci-geosciences/osmctools/osmctools-0.9-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -16,6 +16,8 @@ KEYWORDS="amd64 ~x86"
DEPEND="sys-libs/zlib"
RDEPEND="${DEPEND}"
+PATCHES=( "${FILESDIR}/${PN}-0.9-gcc15.patch" )
+
src_prepare() {
default