summaryrefslogtreecommitdiff
path: root/sci-libs/alglib/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-15 17:37:09 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-15 17:37:09 +0100
commit586819755b4dbfdffdc8a725ab7c0f86095b8489 (patch)
treed6790c838cfe9607c996e4913fdf11bad5fdd528 /sci-libs/alglib/files
parent3f71901f8c228f4de570abed1831ce3ee425343e (diff)
gentoo resync : 15.09.2018
Diffstat (limited to 'sci-libs/alglib/files')
-rw-r--r--sci-libs/alglib/files/CMakeLists.txt32
-rw-r--r--sci-libs/alglib/files/alglib-3.10.0-disable-minlm-test.patch16
2 files changed, 16 insertions, 32 deletions
diff --git a/sci-libs/alglib/files/CMakeLists.txt b/sci-libs/alglib/files/CMakeLists.txt
deleted file mode 100644
index 6455423b0fe9..000000000000
--- a/sci-libs/alglib/files/CMakeLists.txt
+++ /dev/null
@@ -1,32 +0,0 @@
-project(alglib CXX)
-cmake_minimum_required(VERSION 2.8)
-
-INCLUDE(GNUInstallDirs)
-INCLUDE_DIRECTORIES(${CMAKE_SOURCE_DIR}/src)
-SET(VERSION 3.7.0)
-SET(SOVERSION 3.7)
-
-FILE(GLOB ALGLIB_SRC_LIB "src/*.cpp")
-FILE(GLOB ALGLIB_HDR_LIB "src/*.h")
-
-ADD_LIBRARY(alglib SHARED ${ALGLIB_SRC_LIB})
-SET_TARGET_PROPERTIES(alglib PROPERTIES
- VERSION ${VERSION}
- SOVERSION ${SOVERSION})
-
-INSTALL(TARGETS alglib DESTINATION ${CMAKE_INSTALL_LIBDIR}/)
-INSTALL(FILES ${ALGLIB_HDR_LIB} DESTINATION ${CMAKE_INSTALL_INCLUDEDIR})
-
-#===========================================================
-ADD_EXECUTABLE(test_c tests/test_c.cpp)
-TARGET_LINK_LIBRARIES(test_c alglib)
-#INSTALL(TARGETS test_c DESTINATION ${CMAKE_INSTALL_BINDIR}/)
-#===========================================================
-ADD_EXECUTABLE(test_i tests/test_i.cpp)
-TARGET_LINK_LIBRARIES(test_i alglib)
-#INSTALL(TARGETS test_i DESTINATION ${CMAKE_INSTALL_BINDIR}/)
-#===========================================================
-
-enable_testing()
-add_test( test_c ${CMAKE_BUILD_DIR}/test_c)
-add_test( test_i ${CMAKE_BUILD_DIR}/test_i)
diff --git a/sci-libs/alglib/files/alglib-3.10.0-disable-minlm-test.patch b/sci-libs/alglib/files/alglib-3.10.0-disable-minlm-test.patch
new file mode 100644
index 000000000000..fc2dfae6c012
--- /dev/null
+++ b/sci-libs/alglib/files/alglib-3.10.0-disable-minlm-test.patch
@@ -0,0 +1,16 @@
+Description: disable minlm test, because it fails sometimes on some platforms.
+Author: Anton Gladky <gladk@debian.org>
+Last-Update: 2015-05-29
+
+Index: cpp/tests/test_c.cpp
+===================================================================
+--- cpp.orig/tests/test_c.cpp
++++ cpp/tests/test_c.cpp
+@@ -93354,7 +93354,6 @@ _s_testrecord unittests[] =
+ {"spline1d",testspline1d,_pexec_testspline1d},
+ {"normestimator",testnormestimator,_pexec_testnormestimator},
+ {"minqp",testminqp,_pexec_testminqp},
+- {"minlm",testminlm,_pexec_testminlm},
+ {"lsfit",testlsfit,_pexec_testlsfit},
+ {"parametric",testparametric,_pexec_testparametric},
+ {"linlsqr",testlinlsqr,_pexec_testlinlsqr},