summaryrefslogtreecommitdiff
path: root/sci-libs/buddy/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-libs/buddy/files
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-libs/buddy/files')
-rw-r--r--sci-libs/buddy/files/buddy-2.4-gcc43.patch22
-rw-r--r--sci-libs/buddy/files/buddy-2.4-gold.patch16
2 files changed, 38 insertions, 0 deletions
diff --git a/sci-libs/buddy/files/buddy-2.4-gcc43.patch b/sci-libs/buddy/files/buddy-2.4-gcc43.patch
new file mode 100644
index 000000000000..c7b9f85688eb
--- /dev/null
+++ b/sci-libs/buddy/files/buddy-2.4-gcc43.patch
@@ -0,0 +1,22 @@
+diff -Naurp buddy-2.4-orig/src/bddtest.cxx buddy-2.4/src/bddtest.cxx
+--- buddy-2.4-orig/src/bddtest.cxx 2004-06-25 07:22:26.000000000 -0600
++++ buddy-2.4/src/bddtest.cxx 2009-02-09 22:14:19.000000000 -0600
+@@ -28,6 +28,7 @@
+ ========================================================================*/
+
+ #include <string>
++#include <cstdlib>
+ #include "bdd.h"
+ #include "bvec.h"
+
+diff -Naurp buddy-2.4-orig/examples/bddcalc/parser_.h buddy-2.4/examples/bddcalc/parser_.h
+--- buddy-2.4-orig/examples/bddcalc/parser_.h 2004-06-25 07:21:43.000000000 -0600
++++ buddy-2.4/examples/bddcalc/parser_.h 2009-02-09 22:21:09.000000000 -0600
+@@ -9,6 +9,7 @@
+ #define _PARSER_H
+
+ #include <stdio.h>
++#include <stdlib.h>
+ #include "bdd.h"
+
+ #define MAXIDLEN 32 /* Max. number of allowed characters in an identifier */
diff --git a/sci-libs/buddy/files/buddy-2.4-gold.patch b/sci-libs/buddy/files/buddy-2.4-gold.patch
new file mode 100644
index 000000000000..dc30a642141d
--- /dev/null
+++ b/sci-libs/buddy/files/buddy-2.4-gold.patch
@@ -0,0 +1,16 @@
+ examples/cmilner/Makefile.in | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/examples/cmilner/Makefile.in b/examples/cmilner/Makefile.in
+index 9b49e9d..f7a9b8a 100644
+--- a/examples/cmilner/Makefile.in
++++ b/examples/cmilner/Makefile.in
+@@ -217,7 +217,7 @@ clean-checkPROGRAMS:
+ done
+ cmilner$(EXEEXT): $(cmilner_OBJECTS) $(cmilner_DEPENDENCIES)
+ @rm -f cmilner$(EXEEXT)
+- $(LINK) $(cmilner_LDFLAGS) $(cmilner_OBJECTS) $(cmilner_LDADD) $(LIBS)
++ $(LINK) $(cmilner_LDFLAGS) $(cmilner_OBJECTS) $(cmilner_LDADD) $(LIBS) -lm
+
+ mostlyclean-compile:
+ -rm -f *.$(OBJEXT)