summaryrefslogtreecommitdiff
path: root/sci-libs/cantera/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-30 14:58:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-30 14:58:12 +0000
commit268511f85b0606dd23fda1991345568dd3e1976b (patch)
tree6db33fa4a4774e1e23c22fb636b6d8717f28f2c8 /sci-libs/cantera/files
parent552fc3ba95eab5c2c1a8b2b55ab432a1019739a0 (diff)
gentoo auto-resync : 30:01:2023 - 14:58:12
Diffstat (limited to 'sci-libs/cantera/files')
-rw-r--r--sci-libs/cantera/files/cantera-2.5.1_env.patch130
-rw-r--r--sci-libs/cantera/files/cantera-2.6.0_drop_deprecated_open_U_option.patch49
2 files changed, 49 insertions, 130 deletions
diff --git a/sci-libs/cantera/files/cantera-2.5.1_env.patch b/sci-libs/cantera/files/cantera-2.5.1_env.patch
deleted file mode 100644
index 77004803b127..000000000000
--- a/sci-libs/cantera/files/cantera-2.5.1_env.patch
+++ /dev/null
@@ -1,130 +0,0 @@
-diff -Naur old/SConstruct new/SConstruct
---- old/SConstruct 2021-03-21 01:18:43.000000000 +0300
-+++ new/SConstruct 2021-03-21 01:27:06.000000000 +0300
-@@ -193,7 +193,7 @@
- toolchain = ['default']
-
- env = Environment(tools=toolchain+['textfile', 'subst', 'recursiveInstall', 'wix', 'gch'],
-- ENV={'PATH': os.environ['PATH']},
-+ ENV={'PATH': os.environ['PATH'], 'CCACHE_DIR': os.environ.get('CCACHE_DIR','')},
- toolchain=toolchain,
- **extraEnvArgs)
-
-@@ -239,6 +239,9 @@
- sys.exit(1)
-
- compiler_options = [
-+ ('AR',
-+ """The archiver to use.""",
-+ env['AR']),
- ('CXX',
- """The C++ compiler to use.""",
- env['CXX']),
-@@ -734,10 +734,7 @@
- env['cantera_pure_version'] = re.match(r'(\d+\.\d+\.\d+)', env['cantera_version']).group(0)
- env['cantera_short_version'] = re.match(r'(\d+\.\d+)', env['cantera_version']).group(0)
-
--try:
-- env['git_commit'] = getCommandOutput('git', 'rev-parse', '--short', 'HEAD')
--except Exception:
-- env['git_commit'] = 'unknown'
-+env['git_commit'] = 'unknown'
-
- # Print values of all build options:
- print("Configuration variables read from 'cantera.conf' and command line:")
-@@ -1149,10 +1149,24 @@
- if retcode == 0:
- config_error("Failed to determine Sundials BLAS/LAPACK.")
- env['has_sundials_lapack'] = int(has_sundials_lapack.strip())
-- else:
-- # In Sundials 2.6, SUNDIALS_BLAS_LAPACK is either defined or undefined
-+ elif sundials_ver < parse_version('5.5'):
-+ # In Sundials 2.6-5.5, SUNDIALS_BLAS_LAPACK is either defined or undefined
- env['has_sundials_lapack'] = conf.CheckDeclaration('SUNDIALS_BLAS_LAPACK',
- '#include "sundials/sundials_config.h"', 'C++')
-+ else:
-+ # In Sundials 5.5 and higher, two defines are included specific to the
-+ # SUNLINSOL packages indicating whether SUNDIALS has been built with LAPACK
-+ lapackband = conf.CheckDeclaration(
-+ "SUNDIALS_SUNLINSOL_LAPACKBAND",
-+ '#include "sundials/sundials_config.h"',
-+ "C++",
-+ )
-+ lapackdense = conf.CheckDeclaration(
-+ "SUNDIALS_SUNLINSOL_LAPACKDENSE",
-+ '#include "sundials/sundials_config.h"',
-+ "C++",
-+ )
-+ env["has_sundials_lapack"] = lapackband and lapackdense
-
- # In the case where a user is trying to link Cantera to an external BLAS/LAPACK
- # library, but Sundials was configured without this support, print a Warning.
-diff -Naur old/interfaces/cython/SConscript new/interfaces/cython/SConscript
---- old/interfaces/cython/SConscript 2021-03-21 01:18:43.000000000 +0300
-+++ new/interfaces/cython/SConscript 2021-03-21 01:59:29.000000000 +0300
-@@ -108,8 +108,7 @@
- elif localenv['libdirname'] != 'lib':
- # 64-bit RHEL / Fedora etc. or e.g. x32 Gentoo profile
- extra = localenv.subst(
-- ' --prefix=${{python_prefix}}'
-- ' --install-lib=${{python_prefix}}/${{libdirname}}/python{}/site-packages'.format(py_version))
-+ ' --prefix=${stage_dir}${prefix} --install-lib=${python_prefix}')
- else:
- extra = '--user'
- localenv.AppendENVPath(
-diff -Naur old/interfaces/python_minimal/SConscript new/interfaces/python_minimal/SConscript
---- old/interfaces/python_minimal/SConscript 2021-02-13 00:57:15.000000000 +0300
-+++ new/interfaces/python_minimal/SConscript 2021-04-09 23:26:28.000000000 +0300
-@@ -8,7 +8,7 @@
- make_setup = build(localenv.SubstFile('setup.py', 'setup.py.in'))
-
- # copy scripts from the full Cython module
--for script in ['ctml_writer', 'ck2cti']:
-+for script in ['ctml_writer', 'ck2cti', 'ck2yaml', 'cti2yaml', 'ctml2yaml']:
- # The actual script
- s = build(env.Command('cantera/{}.py'.format(script),
- '#interfaces/cython/cantera/{}.py'.format(script),
-@@ -38,8 +38,7 @@
- elif localenv['libdirname'] != 'lib':
- # 64-bit RHEL / Fedora etc. or e.g. x32 Gentoo profile
- extra = localenv.subst(
-- ' --prefix=${{python_prefix}}'
-- ' --install-lib=${{python_prefix}}/${{libdirname}}/python{}/site-packages'.format(py_version))
-+ ' --prefix=${stage_dir}${prefix} --install-lib=${python_prefix}')
- else:
- extra = '--user'
- localenv.AppendENVPath(
-diff -Naur old/interfaces/python_minimal/cantera/__init__.py new/interfaces/python_minimal/cantera/__init__.py
---- old/interfaces/python_minimal/cantera/__init__.py 2021-02-13 00:57:15.000000000 +0300
-+++ new/interfaces/python_minimal/cantera/__init__.py 2021-04-10 00:07:38.000000000 +0300
-@@ -1,2 +1,5 @@
- from . import ck2cti
- from . import ctml_writer
-+from . import ck2yaml
-+from . import cti2yaml
-+from . import ctml2yaml
-diff -Naur old/interfaces/python_minimal/setup.py.in new/interfaces/python_minimal/setup.py.in
---- old/interfaces/python_minimal/setup.py.in 2021-02-13 00:57:15.000000000 +0300
-+++ new/interfaces/python_minimal/setup.py.in 2021-04-09 23:32:09.000000000 +0300
-@@ -12,6 +12,9 @@
- 'console_scripts': [
- 'ck2cti=cantera.ck2cti:script_entry_point',
- 'ctml_writer=cantera.ctml_writer:main',
-+ 'ck2yaml=cantera.ck2yaml:script_entry_point',
-+ 'cti2yaml=cantera.cti2yaml:main',
-+ 'ctml2yaml=cantera.ctml2yaml:main',
- ],
- },
- )
-diff -Naur old/test_problems/SConscript new/test_problems/SConscript
---- old/test_problems/SConscript 2021-03-21 01:18:43.000000000 +0300
-+++ new/test_problems/SConscript 2021-03-21 01:42:19.000000000 +0300
-@@ -222,7 +222,7 @@
- CompileAndTest('VPsilane_test')
-
- CompileAndTest('clib', 'clib_test', 'clib_test',
-- extensions=['^clib_test.c'], libs=['cantera_shared'])
-+ extensions=['^clib_test.c'])
-
- # C++ Samples
- Test('cxx-bvp', 'cxx_samples', '#build/samples/cxx/bvp/blasius', None,
diff --git a/sci-libs/cantera/files/cantera-2.6.0_drop_deprecated_open_U_option.patch b/sci-libs/cantera/files/cantera-2.6.0_drop_deprecated_open_U_option.patch
new file mode 100644
index 000000000000..41243da82f68
--- /dev/null
+++ b/sci-libs/cantera/files/cantera-2.6.0_drop_deprecated_open_U_option.patch
@@ -0,0 +1,49 @@
+From 0b407e11fe0bae4707286ab3cbf6a7a72a906817 Mon Sep 17 00:00:00 2001
+From: "Mark E. Fuller" <mark.e.fuller@gmx.de>
+Date: Thu, 23 Jun 2022 00:04:22 +0300
+Subject: [PATCH] drop deprecated 'U' open option
+
+---
+ site_scons/site_tools/subst.py | 15 +++------------
+ 1 file changed, 3 insertions(+), 12 deletions(-)
+
+diff --git a/site_scons/site_tools/subst.py b/site_scons/site_tools/subst.py
+index 3a1c4f6fb8..05d520491b 100644
+--- a/site_scons/site_tools/subst.py
++++ b/site_scons/site_tools/subst.py
+@@ -12,7 +12,7 @@
+
+ from SCons.Script import *
+ import SCons.Errors
+-
++from pathlib import Path
+
+ # Helper/core functions
+ ##############################################################################
+@@ -20,12 +20,7 @@
+ # Do the substitution
+ def _subst_file(target, source, env, pattern, replace):
+ # Read file
+- #print 'CALLING SUBST_FILE'
+- f = open(source, "rU")
+- try:
+- contents = f.read()
+- finally:
+- f.close()
++ contents = Path(source).read_text()
+
+ # Substitute, make sure result is a string
+ def subfn(mo):
+@@ -46,11 +41,7 @@ def subfn(mo):
+ # Determine which keys are used
+ def _subst_keys(source, pattern):
+ # Read file
+- f = open(source, "rU")
+- try:
+- contents = f.read()
+- finally:
+- f.close()
++ contents = Path(source).read_text()
+
+ # Determine keys
+ keys = []