summaryrefslogtreecommitdiff
path: root/sci-libs/cartopy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /sci-libs/cartopy
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'sci-libs/cartopy')
-rw-r--r--sci-libs/cartopy/Manifest2
-rw-r--r--sci-libs/cartopy/cartopy-0.18.0.ebuild65
2 files changed, 67 insertions, 0 deletions
diff --git a/sci-libs/cartopy/Manifest b/sci-libs/cartopy/Manifest
index e56c3d7fe4cd..9dbcc5759efc 100644
--- a/sci-libs/cartopy/Manifest
+++ b/sci-libs/cartopy/Manifest
@@ -1,3 +1,5 @@
+DIST cartopy-0.18.0.tar.gz 14191937 BLAKE2B bb10791ef2534dad404cc492e378161a4a078813b09d6e2c16d0d465c7dcfbaa7f24d3818cfe0f1f46e7683bdf2e00440640534835ce064492d5321489e355bc SHA512 912d5ab57c96b9e6c51b3ad26f94d77e495eb9c3a8fb8a68bdd957c11b1bc8a3ddc97e76e0d8a5ec9afca9302b01fe5753f4208ec3829df8741ee0ebbaafe30f
DIST cartopy-0.18.0_beta1.tar.gz 14215372 BLAKE2B 5bb1e98f18fdf57c0459202bfe77d4e4a476a3008e2f21a77cf643711cc3c438626915c31ee48886e980466f952985503987e3ed571295e2beb6c12754b382c4 SHA512 95d3bd87e57bea89eb2c25d6a709285ba59fb0f994abc3b37faf29b272b73647d0bc8979a25b1480f48bb55c957f4183ac3c3ad49b830ce686e931227c797abe
+EBUILD cartopy-0.18.0.ebuild 1666 BLAKE2B c6dce73d39a0d0278e00362fa7475048e0e64061f2fe02a66863972e1782a9ebe09d24a76cb4f4d86349675d73603a064df38e9c6a7c43122bbeef625334ffcb SHA512 4206796d8def5cc9bf36f260ea5df748af6fe04b6ce24d777cd409b8b4d41255b15a15c5d4a5a20888a833ee50330ca86ac703ddf82183985d91ff96f4697b0d
EBUILD cartopy-0.18.0_beta1.ebuild 1666 BLAKE2B c6dce73d39a0d0278e00362fa7475048e0e64061f2fe02a66863972e1782a9ebe09d24a76cb4f4d86349675d73603a064df38e9c6a7c43122bbeef625334ffcb SHA512 4206796d8def5cc9bf36f260ea5df748af6fe04b6ce24d777cd409b8b4d41255b15a15c5d4a5a20888a833ee50330ca86ac703ddf82183985d91ff96f4697b0d
MISC metadata.xml 602 BLAKE2B 92e179b5503c84c6e567e7adb48917ca6140a7c04a0f5613b5aa3a9c19623d61abed95c325b41ca0d5a99b046c2891511796de49c3117c4ce9c969069bb2c5f0 SHA512 8677cb5685dee0b5868c1b14ffc13ac93e3b26ab741ceb684c7c48caf02f159a7a6613402e0396b9b0bc256c39b6446cbb7779521324447d96ed524fb8ca664d
diff --git a/sci-libs/cartopy/cartopy-0.18.0.ebuild b/sci-libs/cartopy/cartopy-0.18.0.ebuild
new file mode 100644
index 000000000000..0be07b470778
--- /dev/null
+++ b/sci-libs/cartopy/cartopy-0.18.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+inherit distutils-r1 virtualx
+
+MY_PV=${PV/_beta/b}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="Python package for geospatial data processing and analysis"
+HOMEPAGE="https://scitools.org.uk/cartopy"
+SRC_URI="https://github.com/SciTools/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-libs/pyshp[${PYTHON_USEDEP}]
+ sci-libs/Shapely[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ sci-libs/gdal[python,${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
+ sci-libs/geos
+ sci-libs/proj
+"
+
+distutils_enable_tests pytest
+
+DEPEND+="test? (
+ dev-python/filelock[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+S="${WORKDIR}"/${MY_P}
+
+python_prepare_all() {
+ # drop test file requiring network access, which got not covered by markers
+ rm "${S}"/lib/cartopy/tests/mpl/test_crs.py || die
+ # prepare matplotlib backend for test suite
+ export MPLCONFIGDIR="${T}"
+ echo "backend : Agg" > "${MPLCONFIGDIR}"/matplotlibrc || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ cd "${BUILD_DIR}"
+ # drop all tests needing network access
+ virtx pytest -vv -m "not network and not natural_earth" || die "test failed"
+}