summaryrefslogtreecommitdiff
path: root/sci-libs/cartopy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-10-09 04:26:33 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-10-09 04:26:33 +0100
commit6ee17dd82a3bcd0e90af4ebfbb3e411d342761be (patch)
tree5ade54018efa76614b79d832bbe15a22021b6d8c /sci-libs/cartopy
parent325837835fc86686829aaa6acace3d3c06c74cea (diff)
gentoo auto-resync : 09:10:2024 - 04:26:32
Diffstat (limited to 'sci-libs/cartopy')
-rw-r--r--sci-libs/cartopy/Manifest2
-rw-r--r--sci-libs/cartopy/cartopy-0.24.0.ebuild84
2 files changed, 86 insertions, 0 deletions
diff --git a/sci-libs/cartopy/Manifest b/sci-libs/cartopy/Manifest
index 67f176886705..cf37a3111c31 100644
--- a/sci-libs/cartopy/Manifest
+++ b/sci-libs/cartopy/Manifest
@@ -1,4 +1,6 @@
AUX cartopy-0.23.0-backport-test-fixes.patch 520 BLAKE2B 57edd4f30665f243a7e710f3341fae647c897aab5066adf2749fd3c084adc67a730203d29dc3c5d19b8b963ecde2c41cbfd8a5da2c82e8775161d2ee4621a1ef SHA512 701b61807388962d2be57da2b7d32a0cd0b84584119cd0772d8b2a1da15e9cf233a048c2bd3ac08bd353732f7c2ae36bf500983569c1c42fec093752a9c570bd
DIST cartopy-0.23.0.gh.tar.gz 10645484 BLAKE2B aa9306e9f5bd85ae28be4802aac1a36d67df5812e9d188ad20d27103eaff1856b7d48e256459519b4e647bdf17fc207e8473ec6ead7413db113311fe821faba6 SHA512 8f357faad592db03c564d2c87f6d1600d2a04a68b71b250925c222cea418b8588f2eb48f64d3ec7210650a34372777ef8416c8f129af7911661615759d2c60b5
+DIST cartopy-0.24.0.gh.tar.gz 10701591 BLAKE2B 93b555e43031561f4927952839ddb7f95bef3801cbdaa5c20d98612b5a6d0383b83f4c41cf965b9ef2c64aea68c0507b34a3959bebb71b00bd86fc25d2de412a SHA512 eb0349dc3c1358b18f8c8ae71166f1947c3024337d7bf27fe28a2dea30593e7c6fcf1aa4a540537dd02d95f66051469ca679f3a5b8b3c2cf09d2f25736e03a9b
EBUILD cartopy-0.23.0.ebuild 2193 BLAKE2B 82d5147690bbe2081793db394666cbd1ad41c68a8f18a55f7f6e555d7551273f617db996b4298a062f7436635b0b00f085b9cf3773267705082af22562e63fe7 SHA512 4afffbef0971f207444de7013d948993fac1bac211310fd5f10fa2c2f92e338638bb19023a99b49819b88329563510bfc28e11ba67c477e19855dc7dfa1f15ca
+EBUILD cartopy-0.24.0.ebuild 2135 BLAKE2B 6adcea70334d7599ea992c8a62979b48c92247618558b0e975dc4d7819321bf59817209460189774d29964503a2dbd60191a5d0ca7c057dadb2c280d7033578a SHA512 5aa3e739e7b0e4f27cc7faf65b2c5b51161b52268687d77eec8a84ddca2fd809b604ea51b401d51e5a27349fe6d8dc779317666884b403b5eb416690bfe6b28c
MISC metadata.xml 729 BLAKE2B 38605f8140ccae8c9edf2b5eb7bf394e9c99fd089fa998c98422967cc12d3b808d3b7901d3746da25558c9211e47deec01a3d5856176cda8a868c0151a03fed8 SHA512 f3fb714f50475c2e0f4150d20423195fffb39243aefd313e9a9d0fa834364a928a712006d6e1e1def77b902f8c349a4045d3081fe38697054e744441e622a591
diff --git a/sci-libs/cartopy/cartopy-0.24.0.ebuild b/sci-libs/cartopy/cartopy-0.24.0.ebuild
new file mode 100644
index 000000000000..3c21d69d0004
--- /dev/null
+++ b/sci-libs/cartopy/cartopy-0.24.0.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_EXT=1
+PYTHON_COMPAT=( python3_{9..12} )
+
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 multiprocessing virtualx
+
+MY_PV=${PV/_beta/b}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="Python package for geospatial data processing and analysis"
+HOMEPAGE="https://scitools.org.uk/cartopy"
+SRC_URI="https://github.com/SciTools/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ sci-libs/gdal[python,${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/numpy-1.19[${PYTHON_USEDEP}]
+ dev-python/shapely[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/pillow[jpeg,${PYTHON_USEDEP}]
+ dev-python/pyproj[${PYTHON_USEDEP}]
+ sci-libs/pyshp[${PYTHON_USEDEP}]
+ ')
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
+ ')
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/filelock[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/flufl-lock[${PYTHON_USEDEP}]
+ dev-python/pytest-mpl[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ ')
+ )
+"
+
+EPYTEST_IGNORE=(
+ # Require network access, not covered by markers
+ lib/cartopy/tests/mpl/test_crs.py
+ lib/cartopy/tests/mpl/test_gridliner.py
+)
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+ # Prepare matplotlib backend for test suite
+ export MPLCONFIGDIR="${T}"
+ echo "backend : Agg" > "${MPLCONFIGDIR}"/matplotlibrc || die
+
+ sed -i -e "s/exclude =/#exclude =/" pyproject.toml || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ cd "${BUILD_DIR}" || die
+
+ # Drop all tests needing network access
+ virtx epytest -n "$(makeopts_jobs)" -m "not network and not natural_earth" || die "test failed"
+}