summaryrefslogtreecommitdiff
path: root/sci-libs/cgcode/cgcode-1.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /sci-libs/cgcode/cgcode-1.0-r2.ebuild
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'sci-libs/cgcode/cgcode-1.0-r2.ebuild')
-rw-r--r--sci-libs/cgcode/cgcode-1.0-r2.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/sci-libs/cgcode/cgcode-1.0-r2.ebuild b/sci-libs/cgcode/cgcode-1.0-r2.ebuild
index 90160c444ea9..931a56954eb3 100644
--- a/sci-libs/cgcode/cgcode-1.0-r2.ebuild
+++ b/sci-libs/cgcode/cgcode-1.0-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-inherit eutils fortran-2 toolchain-funcs
+inherit eutils fortran-2 flag-o-matic toolchain-funcs
DESCRIPTION="Conjugate gradient Codes for large sparse linear systems"
HOMEPAGE="http://fetk.org/codes/cgcode/index.html"
@@ -23,6 +23,10 @@ S="${WORKDIR}"/${PN}
src_prepare() {
epatch "${FILESDIR}"/${PV}-gentoo.patch
+ # GCC 10 workaround
+ # bug #722000
+ append-fflags $(test-flags-FC -fallow-argument-mismatch)
+
cat >> make.inc <<- EOF
F77 = $(tc-getFC)
FFLAGS = ${FFLAGS}