summaryrefslogtreecommitdiff
path: root/sci-libs/cifparse-obj/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-libs/cifparse-obj/files
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-libs/cifparse-obj/files')
-rw-r--r--sci-libs/cifparse-obj/files/cifparse-obj-7.025-gcc4.3.patch87
-rw-r--r--sci-libs/cifparse-obj/files/cifparse-obj-7.025-gcc4.7.patch64
-rw-r--r--sci-libs/cifparse-obj/files/cifparse-obj-7.025-gcc5_6.patch16
-rw-r--r--sci-libs/cifparse-obj/files/cifparse-obj-7.025-makefile.patch115
-rw-r--r--sci-libs/cifparse-obj/files/cifparse-obj-7.025-strncasecmp-declaration.patch16
-rw-r--r--sci-libs/cifparse-obj/files/cifparse-obj-7.105-makefile.patch110
6 files changed, 408 insertions, 0 deletions
diff --git a/sci-libs/cifparse-obj/files/cifparse-obj-7.025-gcc4.3.patch b/sci-libs/cifparse-obj/files/cifparse-obj-7.025-gcc4.3.patch
new file mode 100644
index 000000000000..1715f493a6e0
--- /dev/null
+++ b/sci-libs/cifparse-obj/files/cifparse-obj-7.025-gcc4.3.patch
@@ -0,0 +1,87 @@
+diff -Naur cifparse-obj-v7.025-prod-src/cif-file-v1.0/src/CifFile.C cifparse-obj-v7.025-prod-src.new/cif-file-v1.0/src/CifFile.C
+--- cifparse-obj-v7.025-prod-src/cif-file-v1.0/src/CifFile.C 2008-02-06 07:17:50.000000000 -0500
++++ cifparse-obj-v7.025-prod-src.new/cif-file-v1.0/src/CifFile.C 2008-09-03 09:36:41.000000000 -0400
+@@ -153,6 +153,7 @@
+ // VLAD - Carefully examine all methods that accept with, for cases where
+ // with is 0. This may happen if the value is empty !!
+
++#include <algorithm>
+ #include "GenString.h"
+ #include "CifString.h"
+ #include "regex.h"
+diff -Naur cifparse-obj-v7.025-prod-src/cifparse-test-v1.0/src/FOtest3.C cifparse-obj-v7.025-prod-src.new/cifparse-test-v1.0/src/FOtest3.C
+--- cifparse-obj-v7.025-prod-src/cifparse-test-v1.0/src/FOtest3.C 2008-02-06 07:17:51.000000000 -0500
++++ cifparse-obj-v7.025-prod-src.new/cifparse-test-v1.0/src/FOtest3.C 2008-09-03 09:40:12.000000000 -0400
+@@ -1,4 +1,5 @@
+ #include <iostream>
++#include <cstdlib>
+ #include "GenString.h"
+ #include "CifFile.h"
+
+diff -Naur cifparse-obj-v7.025-prod-src/cifparse-test-v1.0/src/FOtest7.C cifparse-obj-v7.025-prod-src.new/cifparse-test-v1.0/src/FOtest7.C
+--- cifparse-obj-v7.025-prod-src/cifparse-test-v1.0/src/FOtest7.C 2008-02-06 07:17:51.000000000 -0500
++++ cifparse-obj-v7.025-prod-src.new/cifparse-test-v1.0/src/FOtest7.C 2008-09-03 09:40:42.000000000 -0400
+@@ -3,6 +3,7 @@
+ */
+ #include "CifFile.h"
+ #include <iostream>
++#include <cstdlib>
+
+ void FillTestTable(ISTable *s);
+ void TwoCifFileObj();
+diff -Naur cifparse-obj-v7.025-prod-src/cifparse-test-v1.0/src/FOtest8.C cifparse-obj-v7.025-prod-src.new/cifparse-test-v1.0/src/FOtest8.C
+--- cifparse-obj-v7.025-prod-src/cifparse-test-v1.0/src/FOtest8.C 2008-02-06 07:17:51.000000000 -0500
++++ cifparse-obj-v7.025-prod-src.new/cifparse-test-v1.0/src/FOtest8.C 2008-09-03 09:41:06.000000000 -0400
+@@ -1,6 +1,7 @@
+ /* Test for reading binary files of two different versions*/
+ #include "CifFile.h"
+ #include <iostream>
++#include <cstdlib>
+
+
+ #define FALSE 0
+diff -Naur cifparse-obj-v7.025-prod-src/cifparse-test-v1.0/src/SdbReader.C cifparse-obj-v7.025-prod-src.new/cifparse-test-v1.0/src/SdbReader.C
+--- cifparse-obj-v7.025-prod-src/cifparse-test-v1.0/src/SdbReader.C 2008-02-06 07:17:51.000000000 -0500
++++ cifparse-obj-v7.025-prod-src.new/cifparse-test-v1.0/src/SdbReader.C 2008-09-03 09:41:50.000000000 -0400
+@@ -1,4 +1,5 @@
+ #include <iostream>
++#include <cstdlib>
+ #include "CifFile.h"
+
+
+diff -Naur cifparse-obj-v7.025-prod-src/common-v4.5/src/GenString.C cifparse-obj-v7.025-prod-src.new/common-v4.5/src/GenString.C
+--- cifparse-obj-v7.025-prod-src/common-v4.5/src/GenString.C 2008-02-06 07:17:49.000000000 -0500
++++ cifparse-obj-v7.025-prod-src.new/common-v4.5/src/GenString.C 2008-09-03 09:32:17.000000000 -0400
+@@ -138,7 +138,7 @@
+ POSSIBILITY THEREOF.
+ */
+
+-
++#include <cstring>
+ // Needed, since some platforms do not define std:: elsewhere
+ #include <ctype.h>
+
+diff -Naur cifparse-obj-v7.025-prod-src/tables-v8.0/src/ISTable.C cifparse-obj-v7.025-prod-src.new/tables-v8.0/src/ISTable.C
+--- cifparse-obj-v7.025-prod-src/tables-v8.0/src/ISTable.C 2008-02-06 07:17:50.000000000 -0500
++++ cifparse-obj-v7.025-prod-src.new/tables-v8.0/src/ISTable.C 2008-09-03 09:35:57.000000000 -0400
+@@ -150,6 +150,8 @@
+ #include <sstream>
+ #include <iostream>
+ #include <iomanip>
++#include <algorithm>
++#include <climits>
+
+ #include "Exceptions.h"
+ #include "GenString.h"
+diff -Naur cifparse-obj-v7.025-prod-src/tables-v8.0/src/ITTable.C cifparse-obj-v7.025-prod-src.new/tables-v8.0/src/ITTable.C
+--- cifparse-obj-v7.025-prod-src/tables-v8.0/src/ITTable.C 2008-02-06 07:17:50.000000000 -0500
++++ cifparse-obj-v7.025-prod-src.new/tables-v8.0/src/ITTable.C 2008-09-03 09:35:29.000000000 -0400
+@@ -150,6 +150,8 @@
+ #include <sstream>
+ #include <iostream>
+ #include <iomanip>
++#include <algorithm>
++#include <climits>
+
+ #include "Exceptions.h"
+ #include "GenString.h"
diff --git a/sci-libs/cifparse-obj/files/cifparse-obj-7.025-gcc4.7.patch b/sci-libs/cifparse-obj/files/cifparse-obj-7.025-gcc4.7.patch
new file mode 100644
index 000000000000..b828ae618caa
--- /dev/null
+++ b/sci-libs/cifparse-obj/files/cifparse-obj-7.025-gcc4.7.patch
@@ -0,0 +1,64 @@
+ common-v4.5/src/mapped_ptr_vector.C | 14 +++++++-------
+ 1 files changed, 7 insertions(+), 7 deletions(-)
+
+diff --git a/common-v4.5/src/mapped_ptr_vector.C b/common-v4.5/src/mapped_ptr_vector.C
+index 0ffff35..993d0b9 100644
+--- a/common-v4.5/src/mapped_ptr_vector.C
++++ b/common-v4.5/src/mapped_ptr_vector.C
+@@ -256,12 +256,12 @@ void mapped_ptr_vector<T, StringCompareT>::push_back(T* inP,
+ _vector.push_back(inP);
+
+ typename tIndex::value_type valuePair(inP->GetName(),
+- make_pair(_vector.size() - 1, fileIndex));
++ std::make_pair(_vector.size() - 1, fileIndex));
+
+ _index.insert(valuePair);
+
+ _currentName = inP->GetName();
+- _currentIndices = make_pair(_vector.size() - 1, fileIndex);
++ _currentIndices = std::make_pair(_vector.size() - 1, fileIndex);
+
+ }
+
+@@ -274,12 +274,12 @@ void mapped_ptr_vector<T, StringCompareT>::push_back(const string& name,
+ _vector.push_back(NULL);
+
+ typename tIndex::value_type valuePair(name,
+- make_pair(_vector.size() - 1, fileIndex));
++ std::make_pair(_vector.size() - 1, fileIndex));
+
+ _index.insert(valuePair);
+
+ _currentName = name;
+- _currentIndices = make_pair(_vector.size() - 1, fileIndex);
++ _currentIndices = std::make_pair(_vector.size() - 1, fileIndex);
+ }
+
+
+@@ -447,7 +447,7 @@ void mapped_ptr_vector<T, StringCompareT>::erase(const string& name)
+ if (is_equal(_currentName, name, keyComp))
+ {
+ _currentName.clear();
+- _currentIndices = make_pair(_vector.size(), (unsigned int)0);
++ _currentIndices = std::make_pair(_vector.size(), (unsigned int)0);
+ }
+
+ }
+@@ -532,7 +532,7 @@ pair<unsigned int, unsigned int> mapped_ptr_vector<T, StringCompareT>::get_indic
+ if (_vector.empty())
+ {
+ // Empty container. Return invalid index.
+- return(make_pair(_vector.size(), (unsigned int)0));
++ return(std::make_pair(_vector.size(), (unsigned int)0));
+ }
+
+ typename tIndex::key_compare keyComp = _index.key_comp();
+@@ -556,7 +556,7 @@ pair<unsigned int, unsigned int> mapped_ptr_vector<T, StringCompareT>::get_indic
+ else
+ {
+ // Not found. Return invalid index.
+- return(make_pair(_vector.size(), (unsigned int)0));
++ return(std::make_pair(_vector.size(), (unsigned int)0));
+ }
+ }
+
diff --git a/sci-libs/cifparse-obj/files/cifparse-obj-7.025-gcc5_6.patch b/sci-libs/cifparse-obj/files/cifparse-obj-7.025-gcc5_6.patch
new file mode 100644
index 000000000000..2ac0ec220d9e
--- /dev/null
+++ b/sci-libs/cifparse-obj/files/cifparse-obj-7.025-gcc5_6.patch
@@ -0,0 +1,16 @@
+ etc/platform.sh | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/etc/platform.sh b/etc/platform.sh
+index ff0ab51..1b56ab1 100755
+--- a/etc/platform.sh
++++ b/etc/platform.sh
+@@ -60,7 +60,7 @@ case `uname -s` in
+ # Check if it is a Linux platform
+ Linux)
+ # Check if it is GCC version 4.x
+- gcc_ver=`gcc --version | grep -e " 4\."`
++ gcc_ver=`gcc --version | grep -e " [456]\."`
+ if [[ -z $gcc_ver ]]
+ then
+ # It is not GCC version 4.x. Check if it is GCC version 3.x
diff --git a/sci-libs/cifparse-obj/files/cifparse-obj-7.025-makefile.patch b/sci-libs/cifparse-obj/files/cifparse-obj-7.025-makefile.patch
new file mode 100644
index 000000000000..9e9a61788ddf
--- /dev/null
+++ b/sci-libs/cifparse-obj/files/cifparse-obj-7.025-makefile.patch
@@ -0,0 +1,115 @@
+diff -Naur cifparse-obj-v7.025-prod-src/etc/make.platform.gnu3 cifparse-obj-v7.025-prod-src.new/etc/make.platform.gnu3
+--- cifparse-obj-v7.025-prod-src/etc/make.platform.gnu3 2008-02-06 07:17:49.000000000 -0500
++++ cifparse-obj-v7.025-prod-src.new/etc/make.platform.gnu3 2008-09-03 09:18:55.000000000 -0400
+@@ -107,8 +107,8 @@
+ C_WARNINGS=$(WARNINGS)
+
+ # C compiler flags
+-CFLAGS=$(OPT) $(ABI) $(ANSI_C_FLAG) $(C_WARNINGS) $(DEFINES) $(INCLUDES)
+-CFLAGS_NONANSI=$(OPT) $(ABI) $(NON_ANSI_C_FLAG) $(C_WARNINGS) $(DEFINES) \
++CFLAGS=$(C_OPT) $(ABI) $(ANSI_C_FLAG) $(C_WARNINGS) $(DEFINES) $(INCLUDES)
++CFLAGS_NONANSI=$(C_OPT) $(ABI) $(NON_ANSI_C_FLAG) $(C_WARNINGS) $(DEFINES) \
+ $(INCLUDES)
+
+ ## C++ compiler
+@@ -128,13 +128,13 @@
+ EXT=C
+
+ # C++ compiler flags
+-C++FLAGS=$(OPT) $(ABI) $(ANSI_C_PLUS_FLAG) $(C_PLUS_WARNINGS) $(DEFINES) \
++C++FLAGS=$(CXX_OPT) $(ABI) $(ANSI_C_PLUS_FLAG) $(C_PLUS_WARNINGS) $(DEFINES) \
+ $(INCLUDES)
+-C++FLAGS_NONANSI=$(OPT) $(ABI) $(NON_ANSI_C_PLUS_FLAG) $(C_PLUS_WARNINGS) \
++C++FLAGS_NONANSI=$(CXX_OPT) $(ABI) $(NON_ANSI_C_PLUS_FLAG) $(C_PLUS_WARNINGS) \
+ $(DEFINES) $(INCLUDES)
+ # C++FLAGS_RELAXED should be set to avoid warnings reported by third party
+ # source code that is not maintained by PDB
+-C++FLAGS_RELAXED=$(OPT) $(ABI) $(ANSI_C_PLUS_FLAG) $(NO_DEPRECATED) $(DEFINES) \
++C++FLAGS_RELAXED=$(CXX_OPT) $(ABI) $(ANSI_C_PLUS_FLAG) $(NO_DEPRECATED) $(DEFINES) \
+ $(INCLUDES)
+
+ ## Fortran compiler
+@@ -144,7 +144,7 @@
+ F77=f77
+
+ # Fortran compiler flags
+-FFLAGS=-O -u
++FFLAGS=$(F_OPT)
+
+ # Additional Fortran libraries
+ F77LIBS=
+@@ -157,7 +157,7 @@
+ STATIC_LINKING=-static
+
+ # Linker flags
+-LDFLAGS=$(ABI) -w $(STATIC_LINKING)
++LDFLAGS=$(ABI) -w $(STATIC_LINKING) $(LD_OPT)
+ LDFLAGS_NO_STATIC=$(ABI) -w
+
+ # Fortran linker
+diff -Naur cifparse-obj-v7.025-prod-src/etc/make.platform.gnu4 cifparse-obj-v7.025-prod-src.new/etc/make.platform.gnu4
+--- cifparse-obj-v7.025-prod-src/etc/make.platform.gnu4 2008-02-06 07:17:49.000000000 -0500
++++ cifparse-obj-v7.025-prod-src.new/etc/make.platform.gnu4 2008-09-03 09:20:16.000000000 -0400
+@@ -107,12 +107,12 @@
+ C_WARNINGS=$(WARNINGS)
+
+ # C compiler flags
+-CFLAGS=$(OPT) $(ABI) $(ANSI_C_FLAG) $(C_WARNINGS) $(DEFINES) $(INCLUDES)
+-CFLAGS_NONANSI=$(OPT) $(ABI) $(NON_ANSI_C_FLAG) $(C_WARNINGS) $(DEFINES) \
++CFLAGS=$(C_OPT) $(ABI) $(ANSI_C_FLAG) $(C_WARNINGS) $(DEFINES) $(INCLUDES)
++CFLAGS_NONANSI=$(C_OPT) $(ABI) $(NON_ANSI_C_FLAG) $(C_WARNINGS) $(DEFINES) \
+ $(INCLUDES)
+
+ ## C++ compiler
+-## This part defines C++ compiler information
++
+
+ # C++ compiler executable
+ CCC=g++
+@@ -128,13 +128,13 @@
+ EXT=C
+
+ # C++ compiler flags
+-C++FLAGS=$(OPT) $(ABI) $(ANSI_C_PLUS_FLAG) $(C_PLUS_WARNINGS) $(DEFINES) \
++C++FLAGS=$(CXX_OPT) $(ABI) $(ANSI_C_PLUS_FLAG) $(C_PLUS_WARNINGS) $(DEFINES) \
+ $(INCLUDES)
+-C++FLAGS_NONANSI=$(OPT) $(ABI) $(NON_ANSI_C_PLUS_FLAG) $(C_PLUS_WARNINGS) \
++C++FLAGS_NONANSI=$(CXX_OPT) $(ABI) $(NON_ANSI_C_PLUS_FLAG) $(C_PLUS_WARNINGS) \
+ $(DEFINES) $(INCLUDES)
+ # C++FLAGS_RELAXED should be set to avoid warnings reported by third party
+ # source code that is not maintained by PDB
+-C++FLAGS_RELAXED=$(OPT) $(ABI) $(ANSI_C_PLUS_FLAG) $(NO_DEPRECATED) $(DEFINES) \
++C++FLAGS_RELAXED=$(CXX_OPT) $(ABI) $(ANSI_C_PLUS_FLAG) $(NO_DEPRECATED) $(DEFINES) \
+ $(INCLUDES)
+
+ ## Fortran compiler
+@@ -144,7 +144,7 @@
+ F77=f77
+
+ # Fortran compiler flags
+-FFLAGS=-O -u
++FFLAGS=$(F_OPT)
+
+ # Additional Fortran libraries
+ F77LIBS=
+@@ -157,7 +157,7 @@
+ STATIC_LINKING=-static
+
+ # Linker flags
+-LDFLAGS=$(ABI) -w $(STATIC_LINKING)
++LDFLAGS=$(ABI) -w $(STATIC_LINKING) $(LD_OPT)
+ LDFLAGS_NO_STATIC=$(ABI) -w
+
+ # Fortran linker
+diff -Naur cifparse-obj-v7.025-prod-src/Makefile cifparse-obj-v7.025-prod-src.new/Makefile
+--- cifparse-obj-v7.025-prod-src/Makefile 2008-02-06 07:17:48.000000000 -0500
++++ cifparse-obj-v7.025-prod-src.new/Makefile 2008-09-03 09:19:12.000000000 -0400
+@@ -62,7 +62,7 @@
+ echo "------------------------------------------------------------"; \
+ echo "**** Making $$libdir ****"; \
+ echo "------------------------------------------------------------"; \
+- (cd $$libdir && $(MAKE) -f $(MAKEFILE) "OPT=-O" install) || exit 1; \
++ (cd $$libdir && $(MAKE) -f $(MAKEFILE) C_OPT="${CFLAGS}" CXX_OPT="${CXXFLAGS}" F_OPT="${FFLAGS}" LD_OPT="${LDFLAGS}" install) || exit 1; \
+ done
+
+ debug:
diff --git a/sci-libs/cifparse-obj/files/cifparse-obj-7.025-strncasecmp-declaration.patch b/sci-libs/cifparse-obj/files/cifparse-obj-7.025-strncasecmp-declaration.patch
new file mode 100644
index 000000000000..9222ff27699e
--- /dev/null
+++ b/sci-libs/cifparse-obj/files/cifparse-obj-7.025-strncasecmp-declaration.patch
@@ -0,0 +1,16 @@
+Remove incorrect prototypes of the 'strcasecmp' and 'strncasecmp' functions.
+See also: https://bugs.gentoo.org/show_bug.cgi?id=594054
+
+--- a/misclib-v2.2/include/ndb_misclib.h
++++ b/misclib-v2.2/include/ndb_misclib.h
+@@ -167,10 +167,6 @@
+ #define NDB_MSG_BUFFER_LEN 200000
+
+
+-#if !defined(HAVE_STRCASECMP)
+-int strcasecmp (const char *s1, const char *s2);
+-int strncasecmp (const char *s1, const char *s2, unsigned int n);
+-#endif
+ /*
+ * ndb_misclib.c prototypes
+ */
diff --git a/sci-libs/cifparse-obj/files/cifparse-obj-7.105-makefile.patch b/sci-libs/cifparse-obj/files/cifparse-obj-7.105-makefile.patch
new file mode 100644
index 000000000000..1716cd6390a4
--- /dev/null
+++ b/sci-libs/cifparse-obj/files/cifparse-obj-7.105-makefile.patch
@@ -0,0 +1,110 @@
+ etc/make.platform.gnu3 | 14 +++++++-------
+ etc/make.platform.gnu4 | 16 ++++++++--------
+ 2 files changed, 15 insertions(+), 15 deletions(-)
+
+diff --git a/etc/make.platform.gnu3 b/etc/make.platform.gnu3
+index 54b0297..138fa47 100644
+--- a/etc/make.platform.gnu3
++++ b/etc/make.platform.gnu3
+@@ -107,8 +107,8 @@ NON_ANSI_C_FLAG=
+ C_WARNINGS=$(WARNINGS)
+
+ # C compiler flags
+-CFLAGS=$(OPT) $(ABI) $(PIC) $(ANSI_C_FLAG) $(C_WARNINGS) $(DEFINES) $(INCLUDES)
+-CFLAGS_NONANSI=$(OPT) $(ABI) $(PIC) $(NON_ANSI_C_FLAG) $(C_WARNINGS) \
++CFLAGS=$(C_OPT) $(ABI) $(PIC) $(ANSI_C_FLAG) $(C_WARNINGS) $(DEFINES) $(INCLUDES)
++CFLAGS_NONANSI=$(C_OPT) $(ABI) $(PIC) $(NON_ANSI_C_FLAG) $(C_WARNINGS) \
+ $(DEFINES) $(INCLUDES)
+
+ ## C++ compiler
+@@ -128,14 +128,14 @@ C_PLUS_WARNINGS=$(WARNINGS) $(NO_DEPRECATED)
+ EXT=C
+
+ # C++ compiler flags
+-C++FLAGS=$(OPT) $(ABI) $(PIC) $(ANSI_C_PLUS_FLAG) $(C_PLUS_WARNINGS) \
++C++FLAGS=$(CXX_OPT) $(ABI) $(PIC) $(ANSI_C_PLUS_FLAG) $(C_PLUS_WARNINGS) \
+ $(DEFINES) $(INCLUDES)
+-C++FLAGS_NONANSI=$(OPT) $(ABI) $(PIC) $(NON_ANSI_C_PLUS_FLAG) \
++C++FLAGS_NONANSI=$(CXX_OPT) $(ABI) $(PIC) $(NON_ANSI_C_PLUS_FLAG) \
+ $(C_PLUS_WARNINGS) $(DEFINES) $(INCLUDES)
+
+ # C++FLAGS_RELAXED should be set to avoid warnings reported by third party
+ # source code that is not maintained by PDB
+-C++FLAGS_RELAXED=$(OPT) $(ABI) $(PIC) $(ANSI_C_PLUS_FLAG) $(NO_DEPRECATED) \
++C++FLAGS_RELAXED=$(CXX_OPT) $(ABI) $(PIC) $(ANSI_C_PLUS_FLAG) $(NO_DEPRECATED) \
+ $(DEFINES) $(INCLUDES)
+
+ ## Fortran compiler
+@@ -145,7 +145,7 @@ C++FLAGS_RELAXED=$(OPT) $(ABI) $(PIC) $(ANSI_C_PLUS_FLAG) $(NO_DEPRECATED) \
+ F77=f77
+
+ # Fortran compiler flags
+-FFLAGS=-O -u
++FFLAGS=$(F_OPT)
+
+ # Additional Fortran libraries
+ F77LIBS=
+@@ -158,7 +158,7 @@ F77LIBS=
+ STATIC_LINKING=-static
+
+ # Linker flags
+-LDFLAGS=$(ABI) -w $(STATIC_LINKING)
++LDFLAGS=$(ABI) -w $(STATIC_LINKING) $(LD_OPT)
+ LDFLAGS_NO_STATIC=$(ABI) -w
+
+ # Fortran linker
+diff --git a/etc/make.platform.gnu4 b/etc/make.platform.gnu4
+index 6676f35..51681fa 100644
+--- a/etc/make.platform.gnu4
++++ b/etc/make.platform.gnu4
+@@ -107,11 +107,11 @@ NON_ANSI_C_FLAG=
+ C_WARNINGS=$(WARNINGS)
+
+ # C compiler flags
+-CFLAGS=$(OPT) $(ABI) $(PIC) $(ANSI_C_FLAG) $(C_WARNINGS) $(DEFINES) $(INCLUDES)
+-CFLAGS_NONANSI=$(OPT) $(ABI) $(PIC) $(NON_ANSI_C_FLAG) $(DEFINES) $(INCLUDES)
++CFLAGS=$(C_OPT) $(ABI) $(PIC) $(ANSI_C_FLAG) $(C_WARNINGS) $(DEFINES) $(INCLUDES)
++CFLAGS_NONANSI=$(C_OPT) $(ABI) $(PIC) $(NON_ANSI_C_FLAG) $(DEFINES) $(INCLUDES)
+
+ ## C++ compiler
+-## This part defines C++ compiler information
++
+
+ # C++ compiler executable
+ CCC=g++
+@@ -127,14 +127,14 @@ C_PLUS_WARNINGS=$(WARNINGS) $(NO_DEPRECATED)
+ EXT=C
+
+ # C++ compiler flags
+-C++FLAGS=$(OPT) $(ABI) $(PIC) $(ANSI_C_PLUS_FLAG) $(C_PLUS_WARNINGS) \
++C++FLAGS=$(CXX_OPT) $(ABI) $(PIC) $(ANSI_C_PLUS_FLAG) $(C_PLUS_WARNINGS) \
+ $(DEFINES) $(INCLUDES)
+-C++FLAGS_NONANSI=$(OPT) $(ABI) $(PIC) $(NON_ANSI_C_PLUS_FLAG) \
++C++FLAGS_NONANSI=$(CXX_OPT) $(ABI) $(PIC) $(NON_ANSI_C_PLUS_FLAG) \
+ $(C_PLUS_WARNINGS) $(DEFINES) $(INCLUDES)
+
+ # C++FLAGS_RELAXED should be set to avoid warnings reported by third party
+ # source code that is not maintained by PDB
+-C++FLAGS_RELAXED=$(OPT) $(ABI) $(PIC) $(ANSI_C_PLUS_FLAG) $(NO_DEPRECATED) \
++C++FLAGS_RELAXED=$(CXX_OPT) $(ABI) $(PIC) $(ANSI_C_PLUS_FLAG) $(NO_DEPRECATED) \
+ $(DEFINES) $(INCLUDES)
+
+ ## Fortran compiler
+@@ -144,7 +144,7 @@ C++FLAGS_RELAXED=$(OPT) $(ABI) $(PIC) $(ANSI_C_PLUS_FLAG) $(NO_DEPRECATED) \
+ F77=f77
+
+ # Fortran compiler flags
+-FFLAGS=-O -u
++FFLAGS=$(F_OPT)
+
+ # Additional Fortran libraries
+ F77LIBS=
+@@ -157,7 +157,7 @@ F77LIBS=
+ STATIC_LINKING=-static
+
+ # Linker flags
+-LDFLAGS=$(ABI) -w $(STATIC_LINKING)
++LDFLAGS=$(ABI) -w $(STATIC_LINKING) $(LD_OPT)
+ LDFLAGS_NO_STATIC=$(ABI) -w
+
+ # Fortran linker