summaryrefslogtreecommitdiff
path: root/sci-libs/cqrlib/cqrlib-1.1.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /sci-libs/cqrlib/cqrlib-1.1.4.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'sci-libs/cqrlib/cqrlib-1.1.4.ebuild')
-rw-r--r--sci-libs/cqrlib/cqrlib-1.1.4.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/sci-libs/cqrlib/cqrlib-1.1.4.ebuild b/sci-libs/cqrlib/cqrlib-1.1.4.ebuild
new file mode 100644
index 000000000000..525ebb014f17
--- /dev/null
+++ b/sci-libs/cqrlib/cqrlib-1.1.4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+MY_PN=CQRlib
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Utility library for quaternion arithmetic / rotation math (ANSI C implemented)"
+HOMEPAGE="http://cqrlib.sourceforge.net/"
+SRC_URI="https://github.com/yayahjb/${PN}/archive/${MY_P}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="dev-libs/cvector"
+DEPEND="${RDEPEND}"
+
+DOCS=( README_CQRlib.txt )
+HTML_DOCS=( README_CQRlib.html )
+
+S="${WORKDIR}"/${PN}-${MY_P}
+
+PATCHES=(
+ "${FILESDIR}/${PV}-libtool.patch" # 778911
+ "${FILESDIR}/${PV}-build.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_compile() {
+ emake all
+}
+
+src_test() {
+ emake tests
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ einstalldocs
+ find "${D}" -name '*.la' -delete || die
+}