summaryrefslogtreecommitdiff
path: root/sci-libs/cxsparse
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /sci-libs/cxsparse
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'sci-libs/cxsparse')
-rw-r--r--sci-libs/cxsparse/Manifest3
-rw-r--r--sci-libs/cxsparse/cxsparse-3.2.0.ebuild32
-rw-r--r--sci-libs/cxsparse/files/cxsparse-3.2.0-header.patch17
3 files changed, 52 insertions, 0 deletions
diff --git a/sci-libs/cxsparse/Manifest b/sci-libs/cxsparse/Manifest
index ca8994c03d27..0fb37542e657 100644
--- a/sci-libs/cxsparse/Manifest
+++ b/sci-libs/cxsparse/Manifest
@@ -1,3 +1,6 @@
+AUX cxsparse-3.2.0-header.patch 531 BLAKE2B 7b8738c26a48aa01541db4978cc195f093da3e5d81536ff5819334ac847cd5d5a0e7ea5d2b1891183015ff449d98ba96ad360c4097369a70adab72a5419c471f SHA512 2340a350af044bcded3a592fde76ee885c02a3047772a02d91bfa0b43e7b6a04d7102893ba8d3e2394435fa6194d767812a3896359581c4d789890d2d35a78e0
DIST cxsparse-3.1.2.tar.bz2 2004570 BLAKE2B 4f1874e83faa1d831fce3847b82aeb67ae96e59b635489eceed3ed08a0fd0aaef7b0c9e40142f96ae5c7820a75bfb58b4d6a741c742b5a85dd6d8e4d78960be9 SHA512 dd3c5e31997564387b6145eaf2069c01e2ae8de384cd775a13ac7ccf03a83b6d0b8bf156a6645547f230dd13fc159d14203a4adcbe65703c154f35ecb161b6e9
+DIST cxsparse-3.2.0.tar.bz2 2080196 BLAKE2B 9b89469c45e518077c4348ad3efd8d89d248e4c039057c0286ee44b493ab595075894d01530cbfbe845b91ef5e43cfbfdd102721cfeefe943a1cb4bc5f171843 SHA512 9931dac5b319b61a39ccb5f34309acb4240602b5f55d029c790ed0b7319a373cb925c4b83994526af4bc5b19b88c723f04581068d1fc80960a290c9d6d1e1aef
EBUILD cxsparse-3.1.2-r1.ebuild 753 BLAKE2B a3d892c3b4d585445b255ec89283b610964cf7e87bdb65a8920cebcc7c947e206bd374e6a235051c46e01afffe826ec2f4f872531bf2473ecf2fbaf30e4d34d5 SHA512 48404fb91b86177ed8c275ac1936cd03e20217e3927ac06a93c112a683040cddb5fbd5c68f954f65ef6413a5233ee1524df5dd02213d092699ff08cfa535e7e3
+EBUILD cxsparse-3.2.0.ebuild 804 BLAKE2B d8b006c157f231ea2921db2ef6c385cb04616869125a5b8cc75635f8ad8cb001bbfac734745babacb4447c5209564a2d02d1b6e7423ca759c5957e4b5b5b06ba SHA512 d3ae803a2617814ffcd4cab52e830a2412e9a6395889d1da17af9461b60e99c57d5d7d6e6136820ba9f6d7e24d2478e733fc547b4dae2d02559fe51a63546cce
MISC metadata.xml 449 BLAKE2B 18e0d692b302702a20ecfe5ae10b8d48de7582649feeda3fe9c0bbcbbf6e6876f620bd490dabf788276a378d60b3bd0c1ee19a6fa439f37dff9269e8fd74d12d SHA512 908237dbe24a16831fc04faaff76d06bc4f0ae8605a551a98763d72ecbd19dcdbf2c74f320ccaf296c69bcacb3cda51b600ca0a9a8b481858723c2dd34a3754c
diff --git a/sci-libs/cxsparse/cxsparse-3.2.0.ebuild b/sci-libs/cxsparse/cxsparse-3.2.0.ebuild
new file mode 100644
index 000000000000..5c8ca14041e8
--- /dev/null
+++ b/sci-libs/cxsparse/cxsparse-3.2.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-minimal
+
+DESCRIPTION="Extended sparse matrix package"
+HOMEPAGE="http://faculty.cse.tamu.edu/davis/suitesparse.html"
+SRC_URI="http://202.36.178.9/sage/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="static-libs"
+
+BDEPEND="virtual/pkgconfig"
+DEPEND=">=sci-libs/suitesparseconfig-5.4.0[${MULTILIB_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-3.2.0-header.patch" )
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf $(use_enable static-libs static)
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ # package provides .pc files
+ find "${D}" -name '*.la' -delete || die
+}
diff --git a/sci-libs/cxsparse/files/cxsparse-3.2.0-header.patch b/sci-libs/cxsparse/files/cxsparse-3.2.0-header.patch
new file mode 100644
index 000000000000..0eaaeda69fd6
--- /dev/null
+++ b/sci-libs/cxsparse/files/cxsparse-3.2.0-header.patch
@@ -0,0 +1,17 @@
+diff --git a/CXSparse/Include/cs.h b/CXSparse/Include/cs.h
+index a47ee115..dbdf3017 100644
+--- a/Include/cs.h
++++ b/Include/cs.h
+@@ -43,9 +43,9 @@ extern "C" {
+ #endif
+
+ #define CS_VER 3 /* CXSparse Version */
+-#define CS_SUBVER 1
+-#define CS_SUBSUB 9
+-#define CS_DATE "May 4, 2016" /* CXSparse release date */
++#define CS_SUBVER 2
++#define CS_SUBSUB 0
++#define CS_DATE "Sept 12, 2017" /* CSparse release date */
+ #define CS_COPYRIGHT "Copyright (c) Timothy A. Davis, 2006-2016"
+ #define CXSPARSE
+