summaryrefslogtreecommitdiff
path: root/sci-libs/dsdp/dsdp-5.8-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-03 16:17:22 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-03 16:17:22 +0000
commit4cd2370bed609c118b6edfde5d3f116e5c35b897 (patch)
treeec58f2c41f49754e41521d5ebc9dce4597ddd0a5 /sci-libs/dsdp/dsdp-5.8-r3.ebuild
parentf443475c824b4b5c086e6d040961cb35ad81bc60 (diff)
gentoo resync : 03.12.2017
Diffstat (limited to 'sci-libs/dsdp/dsdp-5.8-r3.ebuild')
-rw-r--r--sci-libs/dsdp/dsdp-5.8-r3.ebuild19
1 files changed, 15 insertions, 4 deletions
diff --git a/sci-libs/dsdp/dsdp-5.8-r3.ebuild b/sci-libs/dsdp/dsdp-5.8-r3.ebuild
index b5304b9065c0..4da8972809f3 100644
--- a/sci-libs/dsdp/dsdp-5.8-r3.ebuild
+++ b/sci-libs/dsdp/dsdp-5.8-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -30,11 +30,22 @@ PATCHES=(
make_shared_lib() {
local soname=$(basename "${1%.a}")$(get_libname $(get_major_version))
+ local cflags=()
+
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ cflags+=(
+ "-Wl,-install_name"
+ "-Wl,${EPREFIX}/usr/$(get_libdir)/${soname}"
+ )
+ else
+ cflags+=(
+ "-shared" "-Wl,-soname=${soname}"
+ "-Wl,--whole-archive" "${1}" "-Wl,--no-whole-archive"
+ )
+ fi
einfo "Making ${soname}"
${2:-$(tc-getCC)} ${LDFLAGS} \
- -shared -Wl,-soname="${soname}" \
- $([[ ${CHOST} == *-darwin* ]] && echo "-Wl,-install_name -Wl,${EPREFIX}/usr/$(get_libdir)/${soname}") \
- -Wl,--whole-archive "${1}" -Wl,--no-whole-archive \
+ "${cflags[@]}" \
-o $(dirname "${1}")/"${soname}" \
-lm $($(tc-getPKG_CONFIG) --libs blas lapack) || return 1
}