summaryrefslogtreecommitdiff
path: root/sci-libs/fcl/fcl-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /sci-libs/fcl/fcl-9999.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'sci-libs/fcl/fcl-9999.ebuild')
-rw-r--r--sci-libs/fcl/fcl-9999.ebuild65
1 files changed, 45 insertions, 20 deletions
diff --git a/sci-libs/fcl/fcl-9999.ebuild b/sci-libs/fcl/fcl-9999.ebuild
index 6d823b172040..fe367b10808f 100644
--- a/sci-libs/fcl/fcl-9999.ebuild
+++ b/sci-libs/fcl/fcl-9999.ebuild
@@ -1,41 +1,66 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-SCM=""
-if [ "${PV#9999}" != "${PV}" ] ; then
- SCM="git-r3"
- EGIT_REPO_URI="https://github.com/flexible-collision-library/fcl"
-fi
-
-inherit ${SCM} cmake-utils
+inherit cmake
-if [ "${PV#9999}" != "${PV}" ] ; then
- KEYWORDS=""
- SRC_URI=""
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="https://github.com/flexible-collision-library/${PN}.git"
+ inherit git-r3
else
+ SRC_URI="https://github.com/flexible-collision-library/fcl/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm"
- SRC_URI="https://github.com/flexible-collision-library/fcl/archive/${PV}.tar.gz -> ${P}.tar.gz"
fi
DESCRIPTION="The Flexible Collision Library"
HOMEPAGE="http://gamma.cs.unc.edu/FCL/"
+
LICENSE="BSD"
-SLOT="0"
-IUSE="cpu_flags_x86_sse"
+SLOT="0/6"
+IUSE="cpu_flags_x86_sse doc +octomap profiling test"
+RESTRICT="!test? ( test )"
RDEPEND="
- sci-libs/octomap
- sci-libs/flann
+ dev-cpp/eigen:3
dev-libs/boost:=[threads]
- sci-libs/libccd"
+ sci-libs/flann
+ sci-libs/libccd[double-precision]
+ octomap? ( sci-libs/octomap )"
+
DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ test? ( dev-cpp/gtest )"
+
+BDEPEND="${RDEPEND}
virtual/pkgconfig"
src_configure() {
+ sed -i -e "s/include(CompilerSettings)//" "${S}"/CMakeLists.txt || die "failed to remove compiler flags override"
+
local mycmakeargs=(
- "-DFCL_USE_SSE=$(usex cpu_flags_x86_sse TRUE FALSE)"
+ -DBUILD_TESTING=$(usex test ON OFF)
+ -DFCL_COVERALLS=OFF
+ -DFCL_COVERALLS_UPLOAD=OFF
+ -DFCL_ENABLE_PROFILING=$(usex profiling ON OFF)
+ -DFCL_TREAT_WARNINGS_AS_ERRORS=OFF
+ -DFCL_USE_HOST_NATIVE_ARCH=OFF
+ -DFCL_USE_X64_SSE=$(usex cpu_flags_x86_sse ON OFF)
+ -DFCL_WITH_OCTOMAP=$(usex octomap ON OFF)
)
- cmake-utils_src_configure
+ local CMAKE_BUILD_TYPE="Release"
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+
+ use doc && cmake_src_compile docs
+}
+
+src_install() {
+ cmake_src_install
+
+ use doc && HTML_DOCS=( "${S}"/doc/doxygen/html )
+ einstalldocs
}