summaryrefslogtreecommitdiff
path: root/sci-libs/fplll
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
commit29aabba0ea759c6a2864ff5631735b67ee38e5e0 (patch)
treeab466b4dfa7abecb401b2f8039d08af4689306bb /sci-libs/fplll
parentd42200bec37eef2a7478d88988ff00addd0a9202 (diff)
gentoo resync : 05.02.2020
Diffstat (limited to 'sci-libs/fplll')
-rw-r--r--sci-libs/fplll/Manifest4
-rw-r--r--sci-libs/fplll/fplll-5.3.2.ebuild29
-rw-r--r--sci-libs/fplll/metadata.xml21
3 files changed, 52 insertions, 2 deletions
diff --git a/sci-libs/fplll/Manifest b/sci-libs/fplll/Manifest
index ce7ff66d9150..1f0147c1d68e 100644
--- a/sci-libs/fplll/Manifest
+++ b/sci-libs/fplll/Manifest
@@ -1,3 +1,5 @@
+DIST fplll-5.3.2.tar.gz 1284989 BLAKE2B 66d022c1a6acb3f029c871bebf4925ec5f9447af71829c6d52f2065155bf75f075965a41918722d095546ca18e8e87a85f181a76f5e42abd20c8de8165210bab SHA512 eacd990c468b1d919e1d6cc04f99656d982d5a3807970e0a1dd910a2703eb5b8eff913bc5c0e45790a547bb7aa71189fb9022024186bb84ee04d8602c9980ac2
DIST libfplll-4.0.4.tar.gz 413519 BLAKE2B afeea5a813d3d5b1b7fe3e81d5a8e9bce66ee4f8a3d265dacaa0ba7ff2f632f0f533182027322e2fd17645f5bc5816b266b167da0e36a00a38f73e794e22a522 SHA512 81cf61118f0dadca8fd82cc58df2fb5f0dc3ddd15a9b5de95a7777e0ece77d8f6a6d50d14ba7fdd6be6697cf375fac2e60792c94cc65f5a181c427dea84d552d
EBUILD fplll-4.0.4.ebuild 699 BLAKE2B 01dfbd79f44fda5d78257847f921639fc76b2d50f24362a5b7d1086004221d3956246d8d0357c9eb53701ea5b953d27c8cea555de3774bac78fbec653542b5ca SHA512 182361c2baee4f47ab8e8da716631f242f1be5d0f915cf1aef4addc5a17b5755ac21346dfb9b1fa404039975a73508edb5e9aad160d164c515b242218dd33898
-MISC metadata.xml 166 BLAKE2B c254f1fb642881aba57637be14fb0a89b10384f91a128feaec3a8c870d76efc2cbacb92caccc0dee2dd19a5ac5eaf8643080dafa05c4e2ac96a68568927e5afd SHA512 a56648c974a1d14dd4c18237532773c72057a13ab90c58b5da04f185e3c12a8bd8d5c21fb06053507f31766291a82dc7d87b34cd65fd94cfe2af7295c813ef84
+EBUILD fplll-5.3.2.ebuild 685 BLAKE2B 340d7ff679520ac9244439854cb3932c449a5cae6e9b0f6342c8146b6b515f4b440829ee12ef17ad440a37a0924398e6a87a5f28546b4f693119bc3c51b95e5a SHA512 0520db7cb4714ab0965beea69fad3966e20bbd0545f55c1a9c7af0212bb67f8c2aadc8d855381d0cb3a1203fc665ac678222f2fb4c3972ee866e3ff7577944c4
+MISC metadata.xml 731 BLAKE2B 64e80fd07c1887f4478cbd116254222a26b79a90037007fe4c99e3bef59036168de165468d3c4c39c2e4c7dae5392aa51de6d4b3cf97d76c7c6687d7cfb0685c SHA512 0ff3088ed94924291b47ffbe624f54b493755f941ab59fe23f67eae01d8e79ac4c8699ce23db4ffd8bc9012290da379b19dd4a0772a9e0e2c6312387a93e01b7
diff --git a/sci-libs/fplll/fplll-5.3.2.ebuild b/sci-libs/fplll/fplll-5.3.2.ebuild
new file mode 100644
index 000000000000..13f7fa295ee2
--- /dev/null
+++ b/sci-libs/fplll/fplll-5.3.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Implementations of the floating-point LLL reduction algorithm"
+HOMEPAGE="https://github.com/fplll/fplll"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/6"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+BDEPEND=""
+DEPEND="dev-libs/gmp:0
+ dev-libs/mpfr:0"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ # Support for --with-qd is problematic at the moment.
+ # https://github.com/fplll/fplll/issues/405
+ econf $(use_enable static-libs static)
+}
+
+src_install(){
+ default
+ find "${ED}" -name '*.la' -delete || die
+}
diff --git a/sci-libs/fplll/metadata.xml b/sci-libs/fplll/metadata.xml
index 6f49eba8f496..51b421021524 100644
--- a/sci-libs/fplll/metadata.xml
+++ b/sci-libs/fplll/metadata.xml
@@ -1,5 +1,24 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<!-- maintainer-needed -->
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ </maintainer>
+ <!--
+ mjo: François maintained this package in the sage-on-gentoo overlay
+ long before I moved it into ::gentoo. You don't need an ACK from me
+ to merge his changes.
+ -->
+ <maintainer type="person">
+ <email>frp.bissey@gmail.com</email>
+ <name>François Bissey</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+
+ <upstream>
+ <remote-id type="github">fplll/fplll</remote-id>
+ </upstream>
</pkgmetadata>