summaryrefslogtreecommitdiff
path: root/sci-libs/geos/geos-3.12.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-18 04:58:45 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-18 04:58:45 +0000
commit7e6812aaf62d1be61aaa50252c7e868fc9eabf4c (patch)
tree450af773d11fbdc0a7cf17e5f2ad2ccfc86922fd /sci-libs/geos/geos-3.12.1.ebuild
parent3d3cca628d8563ee68902105ad2e8e8bf0d7db2b (diff)
gentoo auto-resync : 18:11:2023 - 04:58:45
Diffstat (limited to 'sci-libs/geos/geos-3.12.1.ebuild')
-rw-r--r--sci-libs/geos/geos-3.12.1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/sci-libs/geos/geos-3.12.1.ebuild b/sci-libs/geos/geos-3.12.1.ebuild
new file mode 100644
index 000000000000..a95d93f605b6
--- /dev/null
+++ b/sci-libs/geos/geos-3.12.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Geometry engine library for Geographic Information Systems"
+HOMEPAGE="https://libgeos.org/"
+SRC_URI="https://download.osgeo.org/geos/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="doc? ( app-doc/doxygen )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_DOCUMENTATION=$(usex doc)
+ -DBUILD_TESTING=$(usex test)
+ -DUSE_CCACHE=OFF
+
+ # bug #709368
+ $(usev arm '-DDISABLE_GEOS_INLINE=ON')
+ )
+
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+
+ use doc && cmake_src_compile docs
+}
+
+src_install() {
+ cmake_src_install
+
+ if use doc ; then
+ HTML_DOCS=( "${BUILD_DIR}"/doxygen/doxygen_docs/html/. )
+ einstalldocs
+ fi
+}