summaryrefslogtreecommitdiff
path: root/sci-libs/gloo/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-27 22:51:10 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-27 22:51:10 +0000
commitee0c4d5e506a6c64994a15c3af5cf1ca22045567 (patch)
treebdf578939023d42f04092ddb4bcd190eb391770f /sci-libs/gloo/files
parent161eaa4b12ca6314376288834bba20b7824d0d77 (diff)
gentoo auto-resync : 27:11:2023 - 22:51:09
Diffstat (limited to 'sci-libs/gloo/files')
-rw-r--r--sci-libs/gloo/files/gloo-2023.01.17-ssl3.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/sci-libs/gloo/files/gloo-2023.01.17-ssl3.patch b/sci-libs/gloo/files/gloo-2023.01.17-ssl3.patch
new file mode 100644
index 000000000000..f01beafa4596
--- /dev/null
+++ b/sci-libs/gloo/files/gloo-2023.01.17-ssl3.patch
@@ -0,0 +1,19 @@
+--- a/gloo/CMakeLists.txt 2023-11-27 22:39:53.709670525 +0100
++++ b/gloo/CMakeLists.txt 2023-11-27 22:42:29.784250524 +0100
+@@ -77,7 +77,7 @@
+ if(${CMAKE_SYSTEM_NAME} STREQUAL "Linux")
+ set(GLOO_HAVE_TRANSPORT_TCP 1)
+ if(${USE_TCP_OPENSSL_LINK} OR ${USE_TCP_OPENSSL_LOAD})
+- find_package(OpenSSL 1.1 REQUIRED EXACT)
++ find_package(OpenSSL 1.1...<4 REQUIRED)
+ set(GLOO_HAVE_TRANSPORT_TCP_TLS 1)
+ else()
+ set(GLOO_HAVE_TRANSPORT_TCP_TLS 0)
+--- a/gloo/test/CMakeLists.txt 2023-11-27 22:42:55.969844380 +0100
++++ b/gloo/test/CMakeLists.txt 2023-11-27 22:43:14.873551147 +0100
+@@ -1,4 +1,4 @@
+-find_package(OpenSSL 1.1 REQUIRED EXACT)
++find_package(OpenSSL 1.1...<4 REQUIRED)
+
+ set(GLOO_TEST_SRCS
+ "${CMAKE_CURRENT_SOURCE_DIR}/allgather_test.cc"