summaryrefslogtreecommitdiff
path: root/sci-libs/gmsh
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /sci-libs/gmsh
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'sci-libs/gmsh')
-rw-r--r--sci-libs/gmsh/Manifest3
-rw-r--r--sci-libs/gmsh/files/gmsh-4.8.4-gcc11.patch80
-rw-r--r--sci-libs/gmsh/gmsh-4.8.4.ebuild4
3 files changed, 86 insertions, 1 deletions
diff --git a/sci-libs/gmsh/Manifest b/sci-libs/gmsh/Manifest
index 5a1c671ee0aa..b5d88af80652 100644
--- a/sci-libs/gmsh/Manifest
+++ b/sci-libs/gmsh/Manifest
@@ -1,3 +1,4 @@
+AUX gmsh-4.8.4-gcc11.patch 2821 BLAKE2B 21977c525d2359cddcc7dd189a8aa5fa74acb9bd9badd9accac7a7e8334311f4f2c007079c5580118e2f991d802af3ce4d54c93a8e9ada76dc5b41279cdfc848 SHA512 fdeced297f2188461d0d61bafdeb4bf0c2663a7d7cda9cc4aa61f4211173243cb7e6ea68f8db15ed45422a4d0914d628231060f6a3f30251765da768975b0f5b
DIST gmsh-4.8.4-source.tgz 13838352 BLAKE2B 26c7f68e41d1c339c7d5fd499b2261c2ce79c38648df9f4f3853ba69421d59be36992d8aac1d1ebc1fe872bb828769693c12fd9770878fa3b59c179176105ea4 SHA512 c3880e67af03aa6d00300b5f56fd229ffe37da9af66e8c7c87a3bbf7abcb3a90b4858ec76093ef8f039a70d4da1d5cc7f7c687c05b6642299c95e1a07f9513bf
-EBUILD gmsh-4.8.4.ebuild 1784 BLAKE2B 0cd3d1b0981c3dfd5739e10dc2bbf2e2c40130a09997982105ba331dec9ac1ac669e6e50ec12ecca5233cbe5e4e194af708334ec1e9c549fe2bdec9cec9ddd1a SHA512 aec9980a9dae689db3d6a1adcc44614c718922e624ce473571d00d59836b5a4d36027f7fd1c6a695d4cefe5320d22d6900ceb98c7f86eb1297a9962448616150
+EBUILD gmsh-4.8.4.ebuild 1829 BLAKE2B c2fea1f86e8702ca0ac8dca319edc91e7f275a5e321ab46532fbbd7567335a2ff793036810a3549494ad7f85e22dc51b8262264889ced6df614b32af4f70e812 SHA512 93a4fd7f2022ef2ffe72c8f4d3a2aab46599f56e778f9c292eea53aef25e796359d014394983000450289221b5b0d1d22195dbce0829cd2ba241a28a5dba5a63
MISC metadata.xml 738 BLAKE2B 8df642f68bf20aaa8742b4e8c2e469b0af3e9c61f17905604a17f2dade702423927c2d146d68781b056335269a20717cee6502447eb9d30a7bc0684990cd1312 SHA512 5634ec209dad65d0b5845007b9f29aaee6137a6a85a142fde6c8e6d357e4d6acf339cf65c5dc3018305f73c40f653dfc50ed7ff9a321ced62407a98b6a3f710f
diff --git a/sci-libs/gmsh/files/gmsh-4.8.4-gcc11.patch b/sci-libs/gmsh/files/gmsh-4.8.4-gcc11.patch
new file mode 100644
index 000000000000..3f16ef476d7f
--- /dev/null
+++ b/sci-libs/gmsh/files/gmsh-4.8.4-gcc11.patch
@@ -0,0 +1,80 @@
+https://gitlab.onelab.info/gmsh/gmsh/-/commit/e7cd675083f72c6c01701cb0f16d1639aca121ba
+https://bugs.gentoo.org/800536
+
+From: Tristan Carel <tristan.carel@epfl.ch>
+Date: Wed, 28 Jul 2021 10:55:40 +0200
+Subject: [PATCH] Fix symbol conflict in picojson with GCC 11 internal macro
+
+Build issue on MacOS with GCC 11 from brew:
+```
+/usr/local/Cellar/gcc/11.1.0_1/lib/gcc/11/gcc/x86_64-apple-darwin20/11.1.0/include/serializeintrin.h:37: note: macro "_serialize" defined here
+ 37 | #define _serialize() __builtin_ia32_serialize ()
+ |
+```
+--- a/Common/picojson.h
++++ b/Common/picojson.h
+@@ -186,8 +186,8 @@ public:
+ private:
+ template <typename T> value(const T *); // intentionally defined to block implicit conversion of pointer to bool
+ template <typename Iter> static void _indent(Iter os, int indent);
+- template <typename Iter> void _serialize(Iter os, int indent) const;
+- std::string _serialize(int indent) const;
++ template <typename Iter> void serialize_(Iter os, int indent) const;
++ std::string serialize_(int indent) const;
+ void clear();
+ };
+
+@@ -549,11 +549,11 @@ template <typename Iter> void serialize_str(const std::string &s, Iter oi) {
+ }
+
+ template <typename Iter> void value::serialize(Iter oi, bool prettify) const {
+- return _serialize(oi, prettify ? 0 : -1);
++ return serialize_(oi, prettify ? 0 : -1);
+ }
+
+ inline std::string value::serialize(bool prettify) const {
+- return _serialize(prettify ? 0 : -1);
++ return serialize_(prettify ? 0 : -1);
+ }
+
+ template <typename Iter> void value::_indent(Iter oi, int indent) {
+@@ -563,7 +563,7 @@ template <typename Iter> void value::_indent(Iter oi, int indent) {
+ }
+ }
+
+-template <typename Iter> void value::_serialize(Iter oi, int indent) const {
++template <typename Iter> void value::serialize_(Iter oi, int indent) const {
+ switch (type_) {
+ case string_type:
+ serialize_str(*u_.string_, oi);
+@@ -580,7 +580,7 @@ template <typename Iter> void value::_serialize(Iter oi, int indent) const {
+ if (indent != -1) {
+ _indent(oi, indent);
+ }
+- i->_serialize(oi, indent);
++ i->serialize_(oi, indent);
+ }
+ if (indent != -1) {
+ --indent;
+@@ -608,7 +608,7 @@ template <typename Iter> void value::_serialize(Iter oi, int indent) const {
+ if (indent != -1) {
+ *oi++ = ' ';
+ }
+- i->second._serialize(oi, indent);
++ i->second.serialize_(oi, indent);
+ }
+ if (indent != -1) {
+ --indent;
+@@ -628,9 +628,9 @@ template <typename Iter> void value::_serialize(Iter oi, int indent) const {
+ }
+ }
+
+-inline std::string value::_serialize(int indent) const {
++inline std::string value::serialize_(int indent) const {
+ std::string s;
+- _serialize(std::back_inserter(s), indent);
++ serialize_(std::back_inserter(s), indent);
+ return s;
+ }
+
+GitLab
diff --git a/sci-libs/gmsh/gmsh-4.8.4.ebuild b/sci-libs/gmsh/gmsh-4.8.4.ebuild
index df5ea5533a0a..0c32a563f7a1 100644
--- a/sci-libs/gmsh/gmsh-4.8.4.ebuild
+++ b/sci-libs/gmsh/gmsh-4.8.4.ebuild
@@ -40,6 +40,10 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${P}-source
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc11.patch
+)
+
pkg_setup() {
fortran-2_pkg_setup
}