summaryrefslogtreecommitdiff
path: root/sci-libs/gsl/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-01 04:05:50 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-01 04:05:50 +0000
commit6438b14169223c6931a87dd4e1e357934b2c0852 (patch)
treec429df63c28f2b4670bc1d0dfc6ea140ed24ceae /sci-libs/gsl/files
parent5df0c8ba4bb09f65c6cfb7d67dead00d6b2a1bf9 (diff)
gentoo auto-resync : 01:03:2023 - 04:05:50
Diffstat (limited to 'sci-libs/gsl/files')
-rw-r--r--sci-libs/gsl/files/gsl-2.7.1-configure-clang16.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/sci-libs/gsl/files/gsl-2.7.1-configure-clang16.patch b/sci-libs/gsl/files/gsl-2.7.1-configure-clang16.patch
new file mode 100644
index 000000000000..ba239563a38e
--- /dev/null
+++ b/sci-libs/gsl/files/gsl-2.7.1-configure-clang16.patch
@@ -0,0 +1,26 @@
+https://bugs.gentoo.org/898410
+https://savannah.gnu.org/bugs/?63679
+
+Avoid calling the undeclared exit function and future failures
+with compilers which do not support implicit function declarations.
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -449,7 +449,7 @@ int main (void)
+ inf = exp(1.0e10);
+ nan = inf / inf ;
+ status = (nan == nan);
+- exit (status);
++ return status;
+ }]])],[ac_cv_c_ieee_comparisons="yes"],[ac_cv_c_ieee_comparisons="no"],[ac_cv_c_ieee_comparisons="yes"])
+ ])
+
+@@ -469,7 +469,7 @@ int main (void)
+ for (i = 0; i < 5; i++) { z = z / 10.0 ; };
+ for (i = 0; i < 5; i++) { z = z * 10.0 ; };
+ status = (z == 0.0);
+- exit (status);
++ return status;
+ }]])],[ac_cv_c_ieee_denormals="yes"],[ac_cv_c_ieee_denormals="no"],[ac_cv_c_ieee_denormals="yes"])
+ ])
+