summaryrefslogtreecommitdiff
path: root/sci-libs/hipSPARSE
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-29 18:03:51 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-29 18:03:51 +0000
commitd7ed2b01311f15ba54fe8ea872aab7d59ab2b193 (patch)
tree1814dd2b5bbf2e7639fdafbeef48d228cfaf5e9b /sci-libs/hipSPARSE
parentabaa75b10f899ada8dd05b23cc03205064394bc6 (diff)
gentoo resync : 29.01.2021
Diffstat (limited to 'sci-libs/hipSPARSE')
-rw-r--r--sci-libs/hipSPARSE/Manifest3
-rw-r--r--sci-libs/hipSPARSE/hipSPARSE-4.0.0-r1.ebuild49
-rw-r--r--sci-libs/hipSPARSE/metadata.xml19
3 files changed, 71 insertions, 0 deletions
diff --git a/sci-libs/hipSPARSE/Manifest b/sci-libs/hipSPARSE/Manifest
new file mode 100644
index 000000000000..eb5a604af10e
--- /dev/null
+++ b/sci-libs/hipSPARSE/Manifest
@@ -0,0 +1,3 @@
+DIST hipSPARSE-4.0.tar.gz 271756 BLAKE2B d774632c145a842c5dd97df6e0c1c3b3fc6986a5d3e000564b3b9b4f8a9c72bc01b360baf93a82f8a70a85b8ee1833f4e767a48021d3869391000551ed00e614 SHA512 78c9501e6f9f8b0727d2f2207814048f8c784b2b06797559d6f639244cb1439e9218a46c582a6b337b15791519f0bcb9e0f42c17bff00c096c797c96cc7660ae
+EBUILD hipSPARSE-4.0.0-r1.ebuild 1139 BLAKE2B f121839a28ad5d73c51175ac4b0d071e315165010ac02cb3659658d55c13ac7b679d9b347bac747c1ecb00f5f486e1129f287346a92cda0c738ff468ff8d2b18 SHA512 2637a62410ca0084fa15ebd46507615cfba7a6b10a91326dae41ff7b9b35a1e0fcc11f160885d6333c37956e1b8a5f96191792d03406f923bad50f43f884059c
+MISC metadata.xml 588 BLAKE2B 28ef304a020639fe4677a6fac7d4bd56a544406d05feab9c11567d98c00fc612d4f2bd89b95df4850d0a892bfadd01e38356c35df7ecd4e3ea156482e50eb0f8 SHA512 491b454e61d5aae073bcf5a591dcddc7267bb929bdc686c5d811310025dd94ab8b5ad65abbec1b2ab5e9d91eff204b5e97c163a0e6c5f9af9ad7a245fcad4b4b
diff --git a/sci-libs/hipSPARSE/hipSPARSE-4.0.0-r1.ebuild b/sci-libs/hipSPARSE/hipSPARSE-4.0.0-r1.ebuild
new file mode 100644
index 000000000000..6db7fd375008
--- /dev/null
+++ b/sci-libs/hipSPARSE/hipSPARSE-4.0.0-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="ROCm SPARSE marshalling library"
+HOMEPAGE="https://github.com/ROCmSoftwarePlatform/hipSPARSE"
+SRC_URI="https://github.com/ROCmSoftwarePlatform/hipSPARSE/archive/rocm-${PV}.tar.gz -> hipSPARSE-$(ver_cut 1-2).tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64"
+SLOT="0"
+
+RDEPEND=">=dev-util/rocminfo-$(ver_cut 1-2)
+ =dev-util/hip-$(ver_cut 1-2)*
+ =sci-libs/rocSPARSE-${PV}*"
+DEPEND="${RDPEND}"
+
+S="${WORKDIR}/hipSPARSE-rocm-${PV}"
+
+src_prepare() {
+ sed -e "s/PREFIX hipsparse//" \
+ -e "/<INSTALL_INTERFACE/s,include,include/hipsparse," \
+ -e "s:rocm_install_symlink_subdir(hipsparse):#rocm_install_symlink_subdir(hipsparse):" \
+ -i library/CMakeLists.txt || die
+
+ eapply_user
+ cmake_src_prepare
+}
+
+src_configure() {
+ # Grant access to the device
+ addwrite /dev/kfd
+ addpredict /dev/dri/
+
+ # Compiler to use
+ export CXX=hipcc
+
+ local mycmakeargs=(
+ -DHIP_RUNTIME="ROCclr"
+ -DBUILD_CLIENTS_TESTS=OFF
+ -DBUILD_CLIENTS_SAMPLES=OFF
+ -DCMAKE_INSTALL_INCLUDEDIR=include/hipsparse
+ )
+
+ cmake_src_configure
+}
diff --git a/sci-libs/hipSPARSE/metadata.xml b/sci-libs/hipSPARSE/metadata.xml
new file mode 100644
index 000000000000..b745c3d73285
--- /dev/null
+++ b/sci-libs/hipSPARSE/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>candrews@gentoo.org</email>
+ <name>Craig Andrews</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>gentoo@holzke.net</email>
+ <name>Wilfried Holzke</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ROCmSoftwarePlatform/hipSPARSE</remote-id>
+ </upstream>
+</pkgmetadata>