summaryrefslogtreecommitdiff
path: root/sci-libs/keras-preprocessing
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
commit43793fab84041cfc5c60c0151d1591b8a69fb24a (patch)
tree6208a7f4fc744684fce0f55acbb47511acace498 /sci-libs/keras-preprocessing
parent28e3d252dc8ac8a5635206dfefe1cfe05058d1db (diff)
gentoo resync : 25.08.2018
Diffstat (limited to 'sci-libs/keras-preprocessing')
-rw-r--r--sci-libs/keras-preprocessing/Manifest3
-rw-r--r--sci-libs/keras-preprocessing/keras-preprocessing-1.0.2.ebuild22
-rw-r--r--sci-libs/keras-preprocessing/metadata.xml14
3 files changed, 39 insertions, 0 deletions
diff --git a/sci-libs/keras-preprocessing/Manifest b/sci-libs/keras-preprocessing/Manifest
new file mode 100644
index 000000000000..2aede3829617
--- /dev/null
+++ b/sci-libs/keras-preprocessing/Manifest
@@ -0,0 +1,3 @@
+DIST keras-preprocessing-1.0.2.tar.gz 34762 BLAKE2B 3b4766aa48d6e6cfd50817af97c8f2faf9ae7e78007f7dddcbf1f4ded072657a5b94ac4b563d090dd8a8437a249b64fea61a1cd5f680767f14611fa6fe92dd3a SHA512 d5a558c3d9741c298ea3737bfb04788bd2cbecefe14aa53e0f6ccde891ad9304ec673a888dc53a2f954c0b718ce31d9d35095d3f21e15d73248acfc8105457d9
+EBUILD keras-preprocessing-1.0.2.ebuild 602 BLAKE2B 2e9a1d1fe5af86239dd6c28ad262506b1e6d52ca853daa89130ac536ae37de0b83954cbf3cfddf4a1e25e20c945aee9d3a28f1d5ea192eead788960294cd6410 SHA512 eab972f49c8c94d4c2a14b2f643e9ebc164657fc637605ee683eabb7eefa414245b65859dd01b60387c9b1b638bc4038bbafeb1bf2cdf643b88695bdf7f7cce1
+MISC metadata.xml 585 BLAKE2B a2f92ac4e2b9af055313a13de9bcbaee7ab7ca2efa4790c82027aece4b629bfa7a73c5ed0286b0f24f1853330057527009afe6ab1722f19d9c504a9d0737e827 SHA512 371cc3f5897bd28c62642a8857a22e775e24aa917bc0e58bb4de4e0a2a6580174ba35cfda2e8dd83599e2180fdfb3f11a953e7076c6d87073e1465b145b115e9
diff --git a/sci-libs/keras-preprocessing/keras-preprocessing-1.0.2.ebuild b/sci-libs/keras-preprocessing/keras-preprocessing-1.0.2.ebuild
new file mode 100644
index 000000000000..930bd5dcf266
--- /dev/null
+++ b/sci-libs/keras-preprocessing/keras-preprocessing-1.0.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_6 )
+inherit distutils-r1
+
+DESCRIPTION="Easy data preprocessing and data augmentation for deep learning models"
+HOMEPAGE="https://keras.io/"
+SRC_URI="https://github.com/keras-team/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/sci-libs/keras-preprocessing/metadata.xml b/sci-libs/keras-preprocessing/metadata.xml
new file mode 100644
index 000000000000..833dd3977c1a
--- /dev/null
+++ b/sci-libs/keras-preprocessing/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>perfinion@gentoo.org</email>
+ <name>Jason Zaman</name>
+ </maintainer>
+ <longdescription lang="en">
+ Keras Preprocessing is the data preprocessing and data augmentation module of the Keras deep learning library. It provides utilities for working with image data, text data, and sequence data.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">keras-team/keras-preprocessing</remote-id>
+ </upstream>
+</pkgmetadata>