summaryrefslogtreecommitdiff
path: root/sci-libs/libsigrokdecode/libsigrokdecode-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /sci-libs/libsigrokdecode/libsigrokdecode-9999.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'sci-libs/libsigrokdecode/libsigrokdecode-9999.ebuild')
-rw-r--r--sci-libs/libsigrokdecode/libsigrokdecode-9999.ebuild29
1 files changed, 15 insertions, 14 deletions
diff --git a/sci-libs/libsigrokdecode/libsigrokdecode-9999.ebuild b/sci-libs/libsigrokdecode/libsigrokdecode-9999.ebuild
index d4b8425482e3..4ab1fd8f07d5 100644
--- a/sci-libs/libsigrokdecode/libsigrokdecode-9999.ebuild
+++ b/sci-libs/libsigrokdecode/libsigrokdecode-9999.ebuild
@@ -1,13 +1,12 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+inherit python-single-r1
-inherit eutils ltprune python-single-r1
-
-if [[ ${PV} == "9999" ]]; then
+if [[ ${PV} == *9999* ]]; then
EGIT_REPO_URI="git://sigrok.org/${PN}"
inherit git-r3 autotools
else
@@ -15,7 +14,7 @@ else
KEYWORDS="~amd64 ~x86"
fi
-DESCRIPTION="provide (streaming) protocol decoding functionality"
+DESCRIPTION="Provide (streaming) protocol decoding functionality"
HOMEPAGE="https://sigrok.org/wiki/Libsigrokdecode"
LICENSE="GPL-3"
@@ -23,21 +22,23 @@ SLOT="0/9999"
IUSE="static-libs"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-RDEPEND=">=dev-libs/glib-2.34.0
- ${PYTHON_DEPS}"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+RDEPEND="${PYTHON_DEPS}
+ >=dev-libs/glib-2.34.0
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+"
src_prepare() {
- [[ ${PV} == "9999" ]] && eautoreconf
+ default
+ [[ ${PV} == *9999* ]] && eautoreconf
# Only a test program (not installed, and not used by src_test)
# is used by libsigrok, so disable it to avoid the compile.
sed -i \
-e '/build_runtc=/s:yes:no:' \
configure || die
-
- eapply_user
}
src_configure() {
@@ -50,5 +51,5 @@ src_test() {
src_install() {
default
- prune_libtool_files
+ find "${D}" -name '*.la' -type f -delete || die
}