summaryrefslogtreecommitdiff
path: root/sci-libs/libxc/libxc-5.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-29 18:03:51 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-29 18:03:51 +0000
commitd7ed2b01311f15ba54fe8ea872aab7d59ab2b193 (patch)
tree1814dd2b5bbf2e7639fdafbeef48d228cfaf5e9b /sci-libs/libxc/libxc-5.1.0.ebuild
parentabaa75b10f899ada8dd05b23cc03205064394bc6 (diff)
gentoo resync : 29.01.2021
Diffstat (limited to 'sci-libs/libxc/libxc-5.1.0.ebuild')
-rw-r--r--sci-libs/libxc/libxc-5.1.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sci-libs/libxc/libxc-5.1.0.ebuild b/sci-libs/libxc/libxc-5.1.0.ebuild
new file mode 100644
index 000000000000..bade5f34f401
--- /dev/null
+++ b/sci-libs/libxc/libxc-5.1.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools fortran-2
+
+DESCRIPTION="A library of exchange-correlation functionals for use in DFT"
+HOMEPAGE="https://octopus-code.org/wiki/Libxc"
+SRC_URI="https://gitlab.com/libxc/libxc/-/archive/${PV}/${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE="fortran test"
+RESTRICT="!test? ( test )"
+
+pkg_setup() {
+ use fortran && fortran-2_pkg_setup
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-shared \
+ --disable-static \
+ $(use_enable fortran)
+}
+
+src_install() {
+ default
+
+ # no static archives
+ find "${ED}" -name '*.la' -type f -delete || die
+}