summaryrefslogtreecommitdiff
path: root/sci-libs/linux-gpib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-10-07 11:03:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-10-07 11:03:14 +0100
commit957235cf19a691360c720f7913672adda4258ed0 (patch)
tree812bba7928f4293ead05a7ee9c1ac39c5ef9f12e /sci-libs/linux-gpib
parent62f67115b5c46134c34f88f4b1cbdacc19384c0a (diff)
gentoo resync : 07.10.2018
Diffstat (limited to 'sci-libs/linux-gpib')
-rw-r--r--sci-libs/linux-gpib/Manifest2
-rw-r--r--sci-libs/linux-gpib/linux-gpib-4.2.0_rc1.ebuild170
2 files changed, 172 insertions, 0 deletions
diff --git a/sci-libs/linux-gpib/Manifest b/sci-libs/linux-gpib/Manifest
index 13eb931d9d04..073b7e3e5878 100644
--- a/sci-libs/linux-gpib/Manifest
+++ b/sci-libs/linux-gpib/Manifest
@@ -4,5 +4,7 @@ AUX linux-gpib-4.0.3-reallydie.patch 621 BLAKE2B 367ea6a50513b86591e5dfe60df11a4
AUX linux-gpib-4.0.4_rc2-kernel-4.11.0.patch 387 BLAKE2B 38516ea8a9ca5dd3dc32cfd605bd68100726bbcc8d96fa457caabfb91cbc17ce37e61194ac32e573acc797d71c448454d03e6202ec331cb25c056f8ee7b78829 SHA512 6f6b25695ae81671a93e8b86978ea1ef9e71ba5a38d14ad95b9a6aa59704bb2d6a8064c1ac006b1e7c4740d059184d4d4cefef88a2fd0c2a09406f64f6597187
DIST gpib_firmware-2006-11-12.tar.gz 169357 BLAKE2B 05f1be78545e025d76e2b9819a5dcac5a6715dfbb6df5c6fbe8b78900adf8ca7b1c28db350674ff1dd9c77e24507e98b536ca1af8b558c9a46ef8c25034c9769 SHA512 164d6fcfb3af43933f0a16645276f7d527a7aa24ef311f6ae3dcd7f45c41f92c855cf221bc946772f43fc2f9524057abc34bbd7d805c89b33ed7e111bc6870af
DIST linux-gpib-4.1.0.tar.gz 1529480 BLAKE2B b49df07f15d0f91b9d475052993421979d6776ef15aaa9b7e49632db9018f0cbd9ff38d12e2afa9e8027202e450dfc487ac9e2e6ab719086646d983cc41b3482 SHA512 037ed9e484a83caccb15d2d142eef6f1eec356ae972480ca7a676a318d3e9f844fc1911c1b30869b4bb14ef0b4cd10587a803426df9145966bafe22ca7316bd8
+DIST linux-gpib-user-4.2.0_rc1.tar.gz 1098181 BLAKE2B 3f35eacfcffe04598322af6faed921b20b49959433b6e3c3a4bb2c0b9e3f71a2c00a13d7dec6b4e0bc415f1f8635945419805d5c9dec4ddcddb18fc7e8c5e7b4 SHA512 69d8b3059eab8d1d09006b4da13dbf3479c9a9d45e464767a13a2b1d6d32705e91e2800ca79015d302ea05e4fcbddb433dd817d208d751b6af8ac3867b7cee78
EBUILD linux-gpib-4.1.0.ebuild 6110 BLAKE2B 354731c55d29f49b1aaca808c45128f7826b322555d5340fa9fd11481a9ec171bfa8cd365c5329f033e46f49d677c1a2a9f56cb8bc02e911224025de51505563 SHA512 29592c5c05b72e8a4263781636aa9a68b3d4e38743f5c7228a9ed449ab1e877141c5f238789e2942dbaa8c883439086c87321e55a7f8be653b91056b9f677656
+EBUILD linux-gpib-4.2.0_rc1.ebuild 4628 BLAKE2B ed09916953f4230719526614c74432ca5722e9a79ee2c5f87c8114442849dc691d5819a3170d3c786915fe6b0eece4c2ae9f1e1acb014b05c119f0b15d0b0f71 SHA512 f29ff1e34b82dd8bde3934b5d9732efe7352a61a8c48f5d94186c4c9398b7a1319ab1614c8145877e9706eb0780678ea82fb98938c42e36f84a371775c97fdf6
MISC metadata.xml 688 BLAKE2B 405c816eb10feec819da0e5994c2ebe1e73ae4882cecf9f619bf30674b9ff499ae044cca42bad687d97cf3aef2a70eb826d5b07695cbde0c164a00cbac576e0a SHA512 d5af868c802d6c01b8267038cc5bdffc61677403ecb88cdfaf97f31d6b80d1e9318bcd507199d6a850df221cda2baf2869a1de4d732cde75a4aea2ec54f944b8
diff --git a/sci-libs/linux-gpib/linux-gpib-4.2.0_rc1.ebuild b/sci-libs/linux-gpib/linux-gpib-4.2.0_rc1.ebuild
new file mode 100644
index 000000000000..b378c006c710
--- /dev/null
+++ b/sci-libs/linux-gpib/linux-gpib-4.2.0_rc1.ebuild
@@ -0,0 +1,170 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_6 python3_7 )
+
+inherit readme.gentoo-r1 versionator eutils autotools perl-functions python-single-r1 toolchain-funcs udev user
+
+DESCRIPTION="Driver library for GPIB (IEEE 488.2) hardware"
+HOMEPAGE="https://linux-gpib.sourceforge.io/"
+SRC_URI="mirror://sourceforge/linux-gpib/${PN}-user-${PV}.tar.gz
+ firmware? ( https://linux-gpib.sourceforge.io/firmware/gpib_firmware-2006-11-12.tar.gz )
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="pcmcia static guile perl php python tcl doc firmware"
+
+S="${WORKDIR}/${PN}-user-${PV}"
+
+COMMONDEPEND="
+ sys-libs/readline:=
+ tcl? ( dev-lang/tcl:0= )
+ guile? ( dev-scheme/guile:12 )
+ perl? ( dev-lang/perl:= )
+ php? ( dev-lang/php:= )
+ python? ( ${PYTHON_DEPS} )
+ firmware? ( sys-apps/fxload )"
+RDEPEND="${COMMONDEPEND}"
+DEPEND="${COMMONDEPEND}
+ virtual/pkgconfig
+ doc? ( app-text/docbook-sgml-utils )
+ perl? ( virtual/perl-ExtUtils-MakeMaker )"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.2.16-perl.patch
+)
+
+pkg_setup () {
+ use perl && perl_set_version
+ use python && python_setup
+}
+
+src_prepare () {
+ [[ ${I_KNOW_WHAT_I_AM_DOING} == "1" ]] || \
+ die "This ebuild is work in progress. Do not use."
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static) \
+ $(use_enable guile guile-binding) \
+ $(use_enable perl perl-binding) \
+ $(use_enable php php-binding) \
+ $(use_enable python python-binding) \
+ $(use_enable tcl tcl-binding) \
+ $(use_enable doc documentation)
+}
+
+src_compile() {
+ FIRM_DIR=/usr/share/usb
+ emake \
+ DESTDIR="${D}" \
+ INSTALL_MOD_PATH="${D}" \
+ HOTPLUG_USB_CONF_DIR=/etc/hotplug/usb \
+ UDEV_RULES_DIR="$(get_udevdir)"/rules.d \
+ USB_FIRMWARE_DIR="${D}"${FIRM_DIR} \
+ docdir=/usr/share/doc/${PF}/html
+}
+
+src_install() {
+ FIRM_DIR=/usr/share/usb
+ emake \
+ DESTDIR="${D}" \
+ INSTALL_MOD_PATH="${D}" \
+ HOTPLUG_USB_CONF_DIR=/etc/hotplug/usb \
+ UDEV_RULES_DIR="$(get_udevdir)"/rules.d \
+ USB_FIRMWARE_DIR="${D}"${FIRM_DIR} \
+ docdir=/usr/share/doc/${PF}/html install
+
+ if use perl; then
+ einfo "Installing perl module"
+ cd "${S}"/language/perl || die
+ DESTDIR=${D} emake install
+ perl_fix_packlist
+ perl_delete_emptybsdir
+ cd "${S}" || die
+ fi
+
+ echo "KERNEL==\"gpib[0-9]*\", MODE=\"0660\", GROUP=\"gpib\"" >> 99-gpib.rules
+ udev_dorules 99-gpib.rules
+
+ dodoc doc/linux-gpib.pdf ChangeLog AUTHORS README* NEWS
+
+ insinto /etc
+ newins util/templates/gpib.conf gpib.conf
+ newins util/templates/gpib.conf gpib.conf.example
+
+ if use pcmcia; then
+ dodir /etc/pcmcia
+ insinto /etc/pcmcia
+ doins "${S}"/etc/pcmcia/*
+ fi
+
+ # fix rules files
+ local f
+ find "${D}$(get_udevdir)"/rules.d -type f -print0 | while read -rd '' f ; do
+ grep -q "${D}" "${f}" && einfo "File ${f} contains a temporary path, fixing."
+ sed -i -e "s:${D}:/:g" "${f}"
+ done
+
+ DOC_CONTENTS="
+You need to run the 'gpib_config' utility to setup the driver before
+you can use it. In order to do it automatically you can add to your
+start script something like this (supposing the appropriate driver
+is loaded on the startup):
+\n
+ gpib_config --minor 0
+\n
+To give a user access to the computer's gpib board you will have to add
+them to the group 'gpib' or, you could change the permissions on the device
+files /dev/gpib[0-15] to something you like better, using 'chmod'
+\n
+Edit /etc/gpib.conf to match your interface board, and any devices you wish
+to open via ibfind(). See the documentation in /usr/share/linux-gpib/html for
+more information.
+\n
+"
+
+ if use pcmcia; then
+ DOC_CONTENTS+='
+For PCMCIA cards:\n
+All files needed for a PCMCIA board were copied to /etc/pcmcia.
+You may wish to edit the options passed to the gpib_config call in the
+/etc/pcmcia/linux-gpib-pcmcia script.
+You may need to send a SIGHUP signal to the cardmgr daemon to force it
+to reload the files in /etc/pcmcia \(alternatively you could use your
+pcmcia init.d script to restart the cardmgr, or you could just reboot\).
+The driver module will be loaded as needed by the cardmgr.
+
+'
+ fi
+
+ if use firmware; then
+ DOC_CONTENTS+='
+For Agilent \(HP\) 82341C and 82341D cards:
+The firmware for these boards is uploaded by passing the appropriate
+firmware file from /usr/share/linux-gpib/hp_82341 directory to
+gpib_config using the -I or --init-data command line option. Example:\n
+gpib_config --minor 0 --init-data /usr/share/linux-gpib/hp_82341/hp_82341c_fw.bin
+'
+ fi
+
+ readme.gentoo_create_doc
+}
+
+pkg_preinst () {
+ use perl && perl_set_version
+ enewgroup gpib
+}
+
+pkg_postinst () {
+ readme.gentoo_print_elog
+}