summaryrefslogtreecommitdiff
path: root/sci-libs/matio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-07 01:33:16 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-07 01:33:16 +0100
commitc8fd0d84af0bfd1949542adc2cbb735b1d28f9ed (patch)
tree3ee550255947da075650f1a551dcc278f9a1b7f8 /sci-libs/matio
parenta978c074e4272bb901fbe4a10de0a7b2af574f17 (diff)
gentoo resync : 07.05.2021
Diffstat (limited to 'sci-libs/matio')
-rw-r--r--sci-libs/matio/Manifest2
-rw-r--r--sci-libs/matio/matio-1.5.21.ebuild46
2 files changed, 48 insertions, 0 deletions
diff --git a/sci-libs/matio/Manifest b/sci-libs/matio/Manifest
index c7a36d9ebac7..3f2f081eb03d 100644
--- a/sci-libs/matio/Manifest
+++ b/sci-libs/matio/Manifest
@@ -1,3 +1,5 @@
DIST matio-1.5.19.tar.gz 10108869 BLAKE2B db641bda8d68e203af765aa83ecf661e011995e242c4f91aacb4bcc8ba2b545c36a3eec3f4954b3d7ecc286e630acd15b34ec48b372063bfb8b892259fc49ec7 SHA512 c087944a7d87d78a7de662d7e19f5f81c55858cf5bf315c28d5a0f7544555b0816045e20bb0c83752eb3d54b589d9237a27cf3de98e3ebefcc7ea0af9311740e
+DIST matio-1.5.21.tar.gz 10110430 BLAKE2B 1c43d44e69b28eacd9cc672a393df6a55c4ea0e06334eace9058b45bb0bd1582d43cafd30ad121bad33ad29dda52d5259be8c38f6cbacdb05a47da3644dfb984 SHA512 b00bcad807e6a7e10afa656eb77a0e3e9fb08d9cecc3e94ba41ef91ce60367d6686e6d387a874bbb83eb2f895d4a97caac554a70e7f5f6f5cb750052702d411c
EBUILD matio-1.5.19.ebuild 966 BLAKE2B 7bfd290e52e38a2805caad4580b1c5400c2c7ab9df3081347e82a5e055337808a408a16f7395b88d2c7a00cdbeb7cdfaa639bc29ef6b3140c3e74aaafb2ae7c7 SHA512 047f6456e2954383b004cabdf8c4e20684188714fc65e266ca4c9cdcc4375273db6d5e1ee059660a6059752e3d48c5c035d73f0fa6c28debd272c1fe5ae28834
+EBUILD matio-1.5.21.ebuild 966 BLAKE2B 7bfd290e52e38a2805caad4580b1c5400c2c7ab9df3081347e82a5e055337808a408a16f7395b88d2c7a00cdbeb7cdfaa639bc29ef6b3140c3e74aaafb2ae7c7 SHA512 047f6456e2954383b004cabdf8c4e20684188714fc65e266ca4c9cdcc4375273db6d5e1ee059660a6059752e3d48c5c035d73f0fa6c28debd272c1fe5ae28834
MISC metadata.xml 591 BLAKE2B f3e23baf2a3e7bd304987be8296034faf78988c95b4d9fbb9eedc7e8cc6efa0c1479a4ed48ecc10d9b0aee6c92603f4436e8d6b34811b227e86a5f822f47adf3 SHA512 d6f20bbc3bff29f3d163909acb1aa6f3cc6557c5717c3ee9771ef17fbd14fe17836f26c2b2dc4defb4223cdeb5b978ef13c4d4a294a1ac11f0559e2518d58009
diff --git a/sci-libs/matio/matio-1.5.21.ebuild b/sci-libs/matio/matio-1.5.21.ebuild
new file mode 100644
index 000000000000..adb63f7b65e3
--- /dev/null
+++ b/sci-libs/matio/matio-1.5.21.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Library for reading and writing matlab files"
+HOMEPAGE="https://sourceforge.net/projects/matio/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/11" # subslot = soname version
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples hdf5 sparse"
+
+RDEPEND="
+ sys-libs/zlib
+ hdf5? ( sci-libs/hdf5:= )"
+DEPEND="${RDEPEND}"
+BDEPEND="doc? ( virtual/latex-base )"
+
+src_configure() {
+ econf \
+ --disable-static \
+ $(use_enable hdf5 mat73) \
+ $(use_enable sparse extended-sparse)
+}
+
+src_compile() {
+ default
+ use doc && emake -C documentation pdf
+}
+
+src_install() {
+ default
+ use doc && dodoc documentation/matio_user_guide.pdf
+
+ if use examples; then
+ docinto examples
+ dodoc test/test*.c
+ insinto /usr/share/${PN}
+ doins share/test*
+ fi
+
+ # no static archives
+ find "${ED}" -name "*.la" -delete || die
+}