summaryrefslogtreecommitdiff
path: root/sci-libs/mpfi
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-libs/mpfi
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-libs/mpfi')
-rw-r--r--sci-libs/mpfi/Manifest5
-rw-r--r--sci-libs/mpfi/metadata.xml21
-rw-r--r--sci-libs/mpfi/mpfi-1.5.1.ebuild21
3 files changed, 47 insertions, 0 deletions
diff --git a/sci-libs/mpfi/Manifest b/sci-libs/mpfi/Manifest
new file mode 100644
index 000000000000..d2eebd9d5fdf
--- /dev/null
+++ b/sci-libs/mpfi/Manifest
@@ -0,0 +1,5 @@
+DIST mpfi-1.5.1.tar.bz2 365467 SHA256 3fcc6536d117a67fbfbb875ab2d2b3d7fe76cdf0ce85a7e707aae1e89893696e SHA512 498f8b2e114e71c0600f601e4bfef21011e46434d6795e3cd999d38ea9a3d4c66cad2d27e7899629ae422a91b6a776dad2fdbd7c93d51a56f5cfc4ab0e3aeca1 WHIRLPOOL 22116a383cde6048e1ba6626f9e6632ffd8ba48aa9d2387c740a75e827432b7b8163fdbe695014cd5158331c9989ad6271be48027c7b38268c1a064cb64c1c63
+EBUILD mpfi-1.5.1.ebuild 527 SHA256 7370ca2027b281bcb28d4aab363a346e1b4a813d2e62ae51cdee13754e5a5d32 SHA512 64043699a92d35aac4f68111ebace7afea870323728fba414d9eb607cbbcc4cc9c3e8350b496e2e59c88678ec7667ff9e667e99b0ce41ff9c6add0c5afdc7643 WHIRLPOOL 102f1142fa44dda4b3cba8bfc41c9994b6ea40f86a14f69707d044caea762bc87a0d5bcb5e151819e0ab208999daf38c6840870a57ff907de2f667e84b19b623
+MISC ChangeLog 2418 SHA256 fecc49b37aa909958b9a63793f5f14383a8b9856792ce69a9673abdc592618fa SHA512 0f707f5f115266ed0e7369f0d4fcfc901d156038de6fddca5efd285d082677ae21fbd2a260d5238d0b1a892ca97d60df1a33d63ff4afecbfd483c1ec9593a35d WHIRLPOOL 96b3b7788947959057262086a64dc7936dde4d90a55430719d3beb8952f4f63e1d6152918ce9953620383ca82786d207b4e0283bac448b2c887fab8a8c04cade
+MISC ChangeLog-2015 1743 SHA256 1c4a827603f72723ec9cd22c34ae0e95b41343dd32f61fc67e066c1a7568c699 SHA512 9c9c22cb4af6e8412b8d15ec3aafa1e3fa4e975141f238059bb018392f009ecf88b3f88d1d8ce7ea7e5bf48e6f1edf3201d1c4e37a63e0908fc04cb67bf13bcc WHIRLPOOL 42cccc9a33703846f974eb92d72ad61adf497942b25314b5b18acbd11cd84bcc7493f072859b21d049869ad16ddb2f4ac9aeba95d2a02b36b9587f23526063cc
+MISC metadata.xml 1029 SHA256 09a451af17e40e9f8b2f09ebe44d7c2c7b09b6d52725ce3d0366c03c5d6ff0c3 SHA512 870810149f2a547a0db4df6c7997fadfeaee91d0a8a1d456fafba76c7c48e0e59e8a0415a10b46b89bf4930e1880b94d3b6d3f28443dda2bb7ea45a62fa3c8b4 WHIRLPOOL 4ed7a637b3ac5d666b30d1ea60bd04d288a2a4cd5ae8957669c75d9e336bdbc600a2d7fee6c2c1893f0c614bc3d6d9fa36576802fb20568d5637015d997f1e1e
diff --git a/sci-libs/mpfi/metadata.xml b/sci-libs/mpfi/metadata.xml
new file mode 100644
index 000000000000..a0c9c3fcbb0c
--- /dev/null
+++ b/sci-libs/mpfi/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-mathematics@gentoo.org</email>
+ <name>Gentoo Mathematics Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ MPFI is intended to be a portable library written in C for arbitrary
+ precision interval arithmetic with intervals represented using MPFR
+ reliable floating-point numbers. It is based on the GNU MP library
+ and on the MPFR library. The purpose of an arbitrary precision
+ interval arithmetic is on the one hand to get guaranteed results,
+ thanks to interval computation, and on the other hand to obtain
+ accurate results, thanks to multiple precision arithmetic. The MPFI
+ library is built upon MPFR in order to benefit from the correct
+ roundings provided by MPFR. Further advantages of using MPFR are its
+ portability and compliance with the IEEE 754 standard for
+ floating-point arithmetic.
+</longdescription>
+</pkgmetadata>
diff --git a/sci-libs/mpfi/mpfi-1.5.1.ebuild b/sci-libs/mpfi/mpfi-1.5.1.ebuild
new file mode 100644
index 000000000000..b448cb8cde86
--- /dev/null
+++ b/sci-libs/mpfi/mpfi-1.5.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="4"
+
+inherit autotools-utils
+
+PID=30129
+
+DESCRIPTION="Multiple precision interval arithmetic library based on MPFR"
+HOMEPAGE="http://perso.ens-lyon.fr/nathalie.revol/software.html"
+SRC_URI="https://gforge.inria.fr/frs/download.php/${PID}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+DEPEND=">=dev-libs/gmp-4.1.2
+ >=dev-libs/mpfr-2.4"
+RDEPEND="${DEPEND}"