summaryrefslogtreecommitdiff
path: root/sci-libs/netcdf-cxx/netcdf-cxx-4.2-r300.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-libs/netcdf-cxx/netcdf-cxx-4.2-r300.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-libs/netcdf-cxx/netcdf-cxx-4.2-r300.ebuild')
-rw-r--r--sci-libs/netcdf-cxx/netcdf-cxx-4.2-r300.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/sci-libs/netcdf-cxx/netcdf-cxx-4.2-r300.ebuild b/sci-libs/netcdf-cxx/netcdf-cxx-4.2-r300.ebuild
new file mode 100644
index 000000000000..5e1d1c252b1a
--- /dev/null
+++ b/sci-libs/netcdf-cxx/netcdf-cxx-4.2-r300.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit autotools-utils versionator
+
+DESCRIPTION="C++ library for netCDF"
+HOMEPAGE="http://www.unidata.ucar.edu/software/netcdf/"
+SRC_URI="https://www.unidata.ucar.edu/downloads/netcdf/ftp/${P}.tar.gz"
+
+LICENSE="UCAR-Unidata"
+SLOT="3"
+KEYWORDS="amd64 ~arm x86 ~amd64-linux ~x86-linux"
+IUSE="examples static-libs"
+
+RDEPEND=">=sci-libs/netcdf-4.2"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ autotools-utils_src_install
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}