summaryrefslogtreecommitdiff
path: root/sci-libs/o2scl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-libs/o2scl
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-libs/o2scl')
-rw-r--r--sci-libs/o2scl/Manifest3
-rw-r--r--sci-libs/o2scl/metadata.xml22
-rw-r--r--sci-libs/o2scl/o2scl-0.920.ebuild68
3 files changed, 93 insertions, 0 deletions
diff --git a/sci-libs/o2scl/Manifest b/sci-libs/o2scl/Manifest
new file mode 100644
index 000000000000..5f31e2fc79b0
--- /dev/null
+++ b/sci-libs/o2scl/Manifest
@@ -0,0 +1,3 @@
+DIST o2scl-0.920.tar.gz 34498666 SHA256 dd08c0cb0ab13b9d63ae0cc83f026f69076166877a76661aa5059b7cce29e712 SHA512 a80c959b76d15473e206f1caac496607af254f0617f7a18d13bd9732861b6c51f5db8ca3ff6866bb8d0ea70865d4ac94cb972e0a0c158f19034667340341467c WHIRLPOOL 625548dd5c954d2227627f6ae0b04ccb81ba55948e5f0b5a8315b491ef45a2648b62c062aadc5c0689ce2c2c404996132d33f3ad924c1a1e5ed68c95554d40dc
+EBUILD o2scl-0.920.ebuild 1672 SHA256 5cfd99c2e86d20d3adae7e91017349c7871cf3014e56d67dc2d34d251a7d46db SHA512 10469aa3ce9e07a0f614c214e6356ff29206d48d5d7ffb61ca5f53f7d41a985707b980d9fb58329b7806530d4e02de59c40e094dac29a746330daf755d909f27 WHIRLPOOL c83d875e6de7282dbae210e6fffb216549e4fa6d38c39c90fa116809a33fd4b630e3b55085826aa517137b58c8a9de7c4d1486915d02241000c6f905a51ac2e6
+MISC metadata.xml 916 SHA256 3e15f775463e9f1e04352d59e686cb6bcae038021794a0ca3dee6e1e9d3ba6bc SHA512 63f980730302a7c1ecdc6481da44613779115ea67339b8d29d2dd02bc91330994bf09aa6955fb836b7cdc2906ca5c7168ff34c74f94df7854397e87bec279cd3 WHIRLPOOL 76e1755b0504e2cd3d1d479c16f4f8a5d481ac98266cf6e298c697d81f48a7bdd5a13cc24b7ad921deef49d0ede6c68e0656f78639913a7ffb6dadfc9ee93a0a
diff --git a/sci-libs/o2scl/metadata.xml b/sci-libs/o2scl/metadata.xml
new file mode 100644
index 000000000000..12a668d82eb1
--- /dev/null
+++ b/sci-libs/o2scl/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ O2scl is a C++ class library for object-oriented numerical
+ programming. It includes classes based on numerical routines from
+ GSL and CERNLIB and two sub-libraries: thermodynamics of ideal and
+ nearly-ideal particles with quantum statistics and e quations of
+ state for finite density relevant for neutron stars.
+ </longdescription>
+ <use>
+ <flag name="armadillo">Build matrix manipulation with <pkg>sci-libs/armadillo</pkg></flag>
+ <flag name="eigen">Build matrix manipulation with <pkg>dev-cpp/eigen</pkg></flag>
+ </use>
+ <upstream>
+ <remote-id type="github">awsteiner/o2scl</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-libs/o2scl/o2scl-0.920.ebuild b/sci-libs/o2scl/o2scl-0.920.ebuild
new file mode 100644
index 000000000000..bf2fa4a38a83
--- /dev/null
+++ b/sci-libs/o2scl/o2scl-0.920.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic
+
+DESCRIPTION="Object-oriented Scientific Computing Library"
+HOMEPAGE="http://web.utk.edu/~asteine1/o2scl"
+SRC_URI="https://github.com/awsteiner/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="armadillo debug doc examples eigen fftw gsl hdf5 openmp readline static-libs"
+
+RDEPEND="
+ dev-libs/boost:0=
+ >=sci-libs/gsl-2:0=
+ virtual/cblas:=
+ eigen? ( dev-cpp/eigen:3 )
+ armadillo? ( sci-libs/armadillo[lapack] )
+ fftw? ( sci-libs/fftw:3.0= )
+ hdf5? ( sci-libs/hdf5:0= )
+ readline? ( sys-libs/readline:0= )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != binary ]] && use openmp && ! tc-check-openmp; then
+ ewarn "OpenMP is not available in your current selected compiler"
+ die "need openmp capable compiler"
+ fi
+}
+
+src_configure() {
+ use debug || append-cppflags -DO2SCL_NO_RANGE_CHECK
+ econf \
+ --enable-acol \
+ $(use_enable armadillo) \
+ $(use_enable eigen) \
+ $(use_enable fftw) \
+ $(use_enable gsl gsl2) \
+ $(use_enable hdf5 hdf) \
+ $(use_enable hdf5 partlib) \
+ $(use_enable hdf5 eoslib) \
+ $(use_enable openmp) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ use static-libs || prune_libtool_files
+ rm -r "${ED}"/usr/doc || die
+ if use doc; then
+ dodoc -r doc/o2scl/html
+ docompress -x /usr/share/doc/${PF}/html
+ fi
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}