summaryrefslogtreecommitdiff
path: root/sci-libs/oc/oc-2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /sci-libs/oc/oc-2.0.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'sci-libs/oc/oc-2.0.ebuild')
-rw-r--r--sci-libs/oc/oc-2.0.ebuild25
1 files changed, 16 insertions, 9 deletions
diff --git a/sci-libs/oc/oc-2.0.ebuild b/sci-libs/oc/oc-2.0.ebuild
index f44b5451489a..24434e06661f 100644
--- a/sci-libs/oc/oc-2.0.ebuild
+++ b/sci-libs/oc/oc-2.0.ebuild
@@ -1,26 +1,33 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
-inherit autotools-utils
+EAPI=7
DESCRIPTION="Network Data Access Protocol client C library"
HOMEPAGE="http://opendap.org/"
SRC_URI="http://opendap.org/pub/OC/source/${P}.tar.gz"
LICENSE="LGPL-2"
-
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc static-libs"
+IUSE="doc"
+# tests need network
+RESTRICT="test"
RDEPEND="net-misc/curl"
DEPEND="${RDEPEND}"
-# tests need network
-#PROPERTIES=network
+src_configure() {
+ econf --disable-static
+}
src_install() {
- autotools-utils_src_install
- use doc; dodoc docs/oc*html && dohtml docs/html/*
+ if use doc; then
+ dodoc docs/oc*html
+ HTML_DOCS=( docs/html/. )
+ fi
+ default
+
+ # no static archives
+ find "${D}" -name '*.la' -delete || die
}