summaryrefslogtreecommitdiff
path: root/sci-libs/onnx/files/onnx-1.14.0-cxx_14.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-01 16:14:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-01 16:14:02 +0100
commitaef01e7679692cb2cf9eca0c03865cfd0a4e33c9 (patch)
tree4a000095846b696df937b27f28c2483b902028c7 /sci-libs/onnx/files/onnx-1.14.0-cxx_14.patch
parentfbf0c3d1b463bf45fb0e9f119bec3424d6a44a4f (diff)
gentoo auto-resync : 01:09:2023 - 16:14:02
Diffstat (limited to 'sci-libs/onnx/files/onnx-1.14.0-cxx_14.patch')
-rw-r--r--sci-libs/onnx/files/onnx-1.14.0-cxx_14.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/sci-libs/onnx/files/onnx-1.14.0-cxx_14.patch b/sci-libs/onnx/files/onnx-1.14.0-cxx_14.patch
new file mode 100644
index 000000000000..239e0bd3a56a
--- /dev/null
+++ b/sci-libs/onnx/files/onnx-1.14.0-cxx_14.patch
@@ -0,0 +1,11 @@
+--- a/CMakeLists.txt 2023-09-01 12:19:40.772172388 +0200
++++ b/CMakeLists.txt 2023-09-01 12:19:53.422188861 +0200
+@@ -58,7 +58,7 @@
+ # Required to use /std:c++17 or higher on Windows
+ # For other platforms, set C++11 as standard for the whole project
+ if(NOT MSVC)
+- set(CMAKE_CXX_STANDARD 11)
++ set(CMAKE_CXX_STANDARD 14)
+ else()
+ string(APPEND CMAKE_CXX_FLAGS " /std:c++17")
+ endif()