summaryrefslogtreecommitdiff
path: root/sci-libs/pyshp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-15 12:04:03 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-15 12:04:03 +0100
commit7fa8a1e3f149eea4c844c47cfe26136ed7614c58 (patch)
treee514d1b9999d088064bee1e34a3a3c500d6d7a07 /sci-libs/pyshp
parentd993571e2ee444d08f4e9e90d493ee37338657e3 (diff)
gentoo auto-resync : 15:04:2024 - 12:04:02
Diffstat (limited to 'sci-libs/pyshp')
-rw-r--r--sci-libs/pyshp/Manifest1
-rw-r--r--sci-libs/pyshp/pyshp-2.3.1-r2.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/sci-libs/pyshp/Manifest b/sci-libs/pyshp/Manifest
index 2a5ac3c83e34..339bc9656a49 100644
--- a/sci-libs/pyshp/Manifest
+++ b/sci-libs/pyshp/Manifest
@@ -1,3 +1,4 @@
DIST pyshp-2.3.1..gh.tar.gz 2213685 BLAKE2B ca5b87dec442508bc4a0612982984ba0fb91aa8acffddb6a448c43ccf42285305600a5e28e1fb781a3d94e8ce0624d027642fddcc5f2176dca3df095e59df170 SHA512 08844492b8d1d824c639844f7f314909d946bd4d3703a4f8d4cb64d400729671b42ff5b0f80aa68d9469f3939a3c7619ba13c9efdcba3b244ec01d7be3a371c5
EBUILD pyshp-2.3.1-r1.ebuild 777 BLAKE2B 59870ff54c0a4a3b8ace5ca05ff0225fdbfb6d9cb1cacee8d3b7759a92099fb4dfd1fdc2a62bd7d53e47bfb481ba4f9df996ed99298ecbcecca0fd3292f91e6f SHA512 5f47eb6e8138c64c6b4ccac8288d01216c7180fdefd486a8c4be2e30327b21af8f56806f01baec58bc23668a3c13056c7d5549d8a9f3473224133a4f28b470cd
+EBUILD pyshp-2.3.1-r2.ebuild 766 BLAKE2B c14fa6ee82cb0649abb28ffacc950263e10e16e42a0ee32096938eb3169fd1ebe55383fc6a3b8304d26a14d4d3602d6b1b494a7c6cd3648b2f1b1dea822f723f SHA512 1eae298a56f3c3c1f01e30e3dfc6860b1b461a73a33af8c2b5e2696576a4cbcbfed271e406cab0608777bb834af0814fd0af6ac1bbe63ab61536d53f09df1db5
MISC metadata.xml 392 BLAKE2B d0502636f7a083b4eca21dd9c9cb2604d96ec91616c88566f42687e53be965090683984d3289ae332c94309e89b25f39a12b601467abec718365d53f423fe21d SHA512 b3914985e7b8857a7f0841d4e987746f64a571a83ed3a237621c048e073c1f5a77512c40011ee1808c3ffadff08c03adc53ffe767e8a5f35c628882df779b771
diff --git a/sci-libs/pyshp/pyshp-2.3.1-r2.ebuild b/sci-libs/pyshp/pyshp-2.3.1-r2.ebuild
new file mode 100644
index 000000000000..18fbf87fe491
--- /dev/null
+++ b/sci-libs/pyshp/pyshp-2.3.1-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+PYTHON_COMPAT=( python3_{9..12} )
+
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Pure Python read/write support for ESRI Shapefile format"
+HOMEPAGE="https://pypi.org/project/pyshp/"
+# pypi tarballs are missing test data
+#SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/GeospatialPython/${PN}/archive/${PV}.tar.gz -> ${P}..gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ epytest test_shapefile.py -m "not network" || die
+}