summaryrefslogtreecommitdiff
path: root/sci-libs/rocBLAS/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /sci-libs/rocBLAS/files
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'sci-libs/rocBLAS/files')
-rw-r--r--sci-libs/rocBLAS/files/rocBLAS-5.0.2-change-default-Tensile-library-dir.patch47
-rw-r--r--sci-libs/rocBLAS/files/rocBLAS-5.0.2-cpp_lib_filesystem.patch50
-rw-r--r--sci-libs/rocBLAS/files/rocBLAS-5.0.2-unbundle-Tensile.patch25
3 files changed, 122 insertions, 0 deletions
diff --git a/sci-libs/rocBLAS/files/rocBLAS-5.0.2-change-default-Tensile-library-dir.patch b/sci-libs/rocBLAS/files/rocBLAS-5.0.2-change-default-Tensile-library-dir.patch
new file mode 100644
index 000000000000..618847b8fb8d
--- /dev/null
+++ b/sci-libs/rocBLAS/files/rocBLAS-5.0.2-change-default-Tensile-library-dir.patch
@@ -0,0 +1,47 @@
+change the default rocm tensile library search path
+Index: rocBLAS-rocm-5.0.1/library/src/tensile_host.cpp
+===================================================================
+--- rocBLAS-rocm-5.0.1.orig/library/src/tensile_host.cpp
++++ rocBLAS-rocm-5.0.1/library/src/tensile_host.cpp
+@@ -558,40 +558,8 @@ namespace
+ // Find the location of librocblas.dll/.so
+ // Fall back on hard-coded path if static library or not found
+
+-#ifndef ROCBLAS_STATIC_LIB
+-#ifdef WIN32
+- // wchar_t wpath[MAX_PATH + 1] = {0};
+- // if(GetModuleFileNameW(GetModuleHandle("rocblas.dll"), wpath, MAX_PATH + 1))
+- // {
+- // std::wstring wspath(wpath);
+- // std::string tmp(wspath.begin(), wspath.end());
+
+- std::vector<TCHAR> dll_path(MAX_PATH + 1);
+- if(GetModuleFileNameA(
+- GetModuleHandleA("rocblas.dll"), dll_path.data(), MAX_PATH + 1))
+- {
+- std::string tmp(dll_path.begin(), dll_path.end());
+- std::filesystem::path exepath = tmp;
+- if(exepath.has_filename())
+- {
+- path = exepath.remove_filename().string();
+- }
+- }
+-#else
+- dl_iterate_phdr(rocblas_dl_iterate_phdr_callback, NULL);
+- if(rocblas_so_path.size())
+- path = std::string{dirname(&rocblas_so_path[0])};
+-#endif
+-#endif // ifndef ROCBLAS_STATIC_LIB
+-
+- // Find the location of the libraries
+- if(TestPath(path + "/../../Tensile/library"))
+- path += "/../../Tensile/library";
+- else
+- path += "/library";
+-
+- if(TestPath(path + "/" + processor))
+- path += "/" + processor;
++ path="@GENTOO_PORTAGE_EPREFIX@/usr/lib64/rocblas/library";
+ }
+
+ // only load modules for the current architecture
diff --git a/sci-libs/rocBLAS/files/rocBLAS-5.0.2-cpp_lib_filesystem.patch b/sci-libs/rocBLAS/files/rocBLAS-5.0.2-cpp_lib_filesystem.patch
new file mode 100644
index 000000000000..500abbacfdc2
--- /dev/null
+++ b/sci-libs/rocBLAS/files/rocBLAS-5.0.2-cpp_lib_filesystem.patch
@@ -0,0 +1,50 @@
+--- b/clients/common/utility.cpp 2022-01-26 03:31:42.000000000 +0800
++++ a/clients/common/utility.cpp 2022-02-22 18:45:35.319732953 +0800
+@@ -23,6 +23,7 @@
+ #include <fcntl.h>
+ #endif
+
++#include <version>
+ #ifdef __cpp_lib_filesystem
+ #include <filesystem>
+ #else
+--- b/clients/include/rocblas_data.hpp 2022-01-26 03:31:42.000000000 +0800
++++ a/clients/include/rocblas_data.hpp 2022-02-22 18:44:51.275733070 +0800
+@@ -17,6 +17,7 @@
+ #include <string>
+ #include <utility>
+
++#include<version>
+ #ifdef __cpp_lib_filesystem
+ #include <filesystem>
+ #else
+--- b/clients/include/singletons.hpp 2022-01-26 03:31:42.000000000 +0800
++++ a/clients/include/singletons.hpp 2022-02-22 18:47:55.139732583 +0800
+@@ -3,6 +3,6 @@
+ * ************************************************************************ */
+
+ // global for device memory padding see d_vector.hpp
++#include<cstddef>
+-
+ extern size_t g_DVEC_PAD;
+ void d_vector_set_pad_length(size_t pad);
+--- b/clients/include/testing_logging.hpp 2022-01-26 03:31:42.000000000 +0800
++++ a/clients/include/testing_logging.hpp 2022-02-22 18:44:13.115733171 +0800
+@@ -22,6 +22,7 @@
+ #include <unistd.h>
+ #endif
+
++#include<version>
+ #ifdef __cpp_lib_filesystem
+ #include <filesystem>
+ #else
+--- b/clients/include/testing_ostream_threadsafety.hpp 2022-01-26 03:31:42.000000000 +0800
++++ a/clients/include/testing_ostream_threadsafety.hpp 2022-02-22 18:45:19.055732996 +0800
+@@ -30,6 +30,7 @@
+ #include <sys/types.h>
+ #endif
+
++#include <version>
+ #ifdef __cpp_lib_filesystem
+ #include <filesystem>
+ #else
diff --git a/sci-libs/rocBLAS/files/rocBLAS-5.0.2-unbundle-Tensile.patch b/sci-libs/rocBLAS/files/rocBLAS-5.0.2-unbundle-Tensile.patch
new file mode 100644
index 000000000000..75f673f63d47
--- /dev/null
+++ b/sci-libs/rocBLAS/files/rocBLAS-5.0.2-unbundle-Tensile.patch
@@ -0,0 +1,25 @@
+Index: rocBLAS-rocm-5.0.2/CMakeLists.txt
+===================================================================
+--- rocBLAS-rocm-5.0.2.orig/CMakeLists.txt
++++ rocBLAS-rocm-5.0.2/CMakeLists.txt
+@@ -271,20 +271,6 @@ if(NOT SKIP_LIBRARY)
+ set( Tensile_ROOT "${CMAKE_BINARY_DIR}/virtualenv/Lib/site-packages/Tensile" )
+ endif()
+
+- include(virtualenv)
+- if (Tensile_TEST_LOCAL_PATH)
+- virtualenv_install(${Tensile_TEST_LOCAL_PATH})
+- message (STATUS "using local Tensile from ${Tensile_TEST_LOCAL_PATH}, copied to ${Tensile_ROOT}")
+- else()
+- # Use the virtual-env setup and download package from specified repot:
+- set( tensile_fork "ROCmSoftwarePlatform" CACHE STRING "Tensile fork to use" )
+- file (STRINGS "tensile_tag.txt" read_tensile_tag)
+- set( tensile_tag ${read_tensile_tag} CACHE STRING "Tensile tag to download" )
+- virtualenv_install("git+https://github.com/${tensile_fork}/Tensile.git@${tensile_tag}")
+- message (STATUS "using GIT Tensile fork=${tensile_fork} from branch=${tensile_tag}")
+- endif()
+- message(STATUS "Adding ${VIRTUALENV_HOME_DIR} to CMAKE_PREFIX_PATH")
+- list(APPEND CMAKE_PREFIX_PATH ${VIRTUALENV_HOME_DIR})
+ if (TENSILE_VERSION)
+ find_package(Tensile ${TENSILE_VERSION} EXACT REQUIRED HIP LLVM OpenMP PATHS "${INSTALLED_TENSILE_PATH}")
+ else()