summaryrefslogtreecommitdiff
path: root/sci-libs/rocSPARSE/rocSPARSE-5.0.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /sci-libs/rocSPARSE/rocSPARSE-5.0.2.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'sci-libs/rocSPARSE/rocSPARSE-5.0.2.ebuild')
-rw-r--r--sci-libs/rocSPARSE/rocSPARSE-5.0.2.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/sci-libs/rocSPARSE/rocSPARSE-5.0.2.ebuild b/sci-libs/rocSPARSE/rocSPARSE-5.0.2.ebuild
index 4203ba70e4de..90733f9a5e59 100644
--- a/sci-libs/rocSPARSE/rocSPARSE-5.0.2.ebuild
+++ b/sci-libs/rocSPARSE/rocSPARSE-5.0.2.ebuild
@@ -59,7 +59,8 @@ RESTRICT="!test? ( test )"
S="${WORKDIR}/rocSPARSE-rocm-${PV}"
PATCHES=( "${FILESDIR}/${PN}-5.0.2-remove-matrices-unpacking.patch"
- "${FILESDIR}/${PN}-5.0.2-enable-gfx1031.patch" )
+ "${FILESDIR}/${PN}-5.0.2-enable-gfx1031.patch"
+ "${FILESDIR}/${PN}-5.0.2-remove-incorrect-assert.patch" )
python_check_deps() {
if use test; then
@@ -81,6 +82,8 @@ src_prepare() {
# use python interpreter specifyied by python-any-r1
sed -e "/COMMAND ..\/common\/rocsparse_gentest.py/s,COMMAND ,COMMAND ${EPYTHON} ," -i clients/tests/CMakeLists.txt || die
+ cmake_src_prepare
+
# Test need download data from https://sparse.tamu.edu (or other mirror site), check MD5, unpack and convert them into csr format
# This process is handled default by ${S}/cmake/ClientMatrices.cmake, but should be the responsibility of portage.
if use test; then
@@ -89,7 +92,7 @@ src_prepare() {
ebegin "$(tc-getCXX) deps/convert.cpp -o deps/convert"
$(tc-getCXX) deps/convert.cpp -o deps/convert
eend $?
- find "${WORKDIR}" -maxdepth 2 -regextype egrep -regex ".*/(.*)/\1\.mtx" -print0 |
+ find "${WORKDIR}" -maxdepth 2 -regextype grep -E -regex ".*/(.*)/\1\.mtx" -print0 |
while IFS= read -r -d '' mtxfile; do
destination=${BUILD_DIR}/clients/matrices/$(basename -s '.mtx' ${mtxfile}).csr
ebegin "Converting ${mtxfile} to ${destination}"
@@ -97,8 +100,6 @@ src_prepare() {
eend $?
done
fi
-
- cmake_src_prepare
}
src_configure() {
@@ -125,7 +126,7 @@ src_test() {
addwrite /dev/kfd
addwrite /dev/dri/
cd "${BUILD_DIR}/clients/staging" || die
- ./rocsparse-test || die
+ LD_LIBRARY_PATH="${BUILD_DIR}/library" ./rocsparse-test || die
}
src_install() {