summaryrefslogtreecommitdiff
path: root/sci-libs/scipy-python2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /sci-libs/scipy-python2
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'sci-libs/scipy-python2')
-rw-r--r--sci-libs/scipy-python2/Manifest2
-rw-r--r--sci-libs/scipy-python2/scipy-python2-1.2.3.ebuild129
2 files changed, 131 insertions, 0 deletions
diff --git a/sci-libs/scipy-python2/Manifest b/sci-libs/scipy-python2/Manifest
index abf28d3aafa4..fbaf34f82f5c 100644
--- a/sci-libs/scipy-python2/Manifest
+++ b/sci-libs/scipy-python2/Manifest
@@ -1,3 +1,5 @@
DIST scipy-1.1.0.tar.gz 15583560 BLAKE2B 477753e622ee26a3bc8c2cb6829410152df84b29ce17a6d53a66348f5536f7993fedf5d32b782405b54b3af3feabf9bc91c381ed39546076849c2fdb71039404 SHA512 72fe32c6c009613cb78202598e5db14f8e630b3218839cfe18d43d40550d94cc5aa100c6f5d41f40e86ae148e9b6a13431bb91b0f9be44b0569ccd7b725fe973
+DIST scipy-1.2.3.tar.gz 23335997 BLAKE2B 183a0e8266a6fa08ca4fa05511d28f51a5ff9b3e8d00c24a355d2db00327eb973befbefbcf47cb288aafd60718db903ac29f775f519484a7c6d0919693c0a21f SHA512 d7739fa2f25689fc14ddf09477207c990b39b593a85f5c74687df1ffe097f6eee1bb2123aaa286189309f6d3b25cdd7757053d8b1008d1d6b3367a8e3a0a53b1
EBUILD scipy-python2-1.1.0.ebuild 3628 BLAKE2B c4fc9703dd9ca163fe298bb3d1d37c72ed7a0bd0b559029cbe988b91b2f705df438d5a8f3fc2e7a78975c93d8cdefc35cf05abfead68177a391e8ff2f0e16ea4 SHA512 dcacd321b5828901290078a4e41618d19d21a6253ee0d8db6c73c247477f31343b8a3c86e9f2098f04abc70f2bc27772b2e41d09722d2d5631cc7f9595d40395
+EBUILD scipy-python2-1.2.3.ebuild 3645 BLAKE2B 1046f2e2bf1fc8ca276706c50f7043ee83d105a384f6b473bf649d738a4f6201ccd719756d4bc77a91b8afb56cde1414a0c14e9640f7b6d8e497bf294a9fcf9d SHA512 2c629e5b399e8a86b15f0b12b1657c5e3cc362a79415ae75f20ba037f36037b39ebcfb3531fc7d3206bae060c7be82954d04fa3b96e8c7f3291dc4cbbc354d7b
MISC metadata.xml 945 BLAKE2B 52bc24aea94ec233940c12969222f7ad3c8b9760b08a608bf6dc6d320b4a519a27103c2f11d720490c933f90a31fe3fb503694bd067136975617c50efa3c5d47 SHA512 7ab95c274799a7852968c63ca6f05c302d4e478d9e195980859b960ec2f2b1146c1c12674d737f324101383155387429ec1c05f779888819503feebf1e38e6c4
diff --git a/sci-libs/scipy-python2/scipy-python2-1.2.3.ebuild b/sci-libs/scipy-python2/scipy-python2-1.2.3.ebuild
new file mode 100644
index 000000000000..05b35f960a41
--- /dev/null
+++ b/sci-libs/scipy-python2/scipy-python2-1.2.3.ebuild
@@ -0,0 +1,129 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit fortran-2 distutils-r1 flag-o-matic multiprocessing toolchain-funcs
+
+MY_PN=${PN/-python2}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Scientific algorithms library for Python (py2 version)"
+HOMEPAGE="https://www.scipy.org/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD LGPL-2"
+SLOT="0"
+IUSE="sparse test"
+RESTRICT="!test? ( test )"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+
+CDEPEND="
+ || (
+ >=dev-python/numpy-python2-1.10[lapack,${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.10[lapack,${PYTHON_USEDEP}]
+ )
+ sci-libs/arpack:0=
+ virtual/cblas
+ virtual/lapack
+ sparse? ( sci-libs/umfpack:0= )"
+DEPEND="${CDEPEND}
+ dev-lang/swig
+ >=dev-python/cython-0.22[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-36[${PYTHON_USEDEP}]
+ virtual/pkgconfig
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+RDEPEND="${CDEPEND}
+ !<sci-libs/scipy-1.4
+ dev-python/pillow[${PYTHON_USEDEP}]"
+
+DOCS=( HACKING.rst.txt THANKS.txt )
+
+DISTUTILS_IN_SOURCE_BUILD=1
+
+pc_incdir() {
+ $(tc-getPKG_CONFIG) --cflags-only-I $@ | \
+ sed -e 's/^-I//' -e 's/[ ]*-I/:/g' -e 's/[ ]*$//' -e 's|^:||'
+}
+
+pc_libdir() {
+ $(tc-getPKG_CONFIG) --libs-only-L $@ | \
+ sed -e 's/^-L//' -e 's/[ ]*-L/:/g' -e 's/[ ]*$//' -e 's|^:||'
+}
+
+pc_libs() {
+ $(tc-getPKG_CONFIG) --libs-only-l $@ | \
+ sed -e 's/[ ]-l*\(pthread\|m\)\([ ]\|$\)//g' \
+ -e 's/^-l//' -e 's/[ ]*-l/,/g' -e 's/[ ]*$//' \
+ | tr ',' '\n' | sort -u | tr '\n' ',' | sed -e 's|,$||'
+}
+
+python_prepare_all() {
+ # scipy automatically detects libraries by default
+ export {FFTW,FFTW3,UMFPACK}=None
+ use sparse && unset UMFPACK
+ # the missing symbols are in -lpythonX.Y, but since the version can
+ # differ, we just introduce the same scaryness as on Linux/ELF
+ [[ ${CHOST} == *-darwin* ]] \
+ && append-ldflags -bundle "-undefined dynamic_lookup" \
+ || append-ldflags -shared
+ [[ -z ${FC} ]] && export FC="$(tc-getFC)"
+ # hack to force F77 to be FC until bug #278772 is fixed
+ [[ -z ${F77} ]] && export F77="$(tc-getFC)"
+ export F90="${FC}"
+ export SCIPY_FCONFIG="config_fc --noopt --noarch"
+ append-fflags -fPIC
+
+ local libdir="${EPREFIX}"/usr/$(get_libdir)
+ cat >> site.cfg <<-EOF || die
+ [blas]
+ include_dirs = $(pc_incdir cblas)
+ library_dirs = $(pc_libdir cblas blas):${libdir}
+ blas_libs = $(pc_libs cblas blas)
+ [lapack]
+ library_dirs = $(pc_libdir lapack):${libdir}
+ lapack_libs = $(pc_libs lapack)
+ EOF
+
+ # Drop hashes to force rebuild of cython based .c code
+ rm cythonize.dat || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ # FIXME: parallel python building fails, bug #614464
+ ${EPYTHON} tools/cythonize.py || die
+ distutils-r1_python_compile \
+ ${SCIPY_FCONFIG}
+}
+
+python_test() {
+ # fails with bdist_egg. should it be fixed in distutils-r1 eclass?
+ distutils_install_for_testing ${SCIPY_FCONFIG}
+ cd "${TEST_DIR}" || die "no ${TEST_DIR} available"
+ "${PYTHON}" -c \
+ 'import numpy as np; print("relaxed strides checking:", np.ones((10,1),order="C").flags.f_contiguous)' \
+ || die
+ "${EPYTHON}" -c \
+ "import scipy, sys; r = scipy.test('fast', verbose=2); sys.exit(r)" \
+ || die "Tests fail with ${EPYTHON}"
+}
+
+python_install() {
+ distutils-r1_python_install ${SCIPY_FCONFIG}
+ python_optimize
+}
+
+pkg_postinst() {
+ elog "You might want to set the variable SCIPY_PIL_IMAGE_VIEWER"
+ elog "to your prefered image viewer. Example:"
+ elog "\t echo \"export SCIPY_PIL_IMAGE_VIEWER=display\" >> ~/.bashrc"
+}