summaryrefslogtreecommitdiff
path: root/sci-libs/sundials
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /sci-libs/sundials
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'sci-libs/sundials')
-rw-r--r--sci-libs/sundials/Manifest2
-rw-r--r--sci-libs/sundials/sundials-5.2.0.ebuild11
2 files changed, 10 insertions, 3 deletions
diff --git a/sci-libs/sundials/Manifest b/sci-libs/sundials/Manifest
index 36b6cd67110e..ddbf24376d15 100644
--- a/sci-libs/sundials/Manifest
+++ b/sci-libs/sundials/Manifest
@@ -3,5 +3,5 @@ AUX sundials-5.2.0-fix-license-install-path.patch 468 BLAKE2B e2c9963f3c528cbe84
DIST sundials-3.2.1.tar.gz 14958699 BLAKE2B ecc4b454ec589e9177acc9375e1db370ad6281f8d29580d9558ad3146dbbaab52794013e9cb56ad83f7309dbd3084a1ccaf6972c6b1468cefcc86bf30d3a460c SHA512 1f3e4b12f368e4f50c38b970c012f1702e339319ee0a858661bdf83e5739bb5b8a36f98b82e2ef76d1ce8a473123046347ee1b44f3cb685509823864f0af1384
DIST sundials-5.2.0.tar.gz 18639221 BLAKE2B c10e6deb5839993b8601347be94412d0b0c058084b4dc0d380681f7b4debd535f9736c2ef734e9fd84c6ddc190ab05f46abcb711225ec1f156a18d8edb6317fb SHA512 99163a104e436dab4779c77519502b5614b65d726324b29b14236315f6916beb5863fcd56b5acf19f62985c033b227fba1ebd3d3c4607ce991d94ee7739bb55f
EBUILD sundials-3.2.1.ebuild 2122 BLAKE2B 14b9cb8eaef1bb2a8dd749a5be242f7a026a040d316828aee9f6aab481df29fb5102862bacfbe7fd83c4ba74b10f633b3e76a754dcb2eccf7ae7d634d1886ff6 SHA512 e076b7de37302cd96f6c4b01931e02d4627b69514c69b1a8275373ac11196a6b19602a96f56c1be527ee1ed501dd4fd0df2517bda45d9721f15a6ba05e3fe606
-EBUILD sundials-5.2.0.ebuild 2090 BLAKE2B a02305f8d4c2cd72d2bac2cbceb687f3b87e5067cfc06cd6501d83da25e51081c95dabd4831bff0b16010298eb66f042cc0602307071e0c31b5ddd802fc515de SHA512 ace0de38a616892fa1dc9d91ec7dbd37a2278d7418345f4e7bdb61f455ca79a83e1e4a4c8dcea832cd7e1877590a02faf24f210e1369ce810a16f80904116cf8
+EBUILD sundials-5.2.0.ebuild 2181 BLAKE2B 105f2ddbd0d5ac00d4bce9a7b797eb8ea6cb9ee34f53db9a5e311cb2a8e1c6ce07f1c148f709db7dc08fdca506be63603dc81f84e28f879d5f4f764fa05d86f4 SHA512 a55f211ab31db02a3a43e3a2d0b8c6ed05a9a3f8fc91039c2b3f531d1ea87a9d80342d9a06819dec430db43f7bc240d9b53a61d63eb39c9c26ea1b00ee2b0e10
MISC metadata.xml 1059 BLAKE2B 48ccadfac9b7ea4203334ffdadaa76ab3164273835c727e76085db3a5afc179404eb21c74aad77ceb368397377afb0efa27d798c849eab2ffc35153cd4fe7588 SHA512 47da8b9edc993c480a045642ad2746ff6180e54e1ad368823fd81b0d217e72c31394d7575cb4c2d5e5cfea065dffb01751bc8b1088f0f1a6feaaea15c2c7fb8f
diff --git a/sci-libs/sundials/sundials-5.2.0.ebuild b/sci-libs/sundials/sundials-5.2.0.ebuild
index aa14eeb5320d..3d60a524cc2c 100644
--- a/sci-libs/sundials/sundials-5.2.0.ebuild
+++ b/sci-libs/sundials/sundials-5.2.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -8,7 +8,7 @@ FORTRAN_NEEDED=fortran
FORTRAN_STANDARD="77 90"
# if FFLAGS and FCFLAGS are set then should be equal
-inherit cmake fortran-2 toolchain-funcs
+inherit cmake fortran-2 toolchain-funcs flag-o-matic
DESCRIPTION="Suite of nonlinear solvers"
HOMEPAGE="https://computation.llnl.gov/projects/sundials"
@@ -38,6 +38,13 @@ pkg_setup() {
fi
}
+src_prepare() {
+ # bug #707240
+ append-cflags -fcommon
+
+ cmake_src_prepare
+}
+
src_configure() {
mycmakeargs+=(
-DBUILD_SHARED_LIBS=ON